DodgeTalk Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
My truck stalled and died today after breaking for a red light after reaching freeway speeds starts back up just fine but loses rpm and stalls out anyone else have this problem?
 

·
Registered
Joined
·
2,138 Posts
Give us some more information on your truck please: year, engine, drivetrain, etc. It will help people diagnose your problem.

I can assume you have an auto trans? I would first make sure the Idle Air Control module is clean and working properly. Next would be the trans torque converter if it is not unlocking as you brake? Just some thoughts here. It all depends how mechanical you are and what research you can do. You can search here but honestly it is faster through google. Add "dodgetalk" to your search and google will find answers quicker.

I wish you luck and hope someone who has more knowledge of this can help. I have a manual trans and it happened once when my IAC was dirty. Believe it or not, injector cleaner also helps idle when decelerating, at least for my truck.

Welcome to Dodgetalk! :gr_patrio
 

·
Registered
Joined
·
1,986 Posts
I would check and clean the all the battery connections, both ends of cables. I could be bad contacts. This is the first thing I do when ever I start to have electrical issues, my truck does not like bad connections.
 

·
Registered
Joined
·
5,152 Posts
Give us some more information on your truck please: year, engine, drivetrain, etc. It will help people diagnose your problem.
X2! Need more info. How old is the battery? Is this the first time it happened? How many miles on the truck? Any codes?(check engine light)
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
It's a 1999 dodge ram 1500 V6 automatic transmission. It has 134,000 miles on it. Yes this is the first time it did this. I did Just recently as in a week ago have the negative cable on the battery replaced as it had a loose and old connection and dodge had it for a couple days cause it died on me and wouldn't start back up they replaced the ignition coil. Everything was running fine and great after that then when I went to brake it stalled and died always starts right back up and sometimes doesn't fully die but loses rpm. The check engine light does flash on and off while its doing this but once you get going its not on.
 

·
Registered
Joined
·
2,138 Posts
Re-check the battery connections and tighten them. I had a car do that to me when I came to a stop. Luckily, it was right by a mechanic and he just tightened the connections. I had unhooked the battery for something recently and hadn't tightened them enough. Start there.
 

·
Registered
Joined
·
22 Posts
If you have not have not solved this issue, try a simple check, the brake power booster may have a leak inside of it, follow the hose and plug it off after disconnecting it from the booster. Also while in park push brakes and see if it cuts out or lowers rpm. If it does the booster could be the cause.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
Still haven't solved the problem :( had a
Mechanic look at it this weekend checked my torque converter, and my idle control module and that was all ok. He thought it was my throttle said it was pretty dirty and cleaned it up but today did the same thing I was behind someone and had to break more than usual and lost rpm and stalled was able to get off the road although it was hard to steer placed it in park and it started right back up. Ill have to look into the power booster
 

·
Registered
Joined
·
803 Posts
do you run your truck on the highway at all? If you don't I suggest you get on the highway and floor it to clean everything out good. I mean floor it then back off then floor it again. That really helps blow out the whole system whether it be in the fuel system or the exhaust. When my mom putted around town for 6 months in my truck it was throwing cat codes and stalling out similar to what you are explaining. Once I got it back and fixed the brake line that broke on me I did some cleaning and it has not stalled since I cleaned the system real good.
 

·
Registered
Joined
·
5,152 Posts
Still haven't solved the problem had a
Mechanic look at it this weekend checked my torque converter, and my idle control module and that was all ok. He thought it was my throttle said it was pretty dirty and cleaned it up but today did the same thing I was behind someone and had to break more than usual and lost rpm and stalled was able to get off the road although it was hard to steer placed it in park and it started right back up. Ill have to look into the power booster
What's the torque converter have to do with the idle? "idle control module" HUH. Do you mean IAC idle air control? How did he check it? It either works or it doesn't. A lot of carbon in the throttle body can cause the idle ports to get clogged up. It wouldn't hurt to pull the tb off and thoroughly clean it. And for the third time, How old is the battery??? A weak battery can cause idle issues. Have you had it load tested? Is your check engine light on? If so what codes?
 

·
Registered
Joined
·
402 Posts
Torque converter can affect idle. If the tranny is low on fluid the t.c. can stay in lockup mode and will stall at idle.
 

·
Registered MOPAR User
Joined
·
9,350 Posts
Another direction is the trans itself, like said above. Check the fluid level.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #14
Sorry my bad didn't give EXACT words for things the transmission fluid is
Fine. I do take the truck on the highway every now and again. When the truck stalls and dies the check engine light flashes on then right back off so haven't been able to pull a code :( it's just really weird cause it drives around fine all day and once or twice it just looses power rpm go down power steering doesn't work and stalls out I put it in park and it starts right back up.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top