DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, yes I am new but not to Dodge's, we have a 1998 Dodge Ram 1500 quad cab 4x4 short box, 5.2L Autofagot. We bought it brand new with 46 miles on it from test drives. The truck was fine for a while (1-2 years) then the trans started to poop, my dad did a service and last I know did nothing. Then the truck started to rust out quicker than his 69 Roadrunner. We have brought it to electrical somewhere because we can unplug connectors from the trans and it will be fine for a few miles. We put a Trans computer from another ram in it and it made a difference but the O/D off light came on. Now the truck is figgety, loves 1st gear when it used to hate it, when she finally decides for 2nd which is only at 35+ (when it wants to shift) sometimes it's not sure if it wants 1st or 2nd so it goes back and forth. It does still have overdrive and it works because it will go into O/D and then you can push the O/D button and it will come out. Also anything 35 or less and it says F! You I'm staying in 1st.


Any help would be appreciated before I start looking for 5spd swap to get out of this B/S Auto crap...... or having to replace the trans but damaging it...
 

·
Transmission Man!
Joined
·
3,508 Posts
You need to "scan" it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Well we have a code reader and we get Torque converter something.... all electrical code's but don't know where the problem would most likely be.
 

·
Transmission Man!
Joined
·
3,508 Posts
That doesn't help us help you much. :huh:

Oh ....and welcome to Dodge Talk! :dtrocks:
 

·
I R SMRAT.
Joined
·
1,622 Posts
Post up the codes from the scanner ("P0xxx") so that we can better help you.

And welcome!
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top