DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Electrical Problem- Radio does not work or light up, however when a tape is put in the tape is moving no sound. Also interior lights do not work. All fuses tested and have power. What could be the problem
 

·
Registered
Joined
·
5 Posts
I think alot of the stock radios had this problem. I bought another on ebay for 30 bucks including shipping. Also there are links on ebay to repair shops the will sell you the fix to yours. You would need to contact them to see if they can help you. I dont think the lights are related. check the bulbs and contacts Had to clean oxidation off mine. good luck
 

·
Registered
Joined
·
2,140 Posts
mopar727 said:
Electrical Problem- Radio does not work or light up, however when a tape is put in the tape is moving no sound. Also interior lights do not work. All fuses tested and have power. What could be the problem
When you say the interior lights, are you talking about the dash lights or dome light?
 

·
Registered
Joined
·
2,140 Posts
Disconnect the battery and pull out the door switches, reconnect the battery and check for 12 volts at each switch...they get their power from the headlight switch, the door switches actually provide a ground when the door is open.
If you pull the door switches with power connected you may get all sorts of sparks when you pull it out of the mounting hole.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top