DodgeTalk Forum banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Howdy folks,
Keeping this brief, My daugters Avenger (2.4) pop up a p2007 code causing it to fail the yearly texas inspection test. After much research I found that code reads to be Intake Manifold Runner Postion Sensor High. I understand this to be that a sensor is reading the position of the four intake manifold butterfly's to wide open at all times. The car runs just like it did when I drove it off the dealer lot, no problems of any kind.
Now to my questions.
1) First train of thought is to remove the electrical sensor box at the front of the manifold and see if that connecting shaft is froze/stuck. Is there a gaskit/seal on that box where it attaches to the manifold? If it is stuck can it be forced/ freed up to move?

2) If the shaft won't move then the obvious thing to do I guess is to replace the manifold. Anyony know where I might locate an free online factory service manual.

3) Is it possible to electricly jumper around that sensor at the electrical plug to kill the 2017code?

The cars got over 100k on it and this has been the only trouble she's had so far and she needs it to get back and forth to college.

Thanks for your help and any ideas you might have.
A College Fund Strapped Dad!

PS*** Am I way out of line with a DIY approach to this because theres just to much involved with replacing the entire intake manifold on a 2.4 motor.
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top