DodgeTalk Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I picked up a 545rfe from an 06 1500....installed it in Mt 08 2500....now tranny isn't receiving signal....just curious if there is a work around. Turns out the transmissions for those two years have different part numbers....so is it different solenoids or is the pcm integrated with the tcm on one year....or can I just flash the pcm....????
 

·
Red Trucker
Joined
·
2,670 Posts
Most RFE's are forwards and backwards compatible. Recheck your connections. What color are the connector plugs for both? Rams have had integrated PCM/TCM modules since 2004.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Most RFE's are forwards and backwards compatible. Recheck your connections. What color are the connector plugs for both? Rams have had integrated PCM/TCM modules since 2004.
The plugs look good....I called the wreckers and they looked it up and they said the 05 and 06 are compatible and the 07 and 08 are separate....the dealership checked the vin from both vehicles and said they are different part numbers.....kinda losing it here....FML
 

·
Registered
Joined
·
440 Posts
So I picked up a 545rfe from an 06 1500....installed it in Mt 08 2500....now tranny isn't receiving signal....just curious if there is a work around. Turns out the transmissions for those two years have different part numbers....so is it different solenoids or is the pcm integrated with the tcm on one year....or can I just flash the pcm....????
You didn't bother checking whether it was compatible before buying and installing it? You have all the symptoms of an incompatible wiring harness. All those errors tell me the wires in the plugs are in different positions, even though the physical plugs are the same.
 
1 - 5 of 5 Posts
Top