DodgeTalk Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey guys-first time posting. I have a 2005 Ram 1500 4.7L w/26g tank. I have changed my fuel pump 2x in last two months. both have been Delphi brand. The 1st one would read 3/4 full for about 10 min after filling it up and then would slowly read full. replaced that pump yesterday with another Delphi pump. when I installed the 2nd one, everything was fine when I tested it. put everything back together and start it up.. now I have P0463 (fuel level sensor circuit) and fuel gauge reading empty at all times. ran all of the wires, checked the instrument gauge/fuses etc and everything checks out good. looking at getting NAPA fuel pump since I have had no luck with Delphi. anyone have any good or bad info on NAPA fuel pumps?
 

·
Registered
Joined
·
54 Posts
I replaced mine on my '06 maybe 3 yrs ago(?) and I bought the one from Rock Auto.

AFTER getting everything installed is when I found out I had no fuel gauge. So I had to uninstall it all over and found the little board in it was cracked so it wasn't making a good connection. It was tax season and I didn't have time to send it back and wait for another and go thru all of it again.

I unsoldered all the fuel gauge apparatus from my old original unit since only the fuel pump part was bad and soldered it onto the new one from Rock Auto and been fine every since.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top