DodgeTalk Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Truck has 69.5K, tranny has been flushed and filtered. Before and after flush, tranny keeps shift cycling down-up when throttle is held steady. Does it on the flat or uphill, but not on the downhill. Does it when cruise is engaged or when throttle is held steady by foot on pedal. Changed the big vacuum line under the air cleaner (it was split on the TB end), none other found bad. Mileage doesn't seem affected, getting 17 on highway with cruise on.
Any ideas?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #2 · (Edited)
Follow-up on my situation....bought some throttle body cleaner and cleaned out throat of throttle body, wow! What a gunky mess!! Sprayed some down the inside the throat, passed the sensor mountings. Started the engine (cold, not run that day), idle came down quickly. Installed "straw" on cleaner can and sprayed across by-pass opening below butterfly bore. Slight hesitation, then RPMs came up. Idle went smooth. Sprayed again, less hesitation. Sprayed again...no hesitation. For insurance, manually opened butterfly slightly and sprayed cleaner around inside of bore and down the throat, no real effect.
On drive to work and back (12 miles, 20 minutes each way, 55MPH) everything worked right. No RPM/Transmission surging. Will know more this weekend when I take it out on the freeway and run cruise at 65-70.
By the way, I can't tell from the illustration in the Chilton (it shows the dual-throat, mine is the single for the 4.7L), but does this thing even havea TV Cable? The one I thought was, turned out to be the cruise control cable.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top