Rear right turn signal inop. - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Closed Thread
 
Thread Tools
post #1 of 3 Old 03-27-2017, 09:57 PM Thread Starter
Elkaholics85
Registered User
 
Join Date: Mar 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Rear right turn signal inop.

Ok so heres the deal I am stumped. I got an 2006 Dodge Ram 2500 4door long bed. A week ago my rear turn signal quite working, I checked my bulb and found no power at the signal. removed the module that all three bulbs go into and checked for power and nothing. traced the wires back into the cab and no power. I replaced the 3 bulb module with new also new bulb. nothing. ( I did check power at the trailer plug and I have a fast turn signal same as the front right. figured it might be the multi function switch. replaced the switch and still nothing. I also removed the tipm (total integrated power module)next top the battery aka fuse panel and checked and cleaned and still nothing. I am completely stump and advise would be greatly appreciated.
Elkaholics85 is offline  
Quick Reply
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-28-2017, 12:19 AM
dmcelhannon
Admin - David Mack
 
dmcelhannon's Avatar
 
Join Date: Apr 2006
Location: McAllen
Posts: 30,924
Mentioned: 7 Post(s)
Tagged: 1 Thread(s)
Quoted: 270 Post(s)
Welcome to DT!

(There are some TSB at the end of the post)

Did you check the ground that's part of the wiring harness? No ground and believe the whole three bulb module doesn't work.

I remember a thread from way back that said you had to do a "TIPM Reset" when a bulb burns out because it stores an error code in Body Module. He claim that the TIPM shuts down the circuit for protection and if the owner doesn't have clue, they have come into the 'stealership' for the rest to solve the problem. Use your reader to clear all the codes and the bulb should work. If you do not have a code reader, you can do a hard dump but I'm not sure if this will reset the TIPM. At least it's free doing it yourself and free far better than the stealership prices.

=============================================
This is from an old DT thread:

You can do what is often called a "hard dump".

We (techs) often do this when we need to totally reset the ECU and either don't have the proper tool close by (too lazy to walk to toolbox and get it) or just are "in a hurry".

First, disconnect positive+ battery cable at the battery and ground it to the chassis. Yes, the POSITIVE CABLE.

Wait a few seconds, 30 won't kill ya.

Now reconnect the positive cable. Careful, no sparks now.

Get in the vehicle, turn ignition key to on (run) position, now depress fully and release the gas pedal 5 times to set the TPS to WOT. (Make sure the floor mats do not keep the pedal from going WFO)

Turn the key to off, wait a min, and you should have cleared everything in the ECU except for the factory programming.

=============================================
The hard dump does not affect the (factory) alarm, the only thing I noticed is my radio presets, as this method came from a working Chrysler tech, I doubt if there are any negative effects.
=============================================

Some of the diesel forums say the 2006 Ram is bad about this problem and they cliam the problem is the Multi Function Switch but you have already replaced it.

There was also a factory recall for the TIPM but it has to do with the 4x4 Transfer Case...

Safety Recall E18

There is also a Technical Service Bulletins (TSB)... "TIPM Flash - Diagnostic Trouble Codes"...

TSB 08-021-06


I really hopes this helps and please post what you find...


.

If you start a thread, be responsible and post the final outcome.


2002 Ram 1500 SLT 4x4 QC ~ 02 Ram 45RFE to Jeep GC TCM 5-45RFE Upgrade - (Nov.01) 4.7L with 91K/3588hrs, 4.56 R&P/DTT, Sonnax Line Booster, SRT-10 Pod w/Dynojet Wideband Commander, 2-speed manual transfer-case, Clifford Security System w/Auto Start/Auto Windows, RB1 CD/DVD/NAV Infinity Sound System w/30GB iPod, Offroad Package, 33" Bridgestone Dueler A/T, Mopar Rear Wheel Liners, K&N w/Airaid Jr Modular Intake Tube, BBK 70mm Throttle Body, AIR_RAM Jet Stream Scoop, PML Diff Cover, ASP Underdrive Crank Pulley, MSD 1.65 Alt Pulley, V8 Lincoln E-Fan, 2-Speed DCC E-Fan Controller, 180 Jet T-Stat, Flowmaster SI/DO Exhaust, Tire-2-Tire Chrome Tuber Step, Line of Fire LED Light Bar, Sylvania Ultra Silverstars

Texas 1845: We the People of the Republic of Texas, acknowledging,
with gratitude, the grace and beneficence of God.

dmcelhannon is offline  
post #3 of 3 Old 03-28-2017, 08:07 AM
MikeT133
Registered User
 
MikeT133's Avatar
 
Join Date: Jul 2012
Location: Chino Valley, AZ
Posts: 131
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Had a similar experience. Left turn signal/brake light would not work on my trailer on a trip, swapped L & R bulbs still the left would not work. Checked all the fuses as there is no fuse listed for trailer turn signals - no bad fuses. Trailer wiring looked good. Took truck to a former dealer mechanic (mopar), hooked it to his computer, diddled a bit and said it's fixed. Got it home, hook it to the trailer, it's fixed. This is also an 06 2500 QC CTD.

Mike
MikeT133 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1500 rear lift Ram1500TRX4 4G Dodge RAM - 4X4 Talk 2 03-27-2017 01:39 PM
2000GC Turn Signal Problems jks0313 3rd Gen Caravan Talk (96-00) 2 03-08-2017 05:51 PM
Turn Signal - 'left only' not working javapop 3rd Gen Caravan Talk (96-00) 2 03-08-2017 05:39 PM
Simultaneous issues with wipers, brights, and turn signal Moose3145 3G Dodge RAM - General Talk 5 01-15-2017 10:51 AM
Turn signal wont quit donthelegend 3G Dodge RAM - General Talk 3 11-29-2016 04:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome