Turn Signal - 'left only' not working - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Reply
 
Thread Tools
post #1 of 3 Old 11-05-2016, 09:32 AM Thread Starter
javapop
Shade Tree Mechanic
 
Join Date: Aug 2014
Location: Augusta
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Turn Signal - 'left only' not working

I have a 2000 Grand Caravan SE, and the turn signal (left only) is not working. I went to the local pull a part and got a new (used) turn signal assembly from the same make model caravan, and the same thing happens.

The emergency flashers work fine. Most often if I turn on the emergency flasher, and turn it off with the left turn signal on, it works.

Any ideas on how I can fix it?
javapop is offline  
Quote Quick Reply
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-01-2017, 02:12 PM
jks0313
Registered User
 
jks0313's Avatar
 
Join Date: Mar 2009
Location: Elkridge, MD
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Angry

Well, I'm glad to see I'm not the only one with this problem. I wrote about it a couple of weeks ago, and got no answers. I hope you do better than I did. I'll keep watching your thread, JIC.


JKS0313


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1999 Dodge Ram 1500 Sport Quad-Cab 4x4 5.9L
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Brand new Fog Lamps (!&#*[email protected]! Deer!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Cat-back Duals, BFG Long Trail T/A's P265-75R16
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

More mods to come as I can afford them!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



2005 Dodge Neon SXT: My Econobox!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Other cars and trucks from different makers but ALL American!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jks0313 is offline  
post #3 of 3 Old 03-08-2017, 05:39 PM
Ratchet75
Registered User
 
Join Date: Nov 2011
Location: CA
Posts: 696
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Have you tried tapping on the combo flasher module on the under dash fuse block? If that goes intermittent remove it. Remove the cover then reflow the solder connecting the external contacts to the internal circuits. The solder often cracks opening the circuit. Very common fix for dead or intermittent turn sigs.
Ratchet75 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome