5.9 V8 Running Rough - Sometimes - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Closed Thread
 
Thread Tools
post #1 of 16 Old 09-12-2011, 03:17 PM Thread Starter
johnnyg1105
Registered User
 
Join Date: Dec 2009
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 5.9 V8 Running Rough - Sometimes

I dont know where to start, this doesn't seem to fit into the normal suck-bang-blow diagnostic chart.
I have a 99 2500 4X4 with the 360 and 70K. has been running and driving great until last week. Started it up cold, idles great, take off from my house running and driving fine. after running for about 2-3 minutes it starts to run very rough, especially if idling at a stop light, and has no power. It is tough to describe because each day it does something a little different. Usually it will idle nice when i stop at the light, then it seems like the RPM's drop about 100, and it starts running rough like a mis-fire, and starts making a loud "sucking" noise, light turns green, hit the gas and it struggles to move, it pops and snaps and feels like somebody is totally choking the intake, lasts for about 30 seconds then slowly goes back to normal.
shut it off and start up again while still hot and it runs fine, leave it for 2 hours and start it up it does the same thing all over again.
air filter is new, cleaned the IAC, disconnected the IAC and still did the same.
I dont know where to go from here.
Any help would be great.
Thanks
John
johnnyg1105 is offline  
Quick Reply
Sponsored Links
Advertisement
 
post #2 of 16 Old 09-12-2011, 03:36 PM
DODGEPICKUP
Senior Member
 
DODGEPICKUP's Avatar
 
Join Date: Feb 2008
Posts: 2,217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
pre-cat o2 is 80% the culprit here....change it out to a ntk sensor direct fit not a universal were you cut n splice....there like 50 buck relatively cheap part that should be changed at or before 75k miles anyways....did you check your plenum for oil pooling when you had the tb off or didnt take it off with the iac?.....thats the other 20%....blown plenum burning oil plugging the cat....WELCOME TO DT

1999 RAM 1500SPORT QC 4X4 5.9 3.55's grrrr
360 MAGNUM POWER 165,000 MILES DYNOED 230/290 ON 35'S
1.7 CRANE ROLLER ROCKERS
DIY CUT,PORTED,EPOXY FILLED KEGGER/ALUMINUM PLENUM PLATE,53MM THROTTLE BODY
JACOBS PRO STREET CD IGNITION
BOSCH DESIGN 3'S 24LBS VETTE INJECTORS
MOPAR P DOUG THORLEY TRI-Y'S
TAYLOR 8.2 THUNDERVOLT WIRE'S
EBC ROTORS N PADS,RUSSELL SS BRAKE HOSES
MARCH UNDERDRIVE CRANK PULLEY
1 TON X-OVER STEERING
DT PRO-FAB TRAC BAR
HELL BENT STEEL 2IN SPACER/SKJ LCA
WINNDEKAR/DSS STEERING BRACE
DODGEPICKUP is offline  
post #3 of 16 Old 09-13-2011, 10:17 AM
OldBettsey
Registered User
 
OldBettsey's Avatar
 
Join Date: Jun 2011
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
x2 on the pre-cat o2 sensor! my 98 did the same thing a few months ago, replaced the o2 with a ntk for 30 bucks at advanced auto parts (ordered online and used promo code p20 for 20% off and used the pick up at store option saved me a few bucks) runs like a champ once again.

1998 Ram 1500 5.2L 147K miles
OldBettsey is offline  
Sponsored Links
Advertisement
 
post #4 of 16 Old 09-13-2011, 11:27 AM
V-10 GUY
Registered User
 
Join Date: Aug 2011
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My thought was did you get some bad gas? I have had that happen. Throw a little ACETONE no more than a couple of ounces in the tank. Start cheap & work your way up.
V-10 GUY is offline  
post #5 of 16 Old 09-13-2011, 03:47 PM Thread Starter
johnnyg1105
Registered User
 
Join Date: Dec 2009
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
That was it! I unplugged the front O2 sensor and she runs great. I guess i will have to replace it when i get the time.
Thanks
johnnyg1105 is offline  
post #6 of 16 Old 09-13-2011, 04:48 PM
DODGEPICKUP
Senior Member
 
DODGEPICKUP's Avatar
 
Join Date: Feb 2008
Posts: 2,217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
when you get the new o2 let us know the out come....little update would be cool beans

1999 RAM 1500SPORT QC 4X4 5.9 3.55's grrrr
360 MAGNUM POWER 165,000 MILES DYNOED 230/290 ON 35'S
1.7 CRANE ROLLER ROCKERS
DIY CUT,PORTED,EPOXY FILLED KEGGER/ALUMINUM PLENUM PLATE,53MM THROTTLE BODY
JACOBS PRO STREET CD IGNITION
BOSCH DESIGN 3'S 24LBS VETTE INJECTORS
MOPAR P DOUG THORLEY TRI-Y'S
TAYLOR 8.2 THUNDERVOLT WIRE'S
EBC ROTORS N PADS,RUSSELL SS BRAKE HOSES
MARCH UNDERDRIVE CRANK PULLEY
1 TON X-OVER STEERING
DT PRO-FAB TRAC BAR
HELL BENT STEEL 2IN SPACER/SKJ LCA
WINNDEKAR/DSS STEERING BRACE
DODGEPICKUP is offline  
post #7 of 16 Old 09-13-2011, 05:26 PM
V-10 GUY
Registered User
 
Join Date: Aug 2011
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Glad you figured it out keep us posted.
V-10 GUY is offline  
post #8 of 16 Old 09-14-2011, 09:31 AM
OldBettsey
Registered User
 
OldBettsey's Avatar
 
Join Date: Jun 2011
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dont mean to thread jack..but i had the same problem and a new upstream o2 sensor fixed the problem. But now on cold starts i have a rough idle it doesnt really jump a whole lot only a couple hundred rpm but you can feel it kind of rumble the truck a little. what could this be? bad TPS? my battery tested weak on my last oil change about 2 months ago could this be the problem i know ive read these trucks act weird with a weak battery....

1998 Ram 1500 5.2L 147K miles
OldBettsey is offline  
post #9 of 16 Old 09-14-2011, 04:41 PM
DODGEPICKUP
Senior Member
 
DODGEPICKUP's Avatar
 
Join Date: Feb 2008
Posts: 2,217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
yes a weak/bad battery and corroded cables can cause all sorts of wacky issues....have you cleaned/replaced your iac?....clean the throttle body to with a new gasket

1999 RAM 1500SPORT QC 4X4 5.9 3.55's grrrr
360 MAGNUM POWER 165,000 MILES DYNOED 230/290 ON 35'S
1.7 CRANE ROLLER ROCKERS
DIY CUT,PORTED,EPOXY FILLED KEGGER/ALUMINUM PLENUM PLATE,53MM THROTTLE BODY
JACOBS PRO STREET CD IGNITION
BOSCH DESIGN 3'S 24LBS VETTE INJECTORS
MOPAR P DOUG THORLEY TRI-Y'S
TAYLOR 8.2 THUNDERVOLT WIRE'S
EBC ROTORS N PADS,RUSSELL SS BRAKE HOSES
MARCH UNDERDRIVE CRANK PULLEY
1 TON X-OVER STEERING
DT PRO-FAB TRAC BAR
HELL BENT STEEL 2IN SPACER/SKJ LCA
WINNDEKAR/DSS STEERING BRACE
DODGEPICKUP is offline  
post #10 of 16 Old 09-14-2011, 08:41 PM
ClubCab5.9
Registered User
 
ClubCab5.9's Avatar
 
Join Date: Aug 2011
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dodgepickup is right. We had a bad battery(had it load tested)and the truck would just out of the blue run rough, sputter and die. Purchased new cables going to the battery and a new interstate and runs good for 190k.
ClubCab5.9 is offline  
post #11 of 16 Old 09-14-2011, 09:23 PM
NeedaRam
Registered User
 
NeedaRam's Avatar
 
Join Date: Jul 2011
Posts: 1,044
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Could this be my problem(Battery) when it gets cold like in the morn. and I start it, it cranks a little longer than it should. and it sometimes revs up to 1900-2000 RPMS for like 2 seconds.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 Sport SOLD
God Squad 95 to eternity
Cracked Dash Club # 33
Blue Truck Club member #259
*DodgeTalk.com 318 Enthusiast Member #(131)*
Interior: Complete Blue LED Lighting, Dash Mat, Painted OH Console, Pioneer HU and Speakers, 1600W Amp, Cobra CB w/ 3ft firestick whips

Exterior: Fender Flares, Bed Lined rockers, Bed, and rear bumper, Plastidipped Wheels, Plastidipped badges, Chrome Wheel Center Caps, Ramhead on Gas Door, LED 3rd Brake Light

Steering/Suspension: 1-Ton cross-steering, Rock Solid Ram Steering Fix

Performance: Superchips 3815(91 Perf. Tune), Magnaflow HF CAT, Flowsound Muffler, Duals out the back w/ black tips, Hughes Plenum, Autolite 3923s
NeedaRam is offline  
post #12 of 16 Old 09-14-2011, 09:38 PM
ClubCab5.9
Registered User
 
ClubCab5.9's Avatar
 
Join Date: Aug 2011
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
We are alittle new to RAM'S but it seem's that if your battery is more then 3 years it should be charged and load tested. Any good Auto store can go this for free. With that said it does no good if the cable's are bad. Cables are a cheap fix and with as many years and mileage these trucks are at we ALL should replace them. They don't last forever.
ClubCab5.9 is offline  
post #13 of 16 Old 09-15-2011, 06:37 AM
NeedaRam
Registered User
 
NeedaRam's Avatar
 
Join Date: Jul 2011
Posts: 1,044
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mine isnt really old though. maybe it would be my cables. I dont have any other symtoms tho


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 Sport SOLD
God Squad 95 to eternity
Cracked Dash Club # 33
Blue Truck Club member #259
*DodgeTalk.com 318 Enthusiast Member #(131)*
Interior: Complete Blue LED Lighting, Dash Mat, Painted OH Console, Pioneer HU and Speakers, 1600W Amp, Cobra CB w/ 3ft firestick whips

Exterior: Fender Flares, Bed Lined rockers, Bed, and rear bumper, Plastidipped Wheels, Plastidipped badges, Chrome Wheel Center Caps, Ramhead on Gas Door, LED 3rd Brake Light

Steering/Suspension: 1-Ton cross-steering, Rock Solid Ram Steering Fix

Performance: Superchips 3815(91 Perf. Tune), Magnaflow HF CAT, Flowsound Muffler, Duals out the back w/ black tips, Hughes Plenum, Autolite 3923s
NeedaRam is offline  
post #14 of 16 Old 09-15-2011, 09:51 AM
OldBettsey
Registered User
 
OldBettsey's Avatar
 
Join Date: Jun 2011
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yes i think its time for a new battery and cables! bought the truck back in 03 with 70k now at 147k and have never changed the battery!! better do it before hunting season next month!! thanks everyone ill post with results!

1998 Ram 1500 5.2L 147K miles
OldBettsey is offline  
post #15 of 16 Old 09-15-2011, 02:56 PM
DODGEPICKUP
Senior Member
 
DODGEPICKUP's Avatar
 
Join Date: Feb 2008
Posts: 2,217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
8-9 year old battery its time for a new one....not saying it will solve all/your problems but its part of maintenance anyways and should be looked at or repaired....clean the iac to if you havent.....

1999 RAM 1500SPORT QC 4X4 5.9 3.55's grrrr
360 MAGNUM POWER 165,000 MILES DYNOED 230/290 ON 35'S
1.7 CRANE ROLLER ROCKERS
DIY CUT,PORTED,EPOXY FILLED KEGGER/ALUMINUM PLENUM PLATE,53MM THROTTLE BODY
JACOBS PRO STREET CD IGNITION
BOSCH DESIGN 3'S 24LBS VETTE INJECTORS
MOPAR P DOUG THORLEY TRI-Y'S
TAYLOR 8.2 THUNDERVOLT WIRE'S
EBC ROTORS N PADS,RUSSELL SS BRAKE HOSES
MARCH UNDERDRIVE CRANK PULLEY
1 TON X-OVER STEERING
DT PRO-FAB TRAC BAR
HELL BENT STEEL 2IN SPACER/SKJ LCA
WINNDEKAR/DSS STEERING BRACE
DODGEPICKUP is offline  
post #16 of 16 Old 09-15-2011, 05:14 PM
OldBettsey
Registered User
 
OldBettsey's Avatar
 
Join Date: Jun 2011
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by DODGEPICKUP View Post
8-9 year old battery its time for a new one....not saying it will solve all/your problems but its part of maintenance anyways and should be looked at or repaired....clean the iac to if you havent.....
how excatly do i go about cleaning the IAC??

1998 Ram 1500 5.2L 147K miles
OldBettsey is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 ctd running rough? lagnaf 3G Dodge RAM Diesel Talk 7 07-10-2009 01:33 PM
01 Ram Running Rough help me devildog_0431 2G Dodge RAM - General Talk 7 04-07-2009 10:45 AM
running rough Barry J 2G Dodge Dakota General Talk 1 06-16-2008 01:28 PM
running a bit rough MegaDad 2G Dodge RAM - General Talk 0 05-25-2007 08:43 AM
running a little rough?? 69charged 3G Dodge RAM - General Talk 1 12-15-2004 09:48 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome