Help with 97 Ram. (The Book) - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Closed Thread
 
Thread Tools
post #1 of 6 Old 04-05-2005, 08:01 PM Thread Starter
bigkane01
 
Join Date: Apr 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Help with 97 Ram. (The Book)

Hello, I'm new to this forum and could use some help. I have a '97 Ram 1500 5.9 w/134K miles. First problem was hesitation, truck would constantly hesitate on take off. Then second problem, on long trips (about 1hr drive) the Ram would start idling erratic and black smoke would pour from tailpipes. Friend had similiar problem with MAP sensor on Chevy. So I replace the MAP, problem seemed to be fixed.....wrong. Month later same trip, same exact symptoms, so I changed plugs(bosch plat.4) wires, cap, button(all mopar) and had upper intake flushed......no help at all(probably should have took it to dealer after this). Next I decided to try changing sensors out around throttle body. Changed TPS....didn't work. Changed IAC selenoid-valve.....helped shortly then back to the crazy idling again. Alright dealer time I suppose. Dealer said fuel pump was bad. $400.00 dished out for fuel pump module and hesitation problem seems to be fixed. But my idling problem is still happening, only now it's accompanied by the sound of air or vacuum of some sort. It's very loud sometimes when I first start the truck, and it seems as if it's gonna die(idle drops). Then I'll hear a click or snap of some sort that sounds like something has closed and the engine will idle up and run somewhat better and the air noise gets much more quiet. Upon raising the hood I can still hear the air but can't figure where from. I checked inside the intake through the throttle body to see if there was oil, indicating a plenum leak...but there's not any that I can see. If anyone can help I'd greatly appreciate it. I've done everything short of buying a new truck. I very seriously contemplating setting this thing on fire or running it off a cliff. Thanks in advance.
bigkane01 is offline  
Quick Reply
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-10-2005, 08:05 PM
heloace
 
Join Date: May 2003
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your cat conv is probably plugged. If you don't care about having one intact, cut the pipe behind the conv, put a 1" spade bit in a drill bit extension and drill out a hole in the foil all the way to the front. That'll fix it temporarily until you can get a new cat or whatever you need to do. re-connect the cut pipes with a splice, clamp it and drive away. the "sucking"sound you hear is exhaust escaping around the exhaust manifold flange. the change in pitch you hear also may be the iac solenoid ont he rear of the tb. by the way, a new fuel pump is about $200 which you didn't need. the reason I know all this is I went through the same thing a month ago and spent about 500 bucks "fixing" things that weren't broke. "check the simple, cheap things first". basic rule of mechanics at home and I forgot it!!!!! duh!! one other basic rule__ NEVER,NEVER,NEVER go to the dealer. they are theives. they will replace one thing after another until they've broken your bank except they don't have to pay for it. Oh, one more thing to check. the iac ( idle air controller solenoid) on the rear of the tb. it will get carboned up. you can remove it, spray carb cleaner inside the tb and the valve and clean it off. wipe out the tb but be carefull with the valve, it's kind of fragile and you don't want to twist it. best of luck, let us know how it comes out
heloace is offline  
post #3 of 6 Old 04-11-2005, 12:31 AM Thread Starter
bigkane01
 
Join Date: Apr 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I appreciate your help, but my Cat has already been gutted and I've replaced the IAC. The fuel pump did cost me $390 some odd dollars for a brand new mopar fuel pump module. Yeah and I agree with you, I really hate dealers and they're tactics. I'll end up figuring it out on my own before I'll ever go back to the dealer. I hate 'em.
bigkane01 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 04-12-2005, 08:33 PM
Big Blue
 
Join Date: Apr 2004
Posts: 268
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like it could also be an O2 sensor. Call one of the major part store chains in your area (Auto Zone, Pep Boys, etc.). Many of them will check the computer for codes free.

Based on your description of the problem, it sounds like either an emissions sensor of some kind, or something in the fuel system, like a bad fuel injector. Either way, it should store a code.

Good luck.
Big Blue is offline  
post #5 of 6 Old 04-13-2005, 01:48 AM Thread Starter
bigkane01
 
Join Date: Apr 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
That's the first place I had a check done, Autozone. They said only code was for a speed sensor. I replaced that. Guess what when I went to dealer after they done their checkup this bast*rds told me they replaced a speed sensor in the tranny, even though I told them I had already done that. Their reply was that there was 2 in the tranny. I have yet to find another one other than the one I put in. I appreciate your help. I've also heard that sometimes an O2 sensor won't show a code. So I guess the next money will go towards that. Eventually I'll end up replaces every da*n thing on the truck. Thanks again for everyone's input.
bigkane01 is offline  
post #6 of 6 Old 04-13-2005, 01:52 AM Thread Starter
bigkane01
 
Join Date: Apr 2005
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Oh also I was gonna ask if anyone had ever replaced an injector or took em off and cleaned 'em. I was thinking I might try this next as soon as I figure out how to depressurize the line(mine doesn't have the needle valve on the rail). It doesn't look like it would be that difficult?
bigkane01 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone have feedback on Bosch +4? huh? 1G Dodge Durango General Talk 19 06-16-2004 12:19 PM
2004 Dodge Ram SRT-10 RAM MAN Rumor Mill & Gossip Talk 0 11-20-2003 05:38 PM
Two dueling Dodge Ram teams RAM MAN Sprint Cup Series Racing 0 11-06-2003 04:20 PM
Gaughan's Ram Scores Hat Trick at TMS RAM MAN Sprint Cup Series Racing 0 06-09-2003 09:16 PM
HEMI® Muscle with the 2003.5 Dodge Ram 1500 RAM MAN 3G Dodge RAM - General Talk 16 12-06-2002 09:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome