2005 Dakota 4x4 4.7 cylinder 7 misfire - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Reply
 
Thread Tools
post #1 of 1 Old 06-13-2019, 01:18 AM Thread Starter
Pat read
Registered User
 
Join Date: Jun 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2005 Dakota 4x4 4.7 cylinder 7 misfire

So first off thank you for reading my post . I bought this 2005 Dakota 4x4 4.7 two years ago and it was a great truck for the 4 months I drove it . I lent it to my GF son as I had another truck at the time. He ran the Dakota with no oil and the #7 rod broke and locked the engine. A year later I got the money and time to replace the motor. First obstacle was to unlock the motor to get to the torque converter bolts. Then the tailgate and air intake cover say V8 Magnum but the vin number shows it a standard 4.7 and I inspected the cams and didn't have the HO notch. So I ordered a 4.7 with the vin number and got it installed and started 3 days ago. It ran great for the first day with no mis . The second day I had idling charging the AC and I got a check engine light turn on for cylinder #7 misfire . I moved the coil and plug to #1 cleared the code and it can back. Then yesterday the 3rd day running and 60 miles on the motor I got Crankshaft position sensor A code . I had bought a new one from Amazon and I went and bought another new one at Autozone . The Autozone CSPS would run for 30-45 seconds and shut off. I replaced my Amazon sensor and it would run but still had a mis. Got a second one from Autozone and did the same as the first one they sold me . Took it back and got my money back and went to Oriley and got one . The truck runs fine until at a stop and can feel it start to mis and I got the P307 #7 misfire again. I cleared the code and took it on the highway for 20 miles and it ran like a champ! After exiting the highway and waiting at the light it was running smooth and then started to mis slightly. Now home no codes are present but running rough at idle . I'm sure if I let it sit in the driveway idling it will get the P307 again. Any suggestions would be greatly appreciated.
Pat read is offline  
Quote Quick Reply
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 4 (0 members and 4 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome