How to check power at fuel pump? - Page 2 - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Closed Thread
 
Thread Tools
post #21 of 28 Old 06-29-2011, 07:24 PM Thread Starter
Mischief007
Registered User
 
Join Date: Sep 2007
Location: London
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Mischief007
(Thread Starter)
I did use a separate ground for the pump as well when I tested it and nothing so I know one needs a new fuel pump. As far as everything else, I'll let my dad decide what he wants to do with the truck. Too many issues at this point. This is what happens when the truck sits all winter and you have a ton of snow on the ground. The truck barely moved at all.
Mischief007 is offline  
Sponsored Links
Advertisement
 
post #22 of 28 Old 07-09-2011, 11:39 AM Thread Starter
Mischief007
Registered User
 
Join Date: Sep 2007
Location: London
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Mischief007
(Thread Starter)
So this is the fuse box. You can see one pin broken (the connector is really corroded), and there seems to be a piece missing on the board itself.

We've already called around here and all the junkyards say this is a popular piece.
Attached Images
File Type: jpg DSCF4654 (Medium).JPG (112.3 KB, 22 views)
Mischief007 is offline  
post #23 of 28 Old 07-09-2011, 12:41 PM
rye
Retired DT Staff
 
rye's Avatar
 
Join Date: Apr 2009
Location: Ontario, Canada
Posts: 11,180
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 0 Post(s)
Hit up PCP on here...he has a tendancy to be able to find all sorts of things....




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


DODGETALK.COM MODERATOR
─────────────────────────────────────────────
5.9 2003 1500 4x4
─────────────────────────────────────────────

Official Dodgetalk Facebook Page:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Like us! Prize Giveaways, News, and More!!!

rye is offline  
Sponsored Links
Advertisement
 
post #24 of 28 Old 07-09-2011, 09:22 PM
06trxhemi
ASE approved
 
06trxhemi's Avatar
 
Join Date: Mar 2005
Posts: 8,862
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I second PCP he is a great guy and can set you up with everything you need.

Quote:
Originally Posted by PCP View Post
if it doesn't put a smile on your face, youre in the wrong shop..
follow along with the CNC Plasma cut parts on a 41 Plymouth rat rod build
(i have the capability to do the cutting)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
06trxhemi is offline  
post #25 of 28 Old 07-09-2011, 11:17 PM
PCP
what's my bore?
 
PCP's Avatar
 
Join Date: Dec 2009
Location: Phoenix Arizona
Posts: 3,933
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thanks guys
Mischief007 if you want me to look, hit me a pm.

510 rwhp and 522 foot lb of torque.
fastest 1/4 and 3rd time out 12.33 at 110 mph



check out our rat rod build.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




Don't TOUCH my truck Club # 92
Silver truck club #235
Trucks and Guns Club #145
PCP is offline  
post #26 of 28 Old 07-12-2011, 03:08 PM Thread Starter
Mischief007
Registered User
 
Join Date: Sep 2007
Location: London
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Mischief007
(Thread Starter)
Thanks guys. Contacted PCP and we shall go from there. I will update this thread once we can get the truck running. We know what is wrong, just need to find the part now .
Mischief007 is offline  
post #27 of 28 Old 07-14-2011, 06:18 PM Thread Starter
Mischief007
Registered User
 
Join Date: Sep 2007
Location: London
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Mischief007
(Thread Starter)
PCP is shipping out a fusebox and a connector for me for a good price. I will let you guys know once we start putting the truck back together.

Found a power wire that was rubbing as well and has corrosion on it. Runs from the fuse box to the alternator. I can make one of those without a problem so not worried about that one.
Mischief007 is offline  
post #28 of 28 Old 07-23-2011, 04:33 PM Thread Starter
Mischief007
Registered User
 
Join Date: Sep 2007
Location: London
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Mischief007
(Thread Starter)
Replaced the fuse box and found a wiring issue inside the wiring harness right by the fuel pump connector. Reconnected those wires and the truck fired up. Almost all issues are also resolved. Broken wires near the fuel pump connector caused the no start issue. Fuse box helped solve most of the other electrical problems we had.
Mischief007 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel pump check valve bad; quick fix by adding an external one? mike_ct 2G Dodge RAM - General Talk 1 10-31-2008 04:10 PM
97 Ram 4x4 V10 No power to Fuel pump SNAL 2G Dodge RAM - General Talk 3 08-18-2007 10:32 PM
Help.. New fuel pump No power to it! icurious1 Vintage Dodge Car Forum 6 10-07-2006 12:46 AM
fuel pump...check valve...????BAD 5.0 2G Dodge RAM - General Talk 11 10-13-2005 02:02 PM
92 Dakota check fuel pump 3.9 v6 rocket3200 Dodge Ram Truck 1st Gen (88 - 93) Forum 3 06-22-2005 05:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome