high idle after hitting water puddle on roadway - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Reply
 
Thread Tools
post #1 of 5 Old 04-27-2019, 04:27 PM Thread Starter
kevaug
Registered User
 
Join Date: Aug 2013
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Arrow high idle after hitting water puddle on roadway

Hi All - 2004 Ram 1500 SLT 4x4 MANUAL Tran with 4.7L
last night we had some major rain and flash flooding.
It was dark and I couldnt see very well and hit a puddle that came up to my step rails. Needless to say it threw and stuffed my truck pretty bad.
Shortly thereafter my RPMs were idling around 1500 and if I pressed the clutch in it went up to 3000 rpms.
Any idea on what could have got wet or disconnected going through this huge puddle?
Thanks
kevaug is offline  
Quote Quick Reply
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-28-2019, 07:51 AM Thread Starter
kevaug
Registered User
 
Join Date: Aug 2013
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yesterday I disconnected the battery hoping to "reset" the computer as no DTC codes were displayed other than a P0563 (Battery/Syetem Voltage High) which I had to hunt for as the CEL was NOT on. I reconnected battery and took it for a test drive and the CEL came on with a P0068 (MAP/MAF -throttle position correlation).
So could the blast of water somehow ruin my TPS? or maybe a vacuum hose was detached?
Any thoughts?
kevaug is offline  
post #3 of 5 Old 06-04-2019, 09:37 PM Thread Starter
kevaug
Registered User
 
Join Date: Aug 2013
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So far Ive swapped out the MAP, TPS, IAC, and installed new spark plugs.
removed and cleaned TB and installed a new gasket.
Compression test indicates all cylinders are fine.
Still have high idle. Could not find a vacuum leak.
Could the PCM be bad, and if so how could I test that?
kevaug is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-05-2019, 08:28 PM Thread Starter
kevaug
Registered User
 
Join Date: Aug 2013
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I checked vacuum today and at idle i was getting about 19.5 inHg.
I think this means my vacuum is excellent and I guess that would indicate no vacuum leaks?
kevaug is offline  
post #5 of 5 Old 06-05-2019, 08:34 PM Thread Starter
kevaug
Registered User
 
Join Date: Aug 2013
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Also I found a melted piece of plastic from an evap line. It appears a line coming off the evap canisters is a vent to atmosphere. I think the force of the water must have broken the bundle ties of this line and allowed it to drop down and come in contact with the exhaust and melt. Its a little "mushroom" looking vent cap but I dont think this is effecting the idle.
I did order a new vent cap and I will have to tie it back up to something to avoid this one melting.
Does anyone know the importance or operation of this vent?
kevaug is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling and high idle 92dak89 Dodge Dakota 1st Gen (87 -96) Forum 1 08-25-2018 03:47 PM
high idle dybeepvw 3G Dodge RAM - General Talk 0 10-08-2017 06:18 PM
Code list slingin_mudd 3G Dodge RAM - General Talk 0 08-27-2017 08:39 PM
High Idle in Nuetral AlReset 4th Gen Caravan Talk (01-07) 3 05-31-2017 10:04 PM
Very high idle in park, won't pass emissions guerajj77 Dodge Ram Truck 1st Gen (88 - 93) Forum 1 01-30-2017 12:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome