Thermoquad problem - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Notices

Reply
 
Thread Tools
post #1 of 1 Old 07-16-2019, 11:53 PM Thread Starter
cribbs74
Registered User
 
cribbs74's Avatar
 
Join Date: Nov 2006
Location: Oklahoma City
Posts: 571
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
(Thread Starter)
Thermoquad problem

I finally got around to switching out my tired Holley 2 barrel to a rebuilt (by me) thermoquad. It fired right up and runs great, performed an idle mixture adjustment and it’s smooth as silk. No bog, no hesitation and I couldn’t be happier. My problem is when I went WOT for the first time one of the metering rods fell out, they aren’t really retained by anything they just move around in the hole in the plunger saddle. Is this a common problem? Anybody know what the fix is? It only did it once, subsequent WOT operations went fine. I know this will happen again. Any ideas guys?

Ron Cribbs

1976 D100 SWB utiline 318/A-833
1958 MGA roadster
1974 Triumph Trident
cribbs74 is offline  
Quote Quick Reply
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome