Instrument Cluster Not Working - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 07-23-2005, 08:53 PM
kikin
Registered User
 
kikin's Avatar
 
Join Date: Feb 2005
Location: houston,tx.
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Instrument Cluster Not Working

I HAVE A 1995 DODGE NEON SOHC AND MY INTRUMENT CLUSTER IS NOT WORKING.WHEN I START THE CAR THE TEMPERATURE GAUGE GOES ALL THE WAY UP TO HOT AND THE TACHOMETER IT'S NOT WORKING,SOMETIMES IT MOVES.DOES ANYBODY KNOW WHAT COULD BE CAUSING THIS?

1998 DODGE DURANGO 5.2L 4X4.SUPER 40 SERIES FLOWMASTER EXHAUST SYSTEM.SUPERCHIPS MICRO TUNER.CUSTOM COLD AIR INTAKE.K&N AIR FILTER.20" KMC CONDOR WHEELS.TV AND DVD .
kikin is offline  
Sponsored Links
Advertisement
 
#2 Old 07-24-2005, 04:19 AM
dodgeneonACR98
So whats UR excuse?
 
Join Date: Sep 2003
Location: mannington
Posts: 4,542
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BE CHECKING YOUR ALTERNATOR BELT MAN. My 98's guages quit on me and sometimes the speedometer would be sayin like 85 and I was doing 2. To make a long story short, I broke my alt belt on a down shift,raceing some punk. I won! But it didn't take long for me to figure out what my guage prob's were.I drove her home on the battery ( what a damn fine battery it is too) and the weaker the battery got the more my guages went nutz.I made it home some 25 miles later only to have it die as I pulled in the driveway....I put on a new belt and have had no prob since.......

Some do have "cold" solder joints.There is a how-to on what to look for and how to fix it yourself im not sure where its at but I have seen one......GOOD LUCK!

http://www.dodgetalk.com/forums/show...p?t=100535]God Squad member #53 [/url]


04 Neon SRT-4
98 Neon ACR-2.4 swaped with goodies
dodgeneonACR98 is offline  
#3 Old 07-24-2005, 09:31 AM
kikin
Registered User
 
kikin's Avatar
 
Join Date: Feb 2005
Location: houston,tx.
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for the advice.I will check the belt maybe that is the problem like you said.

1998 DODGE DURANGO 5.2L 4X4.SUPER 40 SERIES FLOWMASTER EXHAUST SYSTEM.SUPERCHIPS MICRO TUNER.CUSTOM COLD AIR INTAKE.K&N AIR FILTER.20" KMC CONDOR WHEELS.TV AND DVD .
kikin is offline  
#4 Old 07-26-2005, 12:44 AM
RadarLove
Registered User
 
Join Date: Mar 2005
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The connectors into the instrument cluster are kind hokey. They don't snap/lock into place, so they move around a lot. Could be coming disconnected or otherwise losing the normal connection. There are also problems with the solder points on the cluster side, but that tends to be the speedo. On the 1st gens, the J2 (right side) conector comes in at a particularly bad angle. My '95 has issues with the speedo wire getting a bit over extended (not a problem now, dash removed...)

Best of luck!
RadarLove is offline  
#5 Old 07-26-2005, 01:16 PM
EZ4U2CHere
Registered User
 
EZ4U2CHere's Avatar
 
Join Date: Aug 2004
Location: Warner-Vegas, GA
Posts: 890
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Clusters in 1st gen neons are infamous for going bad. I've had to replace mine. I think I paid about $30 at a bone yard with a guarantee it would work when I got home.

2003 Dodge RAM 1500 QuadCab HEMI SLT Sport Flame Red! : Work in progress
22" KMC SS Wheels / Gaylords X2000 Tonneau w/ SpeedSturr Wing / Ground Force Drop / SuperChips Programmer / Magnaflow 14589 Muffler / K&N FIPK / Alpine CDA-9853 Head Unit / 1/2 DIN DVD player in dash / 7" Monitors in Headrests / EGR Fender Flares / Mopar Fender Shields / Rumble Bee Lower Valence / Bumper grill insert to match the stock grill / WestSideVinyl bed stripes and matching hood stripe / WeatherTech In-Channel Wind Deflectors / Clear Corner Lens / Billet Alluminum Gas Lid (painted to match) / Taylor Shorty Wires / PIAA fog light bulbs /SilverStar Headlight Bulbs / Titanium Chrome turn signal bulbs / Billet Shorty Antenna / Rear Wheel Well Liners / LED's in cup holders and dash cubby / Painted to match door handles, brake calipers, and lots of stuff painted to match under the hood

'96 Plymouth Neon Expresso DOHC MTX: Fast, but not Furious
KONI Yellows / Mopar X-High Rate Springs / 15x7" Rota Slipstreams / 205/50/15 Azenis / Mopar Peformance Computer / Ceramic Coated Pacesetter Short Tube Header / MPx UDP / 3.0 CAI / 22mm Front Sway Bar / 22mm Adjustable Rear Sway Bar / Deyemme Racing Motor Mounts / Prothane Motion Control Suspension Bushings / Booger Shifter Bushings / Hawk HP Plus Brake Pads / PT Cruiser Valve Train
EZ4U2CHere is offline  
#6 Old 10-25-2005, 04:08 PM
98NeonR/T2.0
Registered User
 
98NeonR/T2.0's Avatar
 
Join Date: Oct 2005
Location: Hanover
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
In my 98 R/T Neon once in a while I'll drive down the road and all my gauges will shut off. All I do is give my dash a good tap on the left side of the instrument panel and boom! Your gauges are working.
98NeonR/T2.0 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Died at idle penguinsluvme 1G Dodge Durango General Talk 19 05-13-2005 06:11 AM
Instrument Cluster Swap Possible?? ruswilliams 1G Dodge Durango General Talk 5 08-23-2004 10:52 AM
Instrument cluster failure katrina Vintage Dodge Car Forum 0 08-21-2004 10:07 AM
DC to Repair Durango Instrument Cluster Circuit Board RAM MAN Rumor Mill & Gossip Talk 0 12-14-2003 10:16 PM
Air Bag light Came On TEXAS DODGE 3G Dodge RAM - General Talk 3 02-20-2003 01:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome