Whats At' Clickin NOISE- Comedian Henry Chung - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
View Poll Results: What Was your CLICKING NOISE problem
Oil type 0 0%
Exhaust leak or any type of broken leaky part 2 66.67%
Belts,tensioner,rockers,push rods etc etc 1 33.33%
Other 0 0%
Voters: 3. You may not vote on this poll

 
Thread Tools
post #1 of 10 Old 12-18-2012, 03:00 AM Thread Starter
DodgeEMT549
Duh, Big Red Truck
 
DodgeEMT549's Avatar
 
Join Date: Dec 2012
Location: Small Town USA, TN
Posts: 161
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Whats At' Clickin NOISE- Comedian Henry Chung

Sooooo
ive seen many post about this clicking noise on cold start ups, even warm start ups..

Calling all 2010 owners 5.7 HEMI owners, do you have this problem? how did you remedy it? is the cause within the difference between using conventional and synthetic? so on and so forth. let me know what you have figured out as the problem and fix

Thanks
D.Willy
Attached Images
File Type: jpg trc2.JPG (207.6 KB, 19 views)

Current ride (aquired 01/13/14)- 2007 RAM 2500 6.7 Turbo Diesel Fire Engine Red
-Cold Air intake
-17inch Balistic Jester with 35 inch Cooper Discovery A/T 3
-Rhino lined bed
-Deleted
-Tuned










2010 RAM 1500 QC- Deep cherry (Back to Stock, Traded)

DodgeEMT549 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 12-18-2012, 04:57 AM
NoPlugsRequired
Registered User
 
Join Date: Dec 2012
Posts: 615
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That bit is awesome!

'12 Ram 3500 Limited SRW 4x4 CrewCab Longbed
Carli 3" "Dominator", Trussed and Hydo'd front, AFE Intake, Deleted, 4" TBE, 37" Toyo M/Ts on TrailReady 5½ Black/Black wheels, H&S Mini Maxx Race w/ Trans unlock and MCC tuned by Draconian, ISSPRO triple pillars (EGT, Boost and Drive Pressure), ISSPRO Turbo Temp Monitor, Custom Tube Bumper, Custom Bed Supports, AMP steps, Race Radio, Spare Tire Lock and enough Lighting to need sunglasses at night

NoPlugsRequired is offline  
post #3 of 10 Old 12-18-2012, 04:57 AM
NoPlugsRequired
Registered User
 
Join Date: Dec 2012
Posts: 615
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oh and sorry... I have no usefull bit of info for you.

'12 Ram 3500 Limited SRW 4x4 CrewCab Longbed
Carli 3" "Dominator", Trussed and Hydo'd front, AFE Intake, Deleted, 4" TBE, 37" Toyo M/Ts on TrailReady 5½ Black/Black wheels, H&S Mini Maxx Race w/ Trans unlock and MCC tuned by Draconian, ISSPRO triple pillars (EGT, Boost and Drive Pressure), ISSPRO Turbo Temp Monitor, Custom Tube Bumper, Custom Bed Supports, AMP steps, Race Radio, Spare Tire Lock and enough Lighting to need sunglasses at night

NoPlugsRequired is offline  
post #4 of 10 Old 12-18-2012, 02:18 PM
Jadesmarine
Let it go
 
Jadesmarine's Avatar
 
Join Date: Mar 2009
Location: 29 Palms, Ca
Posts: 956
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My dealer is still trying to track down the problem but as soon as they fix it I will let you know.

_______________________
-Dan

14' Dodge Durango AWD R/T Hemi
14' Jeep Cherokee Altitude
Jadesmarine is offline  
post #5 of 10 Old 12-18-2012, 06:38 PM
snow cheif
Registered User
 
snow cheif's Avatar
 
Join Date: Feb 2012
Location: bayville
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Garage
never had the noise
snow cheif is offline  
post #6 of 10 Old 12-21-2012, 07:34 AM
2002 RAM 4 DOOR
2010 HEMI RAM 4X4
 
2002 RAM 4 DOOR's Avatar
 
Join Date: Dec 2006
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Im at 40,000 km. and mine is hit and miss when engine is cold occasionally it ticks like crazy for a few seconds and others it is perfectly quiet. I will check manifold studs when I change oil next. By the way it has had nothing but synthetic oil and napa gold filters since first oil change. My wifes Aspen has 120,000 km and it never ticks at all.

2010 Black Ram Crew Cab SLT Plus 4X4
Engine HEMI
2002 RAM 4 DOOR is offline  
post #7 of 10 Old 12-21-2012, 08:56 PM
Palomba
Registered User
 
Join Date: Jan 2010
Posts: 170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
There prone to bad exhaust manifold bolts. There's a tsb out on it.

2012 HEMI qc Express 4.10s w/lsd. 6.4 camshaft. comp cams ls1 beehive springs. 3000 edge stall. shorties, intake, magnaflow exhaust.
2006 Red Ram 1500 SLT QC 5.7 4x2 Lonestar Edition GONE
Superchips Tuned Long Tube Headers W/ True 2.5" duals and high flow cats Ported Throttle Body CAI
2003 Laramie black 3500 dually 5.9 cummins. 6 speed trans -GONE
4" straight pipe, air raid CAI, edge chip, bullydog programmer on extreme, raptor rp100 lift pump, airbags.
Palomba is offline  
post #8 of 10 Old 12-21-2012, 11:35 PM
Jadesmarine
Let it go
 
Jadesmarine's Avatar
 
Join Date: Mar 2009
Location: 29 Palms, Ca
Posts: 956
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Palomba View Post
There prone to bad exhaust manifold bolts. There's a tsb out on it.
For what year and do you have this information?

_______________________
-Dan

14' Dodge Durango AWD R/T Hemi
14' Jeep Cherokee Altitude
Jadesmarine is offline  
post #9 of 10 Old 12-23-2012, 09:22 AM
mikereidjr
Technology Handyman
 
mikereidjr's Avatar
 
Join Date: Jul 2006
Location: Hampshire
Posts: 1,062
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I was told it was some kind of build up on the exhaust values there is a builtin supposedly I have never seen it and they were not able to da anything about it.

And I love that bit....

Mine = 2010 Dodge Ram 1500 TRX QC 4x4 HEMI
Hers = 2010 Jeep Grand Cherokee Limited 4x4 HEMI
mikereidjr is offline  
post #10 of 10 Old 12-23-2012, 09:36 AM
GermsHemi
Registered User
 
GermsHemi's Avatar
 
Join Date: Feb 2009
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by 2002 RAM 4 DOOR View Post
Im at 40,000 km. and mine is hit and miss when engine is cold occasionally it ticks like crazy for a few seconds and others it is perfectly quiet. I will check manifold studs when I change oil next. By the way it has had nothing but synthetic oil and napa gold filters since first oil change. My wifes Aspen has 120,000 km and it never ticks at all.
Mine similar to this. Very rarely it will do this. Mine does it when I start it and shut it off when it's not fully warmed up and I start it again and I'll hear the ticking noise for a couple seconds then it will go away. I swapped manifolds to shorties with new bolts and it has done it after that. So that rules out the bolts.


2009 RAM Hemi Sport 2WD CC
22" RT Alcoas
Superchips 93 tune
S&B Intake/scoop
Magnaflow catback/hiflow cats
JBA ceramic shorties
Belltech 963sp
GermsHemi is offline  
Closed Thread

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome