Rough idle cold... missing engine components - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 11-29-2012, 03:01 AM
keljen
Registered User
 
Join Date: Jun 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Rough idle cold... missing engine components

First of all, I will apologize for a long post as well as any missing or incorrect info I give. I don't know much about trucks but I wouldn't be here if I did.
Got this truck a little over 5 months ago, it's a 1991 Dodge Dakota v8 318 reg cab long box 2wd with throttle body.
When truck was first purchased seller told me that previous owner had been attempting to turn the truck into a drag truck.
The truck itself runs fine when it is warmed up, but as I am in Canada the issues it has when it's cold are not good.
The truck originally came from somewhere in the southern states. It has about 200,000+ miles (too cold out to go check exact mileage right now) and has excellent gas mileage.
The main problem I have noticed when driving the truck is that when it starts it idles very rough especially when the engine is cold as soon as the truck reaches normal temps it runs fine.
I've come across the following missing parts on the engine and I was wondering if there are any others I should be looking for (under the hood seems kinda empty like it may be missing other parts as truck was supposed to be turned into drag truck)
Idle air control
Heater block
Cruise control motor
The only other somewhat minor problems I have come across is that one bearing needs replacing and the oil gauge doesn't work tho oil levels are normal.
I'm hoping someone can give me some information as to what will fix the idle problem, if it isn't just the iac, as well as any other parts I may need to replace that could be missing.
I will try to get a pic as soon as its warm enough and not stormy outside.
keljen is offline  
Sponsored Links
Advertisement
 
#2 Old 11-29-2012, 11:29 AM
dodgef25
Crazy4x4RT
 
dodgef25's Avatar
 
Join Date: Sep 2007
Location: NM
Posts: 1,341
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The idle problem could be the IAC or a vacuum leak. The poor running when cold could be a bad coolant temp sensor.


My Youtube Videos! ---My Dana 44 SAS
"No truck should ever be lowerd! NEVER"
dodgef25 is offline  
#3 Old 12-06-2012, 08:33 PM
volaredon
older trucks ARE better!
 
Join Date: Oct 2008
Posts: 1,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
the 91 wont have an IAC it has a "stepper motor" that mechanically acts on the throttle (think of the old speedup solenoids on carb'd cars with AC, would extend a bit when the AC would kick on)

but the OP said something about missing the idle motor...
f25 youre thinking of the vac controlled thing on the Magnum motors...

sorry; they will be prying my "old" truck from my cold, dead, fingers!
the new ones make me want to
volaredon is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle/engine hesitation ryanideus 2G Dodge Dakota Performance Talk 3 10-15-2010 03:28 PM
5.9 missing (running rough) when cold? graphicmovement 3G Dodge RAM - General Talk 2 12-31-2008 02:40 PM
rough idle when cold peeweecollins 1972-1987 Dodge Ram Trucks (D, W-series) 3 07-27-2008 10:45 AM
cold start rough idle when cold dodge_johnny 2G Dodge Dakota General Talk 1 01-06-2008 10:34 AM
Rough idle on cold startup 3.9L Advice needed. Damn Dirty Ape 2G Dodge Dakota General Talk 2 06-06-2006 12:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome