Rough idle cold... missing engine components - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Dakota 1st Gen (87 -96) Forum

Closed Thread
 
Thread Tools

keljen
 
  Question Rough idle cold... missing engine components - Posted: 11-29-2012, 02:01 AM
Registered User
Joined: Jun 2012
Posts: 1
State: ON
Status: Offline
Post #1

First of all, I will apologize for a long post as well as any missing or incorrect info I give. I don't know much about trucks but I wouldn't be here if I did.
Got this truck a little over 5 months ago, it's a 1991 Dodge Dakota v8 318 reg cab long box 2wd with throttle body.
When truck was first purchased seller told me that previous owner had been attempting to turn the truck into a drag truck.
The truck itself runs fine when it is warmed up, but as I am in Canada the issues it has when it's cold are not good.
The truck originally came from somewhere in the southern states. It has about 200,000+ miles (too cold out to go check exact mileage right now) and has excellent gas mileage.
The main problem I have noticed when driving the truck is that when it starts it idles very rough especially when the engine is cold as soon as the truck reaches normal temps it runs fine.
I've come across the following missing parts on the engine and I was wondering if there are any others I should be looking for (under the hood seems kinda empty like it may be missing other parts as truck was supposed to be turned into drag truck)
Idle air control
Heater block
Cruise control motor
The only other somewhat minor problems I have come across is that one bearing needs replacing and the oil gauge doesn't work tho oil levels are normal.
I'm hoping someone can give me some information as to what will fix the idle problem, if it isn't just the iac, as well as any other parts I may need to replace that could be missing.
I will try to get a pic as soon as its warm enough and not stormy outside.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

dodgef25
 
 Posted: 11-29-2012, 10:29 AM
dodgef25's Avatar
Crazy4x4RT
Joined: Sep 2007
Posts: 1,341
City: NM
Status: Offline
View This User's Gallery View This User's Garage
View This User's Timeslip
Post #2

The idle problem could be the IAC or a vacuum leak. The poor running when cold could be a bad coolant temp sensor.
__________________

My Youtube Videos! ---My Dana 44 SAS
"No truck should ever be lowerd! NEVER"
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

volaredon
 
 Posted: 12-06-2012, 07:33 PM
older trucks ARE better!
Joined: Oct 2008
Posts: 1,468
State: IL
Status: Offline
Post #3

the 91 wont have an IAC it has a "stepper motor" that mechanically acts on the throttle (think of the old speedup solenoids on carb'd cars with AC, would extend a bit when the AC would kick on)

but the OP said something about missing the idle motor...
f25 youre thinking of the vac controlled thing on the Magnum motors...
__________________
sorry; they will be prying my "old" truck from my cold, dead, fingers!
the new ones make me want to
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle/engine hesitation ryanideus 2G Dodge Dakota Performance Talk 3 10-15-2010 02:28 PM
5.9 missing (running rough) when cold? graphicmovement 3G Dodge RAM - General Talk 2 12-31-2008 01:40 PM
rough idle when cold peeweecollins 1972-1987 Dodge Ram Trucks (D, W-series) 3 07-27-2008 09:45 AM
cold start rough idle when cold dodge_johnny 2G Dodge Dakota General Talk 1 01-06-2008 09:34 AM
Rough idle on cold startup 3.9L Advice needed. Damn Dirty Ape 2G Dodge Dakota General Talk 2 06-06-2006 11:53 AM



All times are GMT -5. The time now is 02:18 PM.





Privacy Statement