Please help! - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 11-16-2012, 12:17 PM
LeeR
Registered User
 
LeeR's Avatar
 
Join Date: Nov 2004
Location: Honolulu
Posts: 460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Please help!

Hey guys, been awhile since I've posted here! I'm soory to bother but I am in some desperate need of a little help!

I have an '03 Durango with 33k miles. Very lows miles but we do drive it.

Now its been about 2 weeks since the last time I dove it, but it has developed a very nasty habit!

When going 45 mph+, the right front (possibly both front) tire(s) will lock up and release. I locks up hard enough to make the tire screech a little and make you feel like you are going to headbut the dash. It scared the crap out of me the first time it happened, but since then, It has happened about 5-6 times back and forth to work yesterday.

Any one have any experiences like this? Pads are good, fluid is good, it's not a frozen caliper as it drives fine when it doesn't lock up. And when it does lock up, I'm not even touching the brake pedal, just driving like normal.

Please help!!!!

2007 Dodge 1500
Big Horn Edition
5.7 Hemi 2wd
LeeR is offline  
Sponsored Links
Advertisement
 
#2 Old 11-16-2012, 11:54 PM
D72Gladiator
DeeGladiator
 
D72Gladiator's Avatar
 
Join Date: Apr 2008
Location: SoCal
Posts: 1,172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
does it happen when you tap the brake pedal, or just cruisin?
are you on 4wd/2wd?
do you have front ABS?
sound freaky.

2000 Durango 4.7L 4x4 SLT+
9" Total Lift
Custom Welded Prerunner Bar w/Laser cut Logo w/Skidplate/3 9" Hid's w/Internal Ballast
Custom Made Fold Down Roof Light Bar w/4 9" Hid's w/Internal Ballast
Custom Made Rear Runner Bar w/2 100w Off Road Lights
Custom Chrome Front Grille w/2 55w Offroad Lights
Fiberglass Extended Prerunner Fenders
3" Longer Rancho RS 5000 Shocks
33x12.50x15 BF Goodrich Mud Terrian T/A KM2
15x8 Pro Comp Xtreme Alloys
Pro Comp Xtreme Offroad Wheel rings
LED Turn Signal Lights w/Heated Mirrors
LED Red Tail Lights
McCullouch 8000K HID Headlights
Diamond Chrome Housing Headlamps
Royal Purple in ALL fluids
CAI w/K&N Filter
Optima Red Top Battery
Drilled and Slotted Front Rotors
Hawk HPS Brake Pads Front
Black Tinted Windows All Around
Mag-Hytec Rear Diff Cover - Powder Coated Hyper Silver
9.25 Auburn High Performance Series LSD
Gibson Superflow Muffler
Motive 4.56 gears

_____________________
Future Mods
Throw entire front suspension away (including Rancho kit, and BL) and go all LT out!
D72Gladiator is offline  
#3 Old 11-17-2012, 02:15 AM
LeeR
Registered User
 
LeeR's Avatar
 
Join Date: Nov 2004
Location: Honolulu
Posts: 460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Just driving, not even touching the brake pedal. it is 2wd with abs. Thanks!

2007 Dodge 1500
Big Horn Edition
5.7 Hemi 2wd
LeeR is offline  
#4 Old 11-17-2012, 08:01 AM
dodgefan360
Platinum 2K R/T
 
dodgefan360's Avatar
 
Join Date: Jan 2005
Location: Kitchener
Posts: 4,037
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'd hope you have 4w ABS for this to happen. If not, it would make it seem even more scary to have the brakes randomly pulsate.

My guess would be a faulty ABS relay. Moisture, even in warmer climates can wreak havoc on vehicles that aren't driven regularly, or taking short trips where the vehicle cannot warm up properly to operating temp for at least 10 minutes to evaporate any condensation built up.

My 2000 always gave me some pull when starting out in the morning. Going out of my driveway the ABS would be overly cautious and grab the brakes when it's not needed. I pulled the relay out for one winter as the ice was very bad and the ABS would kick on constantly not allowing the vehicle to stop but merely kicking the tire(s) forward. Removed the relay and all was great. It did show the engine light so I put the relay back in when the weather warmed up. I know the 2000 model is the odd ball of the group for many things, so hopefully you can do something similar with your 2003 to see if that's the cause of your problem.

2000 5.9 R/T - Platinum
144,000m (233,000kms)
Amsoil in the diffs, transfer case and engine - Hughes Plenum - Fastman 52mm TB - K&N FIPK - SCT tuner currently set at 87 octane - Magnaflow 15659 exhaust

My 2000 R/T
2000 R/T Factory service Manual
dodgefan360 is offline  
#5 Old 11-17-2012, 03:11 PM
LeeR
Registered User
 
LeeR's Avatar
 
Join Date: Nov 2004
Location: Honolulu
Posts: 460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for your help! I kinda felt it was abs related. Ill probably swap out the module and ill report back here if it fixes it!

2007 Dodge 1500
Big Horn Edition
5.7 Hemi 2wd
LeeR is offline  
#6 Old 11-17-2012, 06:29 PM
dodgefan360
Platinum 2K R/T
 
dodgefan360's Avatar
 
Join Date: Jan 2005
Location: Kitchener
Posts: 4,037
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You don't need to swap it just yet. Just pull it out and leave it out for a quick drive. Now, the relay might affect some other systems, like say interior lighting or something along that line, and/or set off the parking brake light/ABS light when you remove it, so just be aware of that. If the braking problem goes away with the ABS relay removed, the relay itself might be your issue.

Each hub (wheel bearing) also has an ABS sensor attached to it, although to have both front wheels act similar when you're driving still points to the relay itself. Also make sure that the brakes have sufficient fluid in the reservoir.

2000 5.9 R/T - Platinum
144,000m (233,000kms)
Amsoil in the diffs, transfer case and engine - Hughes Plenum - Fastman 52mm TB - K&N FIPK - SCT tuner currently set at 87 octane - Magnaflow 15659 exhaust

My 2000 R/T
2000 R/T Factory service Manual
dodgefan360 is offline  
#7 Old 11-17-2012, 07:23 PM
LeeR
Registered User
 
LeeR's Avatar
 
Join Date: Nov 2004
Location: Honolulu
Posts: 460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Alright, I'll give it a try today. I really appreciate you time & help!

2007 Dodge 1500
Big Horn Edition
5.7 Hemi 2wd
LeeR is offline  
#8 Old 11-17-2012, 07:26 PM
dodgefan360
Platinum 2K R/T
 
dodgefan360's Avatar
 
Join Date: Jan 2005
Location: Kitchener
Posts: 4,037
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
No problem at all, that's why we're all here!

Keep us posted on your results...

2000 5.9 R/T - Platinum
144,000m (233,000kms)
Amsoil in the diffs, transfer case and engine - Hughes Plenum - Fastman 52mm TB - K&N FIPK - SCT tuner currently set at 87 octane - Magnaflow 15659 exhaust

My 2000 R/T
2000 R/T Factory service Manual
dodgefan360 is offline  
#9 Old 11-19-2012, 10:05 PM
LeeR
Registered User
 
LeeR's Avatar
 
Join Date: Nov 2004
Location: Honolulu
Posts: 460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
OK, so I unplugged to connector to the ABS module and it is STILL doing the same thing. When the brakes lock up, it does not pull to one side which leads me to believe that both fronts are locking up. For all I know, the rears may be being applied as well but only the front tires screech.

any other ideas?

To review, here are my symptons.

1. Front brakes randomly locking up for about 1 second causing front tires to screech.

2. It happens @ around 45-60 mph definitely not happening beloew 45, to scared to drive it past 60 mph for now.

3. Happens randomly, I'm not even touching the brake pedal.

4. it happens both on uhill and downhill roads.

5. No lights on in the dash

2007 Dodge 1500
Big Horn Edition
5.7 Hemi 2wd

Last edited by LeeR; 11-19-2012 at 10:20 PM.
LeeR is offline  
#10 Old 11-19-2012, 10:38 PM
dodgefan360
Platinum 2K R/T
 
dodgefan360's Avatar
 
Join Date: Jan 2005
Location: Kitchener
Posts: 4,037
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I can't begin to estimate what might be wrong. I'd 'guess' the master cylinder or brake booster is causing the problem. If it's vacuum pressure related you may get away lucky if there's a cracked line somewhere, or something causing a quick jolt in pressure that might cause the brakes to grab, but I'd still point toward a bad component such as the master cylinder or brake booster.

If you have added brake fluid and can't find a leak, or you've been adding it slowly throughout the time you've had the vehicle, the fluid might be leaking into the booster itself, which holds a diaphragm and can cause variable problems. The master cylinder contains multiple springs and plungers that move at different intervals so the higher pressure goes to the front pads, instead of the rear pads or shoes. If there is dirt inside, it can prevent the springs from moving to allow fluid through, or in your case, they're stuck open ever so slightly. Well, I 'guessed'...

Unless someone else chime's in you may have to take it in for a proper diagnosis at a local shop.

2000 5.9 R/T - Platinum
144,000m (233,000kms)
Amsoil in the diffs, transfer case and engine - Hughes Plenum - Fastman 52mm TB - K&N FIPK - SCT tuner currently set at 87 octane - Magnaflow 15659 exhaust

My 2000 R/T
2000 R/T Factory service Manual
dodgefan360 is offline  
#11 Old 11-24-2012, 09:52 PM
B1G BLEU
WORLD'S GREATEST TRUCK
 
B1G BLEU's Avatar
 
Join Date: Sep 2003
Location: W. Hempstead
Posts: 4,418
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Abs applies the brakes? I thought it only releases pressure to the calipers and brake cylinders

Paul
02 Durango (build 11/01) SLT┼ AB/BLACK INT 4.7L NGC 45RFE PT3.55 LSD 4X4 - Superchips 3715 Performance - Sensatracs - Chrome Nose - Carriage Works Billet Grilles - APC Clear Corners - Infinity 6022i's w/stock tweeters - - Hidden Hitch - Silverstar 9007ST's - K&N high-flow 33-2175 air filter- TFP Chrome Handles - 33K Miles - (MB Gunner Chrome Wheels + General Grabbers wintering in basement) Hammered blue factory rims
Wife's Ride : 2006 Grand Caravan SXT INFERNO RED
Work Ride : 2009 Ford Edge SEL
Daughter's Ride : 2011 Jeep Compass Latitude
Son 1's Ride : 2012 Nissan Altima S Coupe
Son 2's Ride : 2006 STi Stage 2 Grandma Gray (kinda mine, too)
B1G BLEU is offline  
#12 Old 11-25-2012, 08:56 AM
dodgefan360
Platinum 2K R/T
 
dodgefan360's Avatar
 
Join Date: Jan 2005
Location: Kitchener
Posts: 4,037
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your thought is correct.

The ABS is (at least in my Durango) overly sensitive if there is moisture in the air that morning. Going from fall to winter I find is the worst. Roads are slick (driveways too) and for the first several hundred meters I just touch my brake pedal and the ABS kicks in. I was lucky to pull the relay/fuse for my ABS system until the snow is here to stay, otherwise ABS is more dangerous when it's overly sensitive. It pulses it (mine sounds like it moans like a dying animal when it kicks in during cooler weather - its odd) and the tire slides over the irregular asphalt surface even if the slippery ice patch is long gone. I can't even slow down on a road covered in leaves or my ABS will kick in like something fierce even with a slight tap of the pedal. It's very annoying.

2000 5.9 R/T - Platinum
144,000m (233,000kms)
Amsoil in the diffs, transfer case and engine - Hughes Plenum - Fastman 52mm TB - K&N FIPK - SCT tuner currently set at 87 octane - Magnaflow 15659 exhaust

My 2000 R/T
2000 R/T Factory service Manual
dodgefan360 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome