UPDATE: ABS and Brake light -- NOT THE REAR SPEED SENSOR - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 07-30-2011, 06:25 PM
Intense-Dakota
Registered User
 
Intense-Dakota's Avatar
 
Join Date: Jul 2003
Location: Joliet
Posts: 196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question UPDATE: ABS and Brake light -- NOT THE REAR SPEED SENSOR

So, for a while now, I have been having issues with the ABS and Brake light coming on from time to time. I always just lived with it. I have never had problems with the spedo, untill yesterday when it started going up in increments. So, I decided to finally change the rear speed sensor in the diff. The brake light and ABS are still coming on. Here are the details... It does comes on faster in hot weather, and sometimes does not come on untill I hit a bump in the road. Other times, it comes on as soon as I start the truck up. Now, during the winter, sometimes I could drive 5 miles to work and it would not come on at all. I do know that even when the ABS light is on, the ABS still engages (found out the hard way... on ice.) Now, the WIERD part. I was hauling about 1800 lbs of paving stones for my brother and during a hot day and on a 20 mile trip, the light NEVER came on. But as soon as I emptied my truck and was heading home, it came right on. So, I believe there is a short or something somewhere, but cannot figure out where to start.

Does anyone know where the wires (from the rear speed sensor) go to. Such as, the ECU, the ABS module, etc... and what color the wires are there?

I have already replaced the front two wheel hubs and ABS sensors, the back ABS sensor (in the diff) and I have also replaced the transmission (last year) along with all sensors on it. All with no change. I dont think it has anything to do with it, but I also replaced the computer last year (due to a different problem). I have checked and cleaned the connections at ABS module under the hood also.

I am stumped and I would rather fix it myself then pay the stealer ship $500+ to say they can't find the problem, or $1000 to replace a $50 part.

The truck is a 1999 Ram 1500 4x4 with 4 wheel ABS and it is an 5.9L auto. Everything in both the front and rear axles is stock and I have the same size tires all around.

win or lose, knowing you gave it your best you finish a champion......

1999 Dodge Ram 4x4 Sport 5.9L 360 QC

Last edited by Intense-Dakota; 08-16-2011 at 11:22 AM.
Intense-Dakota is offline  
Sponsored Links
Advertisement
 
#2 Old 07-30-2011, 08:21 PM
nekked bob
Registered User
 
Join Date: Apr 2009
Location: wilton
Posts: 300
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had a similar problem and found that the wire from the rearend sensor was broken at the point that it attaches to the frame rail.Mine was to close to the gas tank for me to fix it without dropping the tank so I just unplugged the ABS box under the dash(didn't really care for the ABS anyway).

1998 2500 qcsb 24v
5 speed 4x4
stock and unmolested
nekked bob is offline  
#3 Old 07-30-2011, 10:35 PM
BigGreenV10
Big Green
 
BigGreenV10's Avatar
 
Join Date: Jan 2007
Location: Newark, Ohio
Posts: 8,318
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I might have to check for a wire I got new rear sensor and new hubs went out for a while then back on.

POWDER COAT CLUB MEMBER #1
DON'T TOUCH OUR TRUCK CLUB #2
GREEN TRUCK CLUB MEMBER #31
V10 RAM CLUB MEMBER # 35
MILITARY TRUCK CLUB #147
CRACKED DASH CLUB # 32

2000 2500 V10 4x4 Ext. cab 6" suspension 37 x 12.5 x 16.5 with 4.88 gears.
SCT tuner, Cold air and custom exhaust.
Tail lights, fuel filler door and tail gate handle shaved. Body color fiberglass bed cover and fender flares. Custom all steel 4" cowl hood, custom front bumper.
100% Xtreme Kreations Club President looking for members
BigGreenV10 is offline  
#4 Old 08-16-2011, 11:21 AM
Intense-Dakota
Registered User
 
Intense-Dakota's Avatar
 
Join Date: Jul 2003
Location: Joliet
Posts: 196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
UPDATE: I have -

checked all wiring from RWAL ABS to the ABS controller - continuity is good
checked all wiring from Output Speed sensor (on trans) to ECU - continuity is good
check RWAL sensor (even though I just replaced it)
cleaned all connectors with electrical cleaning spray
check brake switch (near brake pedal)
reset ECU (unplugged for about 1 hours to be safe as well as unplugged ABS module)
checked ground to ABS module
checked all ABS related fuses.

I AM COMPLETLELY LOST NOW...

I purchased the ACTRON 9580 scanner thinking it would read the ABS code, but it doesnt read Ram ABS codes untill model year 2002.

I really don't want to take it to the dealership.

I am wondering if a complete brake system bleed would help, or if it is possible anything with the rear brakes (such as drums or cylinders).

ANY Ideas are greatly appreciated.

win or lose, knowing you gave it your best you finish a champion......

1999 Dodge Ram 4x4 Sport 5.9L 360 QC
Intense-Dakota is offline  
#5 Old 08-17-2011, 07:03 AM
Moparite
Senior Member
 
Moparite's Avatar
 
Join Date: Jun 2006
Posts: 2,806
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
You need to find out what is the issue that turned the lights on to begin with. You have to ground out one of the pins on the data link connector to get the code(fault). I dont remember witch one and you need a book that has the abs codes in it. Might be easier to go to the dealer and ask how much to find out what set the fault.
Moparite is offline  
#6 Old 08-17-2011, 08:03 AM
Intense-Dakota
Registered User
 
Intense-Dakota's Avatar
 
Join Date: Jul 2003
Location: Joliet
Posts: 196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I believe the grounding the pin (pin 13 I believe) only works up through 97. I don't believe it works from 98 on.

win or lose, knowing you gave it your best you finish a champion......

1999 Dodge Ram 4x4 Sport 5.9L 360 QC
Intense-Dakota is offline  
#7 Old 08-17-2011, 08:23 PM
kxcrazy
Registered User
 
Join Date: May 2011
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check your wiring that goes to the the connector on the base of the brake reserviour.

My abs and brake light came on this weekend due to one of those wires having a break in it. Fixed the break and no more lights.
kxcrazy is offline  
#8 Old 08-25-2011, 07:02 PM
///VADER\\\
Registered User
 
Join Date: Apr 2004
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
OP, please keep us updated, I am experiencing the exact same situation and have done everything you have. I am so pissed that I cannot find it.

If I find anything, I will PM you.
///VADER\\\ is offline  
#9 Old 08-25-2011, 08:12 PM
Intense-Dakota
Registered User
 
Intense-Dakota's Avatar
 
Join Date: Jul 2003
Location: Joliet
Posts: 196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I didn't realize there was wires one the reservoir, but I will check that and let you know.

win or lose, knowing you gave it your best you finish a champion......

1999 Dodge Ram 4x4 Sport 5.9L 360 QC
Intense-Dakota is offline  
#10 Old 08-25-2011, 08:46 PM
Intense-Dakota
Registered User
 
Intense-Dakota's Avatar
 
Join Date: Jul 2003
Location: Joliet
Posts: 196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Ok. I had to go out with the flashlight and look. I do not have any wires on or near the rervoir

win or lose, knowing you gave it your best you finish a champion......

1999 Dodge Ram 4x4 Sport 5.9L 360 QC
Intense-Dakota is offline  
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Light Problem...Not rear sensor EvilBrutus90 2G Dodge RAM - General Talk 14 05-12-2010 01:39 AM
How To. Vechicle Speed Sensor. (speedometer, ABS, Brake) ruprectgern 3G Dodge RAM - General Talk 8 07-15-2009 02:24 PM
Weird problem....brake or speed sensor? Rotnik2500 2G Dodge RAM - General Talk 6 05-21-2008 03:30 PM
Replaced rear wheel speed sensor and ABS light still on sbeausol 2G Dodge Dakota General Talk 4 04-02-2006 08:56 PM
ABS/Brake light on, Even with NEW Speed Sensor Ted_Z 2G Dodge RAM - General Talk 6 08-31-2004 10:00 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome