98 Ram 2500 diesel, Tach/Shifting problem - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 10-23-2004, 06:52 PM
wayne_vidalia
Registered User
 
Join Date: Oct 2004
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 98 Ram 2500 diesel, Tach/Shifting problem

I have a 98 Ram2500 with 5.9L Cummins, A/T, The Tach stopped working and the transmission does not want to shift out of first. I have checked all the fuses, replaced fluid and filter in trans., checked speed sensor, and all possible wire conections I can see and think to check. This is my first diesel, I am out of ideas. If anyone has an idea on what else to check before I take it to the shop, please let me know.
wayne_vidalia is offline  
Sponsored Links
Advertisement
 
#2 Old 10-28-2004, 10:59 AM
Meierznutz
Older, but no wiser.
 
Meierznutz's Avatar
 
Join Date: Oct 2004
Location: Oakville, Ct
Posts: 989
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Has the check engine light come on yet? I've had the check light come on in a Grand Caravan when the trans felt fine. Scancode said it was for metal in the trans pan. If you have the ALDL scanned at Autozone, it may turn up something. AZ will usually do it for free. The only other thing I can think of is a loose or broken vacume line, used to cause the same symptoms on Chevy turbo 350's and 400's.
The tach dropping out tells me it could be in the CPU. Check the connector to it(firewall,passenger side) as trans function are controled by it too.
Good luck... Chris
Meierznutz is offline  
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome