ESP/BAS/ABS Error - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 12-12-2010, 09:23 AM
soad
Registered User
 
soad's Avatar
 
Join Date: Dec 2005
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
ESP/BAS/ABS Error

I have an 09 Ram with 11,000 miles on it. Last night when driving home a whole bunch of lights when off on my truck. The ABS light, the ESP light, the EVIC said "park assist off" and said "ESP BAS" and "Service 4wd". This stayed on for 5 minutes then turned off. But after another few minutes it started going on and off every 30 seconds or so the whole way home (over an hour). This morning it is doing the same thing.

Two questions: Obviously I'm going to call the dealership on Monday morning, but I have to work and will have to drive the truck in the 8-12 inches of snow we are getting tomorrow....is the truck safe to drive with all this stuff turning on and off constantly?

Will whatever is wrong be covered under factory warranty? I really don't want to spend any money right now

Thanks!

2009 Ram CC Sport 4x4 Hemi Chick Magnet
2007 Durango 4x4 Hemi Grocery Getter
soad is offline  
Sponsored Links
Advertisement
 
#2 Old 12-12-2010, 09:42 AM
mattyb777
Registered User
 
mattyb777's Avatar
 
Join Date: Oct 2009
Location: Brimley
Posts: 268
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I also have an 09 with 10,300 miles and I had the ABS, BRAKE, ESP MDS, TRACTION CONTROL lights come on and stay on last night while driving....

another member told me to check the electrical connections that go to the wheel hubs for the ABS....which I havent had a chance to do yet.

Not sure if this helps....I hope more members can chime in

2012 Ram 1500 CC 4x4 / Mineral Grey / MyGig RBZ / Locpic v5 / Back-up Cam /

COMING SOON:
LOTS!
mattyb777 is offline  
#3 Old 12-12-2010, 10:09 AM
SnowDogs
Registered User
 
SnowDogs's Avatar
 
Join Date: Aug 2009
Location: Lincoln Heights
Posts: 601
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would be cautious about the ABS, you will be able to stop just may not have the ABS. Can you take it to a parts store that lets you use their scanners for free to see if it will pickup anything? Advanced Auto and Auto Zone both have this service around here.

Your factory warranty will cover everything, 3 years or 36,000 miles bumper to bumper except tires, brake pads, wiper blades. If you have an extended warranty you would have to pay the deductable but only after the 3/36 warranty was over.

I Love my fur-wheel-drive !!!


4th Gen Truck Club member #28
Orange Truck Club member #25
2009 Dodge Ram 1500 QC sunburst Orange
2010 Dodge Nitro Detonator Stone White (wife's ride)
3 Siberian Huskies 2, 3 and 4 years old and a good ole dogsled. Much more fun than any vehicle!
SnowDogs is offline  
#4 Old 12-12-2010, 10:30 AM
hemisport25
2k10 Ram 1500 Sport
 
hemisport25's Avatar
 
Join Date: Aug 2005
Posts: 181
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
As already mentioned, these problems sound like a wire harness coming apart ultimately disconnecting sensors from the ECU..
hemisport25 is offline  
#5 Old 12-12-2010, 05:07 PM
soad
Registered User
 
soad's Avatar
 
Join Date: Dec 2005
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Well, I needed to go to the store. I pulled the truck out of the garage the lights were going on and off. I put the truck in drive and while still standing still the spedo was going between 0 and 15mph. I slowly hit the gas and heard the grinding that you get when the truck loses traction (the ABS or the ESP....I'm not sure) the truck kinda jumped forward, and then it went normally. At the stop sign it did the same thing so I just turned around.....

Will the dealership tow it for me under the factory warranty if I call? I am really hesitant to drive it right now.

2009 Ram CC Sport 4x4 Hemi Chick Magnet
2007 Durango 4x4 Hemi Grocery Getter
soad is offline  
#6 Old 12-12-2010, 06:05 PM
blackhemi4x4
Shut up and drive!
 
blackhemi4x4's Avatar
 
Join Date: Sep 2007
Location: Loganville
Posts: 2,899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My dealership towed me for free. They did inform me that I would be responsible if it turned out not to be a warranty issue.

You should be fine

2010 Ram 1500 QuadCab 4x4 5.7 HEMI Big Horn



mods: debadged
future mods: Exhaust, tires, tow hooks, skid plates, a/t tires, red brake calipers, maybe a tuner, line-x, 12" ported sub under a seat, colormatched grille
-Will be keeping it mostly stock.

My G/F also has the same truck, only hers is 100% stock-2010 Ram 1500 QuadCab 4x4 5.7 HEMI Big Horn



Former owner of 2007 Ram QC 4x4 BigHorn 5.7
99 Neon ES auto
01 Neon ES 5 speed
a handful of dodge Shadows (4 of them, all running)
early 90's D50

Im no longer amotorkat :P

blackhemi4x4 is offline  
#7 Old 12-13-2010, 10:20 AM
jball
Registered User
 
Join Date: Jan 2010
Location: Marshall, MI
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Do the key check real quick, cycle from on-accessory (repeat 3 times) and leave it in the on position.

It will flash any diagnostic trouble codes where your odometer is if there is something wrong.
jball is offline  
#8 Old 12-13-2010, 10:32 AM
BMRbrnSNRbrd
Try harder
 
BMRbrnSNRbrd's Avatar
 
Join Date: Jan 2008
Location: Norman
Posts: 13,234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Definitely shouldn't drive and the dealership better tow it.


Mineral Gray 2010 Dodge Ram CC Hemi Sport


Exterior: Limo tint | Painted tips | Painted calipers | De-badged | Painted grill inserts | Gloss black b-pillars | Color matched antenna base |
VHT tinted puddle lights | Color matched tailgate handle | Shaved and two-toned grill | Painted Vararam lid w/ two-toned Ram badge |
Color matched Laramie 2500 flares | Shaved tailgate badge | Shortened and painted antenna
Lighting: Color matched headlights retrofitted with 5000k Morimoto projectors |
5000k HID fog lights tinted with Lamin-x | 6000k HID retrofitted reverse lights
Interior: Color matched interior plastics | 2 MTX 12" subs in a cheap box | REN MyGig 30gb headunit | Black microsuede wrapped headliner and sun visors | Black microsuede wrapped and shaved pillars | Black microsuede wrapped custom made door inserts | SEM black painted interior plastics
Suspension: McGaughy's 2/5 Economy drop | BrakeMotive cross-drilled and slotted rotors | All black Milano M724 22s | 305/40R22 Nitto 420s | AirLift Helper Bags
Performance: Superchips Vivid Paq w/ trans tuning | Vararam Air Grabber | Magnaflow 18" Muffler | Raceland USA E-Cutout |
Billet Technology Oil Catch Can | Clutch fan delete | 180 T-stat | Magnaflow Y-Pipe with relocated crossover pipe

BMRbrnSNRbrd is offline  
#9 Old 12-13-2010, 10:39 AM
Moparn4life
Registered User
 
Join Date: Jul 2009
Posts: 288
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You have a bad wheel speed sensor. I had one go bad last winter. It took the dealer 4 trys to get it fixed. replaced the TIPM, ABS sensor and finally a rear wheel speed sensor to get it fixed. I also had intermittant brakes being applied when going down the road - since the wheel speed sensor was malfunctioning & telling the abs sensor that wheel slip was occuring. It was very weird driving it. The dealer told me that it was ok to drive - though I didn't much.

2009 Ram 1500 Crew TRX4
Moparn4life is offline  
#10 Old 12-13-2010, 11:06 AM
soad
Registered User
 
soad's Avatar
 
Join Date: Dec 2005
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
The tow truck just picked my baby up. I called the dealership this morning, he told me to call Chrysler Roadside Assistance. The lady from there was real nice and now I'm just waiting at home for them to call.....had to call off work today....

2009 Ram CC Sport 4x4 Hemi Chick Magnet
2007 Durango 4x4 Hemi Grocery Getter
soad is offline  
#11 Old 12-13-2010, 11:09 AM
dmcelhannon
Moderator David Mack
 
dmcelhannon's Avatar
 
Join Date: Apr 2006
Location: McAllen
Posts: 28,842
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
I'd have it towed but it's up to the dealer if they pay for it or not; some do and some don't. But there's now way I'd drive-it even around the block.

If you start a thread, be responsible and post the final outcome.


2002 Ram 1500 SLT 4x4 QC
*****
~ Waiting to replace my Ram! ~ 2014 October 23rd WAS Judgement Day! ~
*** After 849-Days (2-Years 119-days) We Nailed Their A$$ to the Barn Door ***



~~~~~~~~~~~~~~~~~~~~~


Rio Grande Valley Make-A-Wish Foundation's Raffle


Tickets are now available for purchase directly from the Rio Grande Valley Make-A-Wish office. They can be reached at (956) 686-9474. Even if you are from out of town you can participate because you do not need to be present to win.

1971 Dodge Charger Superbee


Click the Superbee link to see the whole timeline thread....



dmcelhannon is offline  
#12 Old 12-13-2010, 04:20 PM
soad
Registered User
 
soad's Avatar
 
Join Date: Dec 2005
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So the dealership called a few hours ago and said it was a bad wheel sensor (good call guys ) They said they didn't have the part but would get one in tomorrow. They just called back and said that they were able to fix the sensor and will not have to replace it....does this make sense? I REALLY don't want this to happen again, will just fixing instead of replacing lead to more trouble in the future? They still are going to keep it overnight to do 2 recalls on the truck.

Thanks for all your help guys!

2009 Ram CC Sport 4x4 Hemi Chick Magnet
2007 Durango 4x4 Hemi Grocery Getter
soad is offline  
#13 Old 12-13-2010, 04:25 PM
BMRbrnSNRbrd
Try harder
 
BMRbrnSNRbrd's Avatar
 
Join Date: Jan 2008
Location: Norman
Posts: 13,234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Glad to hear you got it worked out. If it were me, I would call back and ask them how they fixed it and what was wrong to begin with. I agree that it needs to be fixed correctly so the same issue doesn't catch you off guard again.


Mineral Gray 2010 Dodge Ram CC Hemi Sport


Exterior: Limo tint | Painted tips | Painted calipers | De-badged | Painted grill inserts | Gloss black b-pillars | Color matched antenna base |
VHT tinted puddle lights | Color matched tailgate handle | Shaved and two-toned grill | Painted Vararam lid w/ two-toned Ram badge |
Color matched Laramie 2500 flares | Shaved tailgate badge | Shortened and painted antenna
Lighting: Color matched headlights retrofitted with 5000k Morimoto projectors |
5000k HID fog lights tinted with Lamin-x | 6000k HID retrofitted reverse lights
Interior: Color matched interior plastics | 2 MTX 12" subs in a cheap box | REN MyGig 30gb headunit | Black microsuede wrapped headliner and sun visors | Black microsuede wrapped and shaved pillars | Black microsuede wrapped custom made door inserts | SEM black painted interior plastics
Suspension: McGaughy's 2/5 Economy drop | BrakeMotive cross-drilled and slotted rotors | All black Milano M724 22s | 305/40R22 Nitto 420s | AirLift Helper Bags
Performance: Superchips Vivid Paq w/ trans tuning | Vararam Air Grabber | Magnaflow 18" Muffler | Raceland USA E-Cutout |
Billet Technology Oil Catch Can | Clutch fan delete | 180 T-stat | Magnaflow Y-Pipe with relocated crossover pipe

BMRbrnSNRbrd is offline  
#14 Old 12-13-2010, 06:02 PM
King
Registered User
 
Join Date: Aug 2008
Posts: 712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The plugs come loose and there is a RRT for the repair. Simply clean the connection and plug back in.. People with lifts have a better chance of having the problem.

His 2011 2500 4x4 Cummins crew ....Hers 2011 Ford Eco Boost Crew... Daughter 09 Inferno Red SLT Crew Cab loaded.
King is offline  
#15 Old 12-13-2010, 06:19 PM
soad
Registered User
 
soad's Avatar
 
Join Date: Dec 2005
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by BMRbrnSNRbrd View Post
Glad to hear you got it worked out. If it were me, I would call back and ask them how they fixed it and what was wrong to begin with. I agree that it needs to be fixed correctly so the same issue doesn't catch you off guard again.
Quote:
Originally Posted by King View Post
The plugs come loose and there is a RRT for the repair. Simply clean the connection and plug back in.. People with lifts have a better chance of having the problem.

Thanks guys! I don't have a lift, I guess I'm just unlucky Would that RRT be "09-041 -- 2009 DS flash ABS/ESP module" or another one? I just want to double check with the mechanic when I talk to him tomorrow.

2009 Ram CC Sport 4x4 Hemi Chick Magnet
2007 Durango 4x4 Hemi Grocery Getter
soad is offline  
#16 Old 12-13-2010, 06:28 PM
King
Registered User
 
Join Date: Aug 2008
Posts: 712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not 100% sure but there is one for checking the connections at the wheel hubs.

His 2011 2500 4x4 Cummins crew ....Hers 2011 Ford Eco Boost Crew... Daughter 09 Inferno Red SLT Crew Cab loaded.
King is offline  
#17 Old 01-10-2011, 12:12 PM
RogueOps
Registered User
 
RogueOps's Avatar
 
Join Date: Mar 2010
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Moparn4life View Post
You have a bad wheel speed sensor. I had one go bad last winter. It took the dealer 4 trys to get it fixed. replaced the TIPM, ABS sensor and finally a rear wheel speed sensor to get it fixed. I also had intermittant brakes being applied when going down the road - since the wheel speed sensor was malfunctioning & telling the abs sensor that wheel slip was occuring. It was very weird driving it. The dealer told me that it was ok to drive - though I didn't much.
Yes this is the problem, i have about 127 000km on my 09 laramie 4x4, It ust happend to me again this morning on the way to work, this is the 9th time i will now have to take it in, its always the rear abs/speed sencor in the back wheels, always either a bad connection to the sencor or the wireing harness fails, the first time they didnt warranty it cause it was muddy and "warranty doesnt cover off highway driving" so after that when ever it happens i spend about 2 hrs washing it including the frame and suspension so they cant say anything about off highway driving and they warranty it, i find it usually happens if i hit a bad set of washboards it seems to dislodge the connection to the sencor, ive told them this but they dont actually fix anything just replace sencors so it keeps happening, usually takes 2-3 tries for them to fix the connection problem before it clears and stays cleared. I do have 2" blocks in the back but had the problem several times before the blocks were installed
RogueOps is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error code 0601 - Control Module ROM Error phildog 2G Dodge RAM - General Talk 1 12-07-2005 05:10 PM
ABS Error Light & Brake Error Light 78RamCharger01D 1G Dodge Durango General Talk 7 09-11-2005 03:54 PM
Log out error mopar fan DodgeTalk.com Site Feedback and Ideas 2 05-01-2004 06:37 PM
Error NJRamFreak DodgeTalk.com Site Feedback and Ideas 4 07-07-2003 10:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome