Oil Light comes on after a cold night and morning start - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 11-03-2010, 12:19 PM
kressley
Registered User
 
Join Date: Jul 2005
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Oil Light comes on after a cold night and morning start

Using Mobil1 5W20 as it states in the manual. Nights have been in the 30's lately. Oil was just changed last month, so it's "fresh"

If I turn off the engine and restart light does not stay on...

Is this just a factor of the cold engine start, or possibly the start of something more serious?
kressley is offline  
Sponsored Links
Advertisement
 
#2 Old 11-03-2010, 02:50 PM
MJB8
Registered User
 
MJB8's Avatar
 
Join Date: Aug 2008
Posts: 1,724
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If you dont restart it does the light go off after a few seconds?

You may have a oil filter that the check valve isnt holding and your getting alot of drain back so it takes a few seconds to refill. If the light doesnt go out with out restarting it sounds electrical since it will go out after a restart. If you dont have oil pressure it would never go out. To be sure you could hook up a manual gauge



2008 SRT Prototype Under Construction
Dodgetalk.com 287 Enthusiast Member # 289
K&N CAI, ,Summer Polished OEM SRT 22" Wheels , Yokahama 305/40/22 Parada Spec X, Winter Durango 20" 265/50/20 Yokahama Parada Spec X VVME HID's 5000k Heads & Fogs, Mobile 1... Bilsteins, 15% Tint. FlowMaster Cat Back, American Thunder Exhaust.
Dropped a bit, more to come.

"Take a Kid Fishing"

MJB8 is offline  
#3 Old 11-04-2010, 10:35 AM
aypanthony
Registered User
 
aypanthony's Avatar
 
Join Date: Jul 2005
Posts: 377
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by kressley View Post
Using Mobil1 5W20 as it states in the manual. Nights have been in the 30's lately. Oil was just changed last month, so it's "fresh"

If I turn off the engine and restart light does not stay on...

Is this just a factor of the cold engine start, or possibly the start of something more serious?
Common issue. The oil pressure sending unit is bad. It happened to me as well. During the summer, no light. Once it started getting cold, the light would come on. However, after a restart, the light would go away.

Replace the sending unit and you should be good to go.

'04 Durango 5.7L Hemi Limited
Power Wire
T-Bar Crank, Bull Bar
4" Off-Road Lights,
Yakima Low-rider towers w/bars
Gibson Swept Side Exhaust
Hankook ATM "33
Bilstein Shocks
1.5" wheel adapters

aypanthony is offline  
#4 Old 11-04-2010, 07:09 PM
Don Fox
Registered User
 
Don Fox's Avatar
 
Join Date: Jul 2006
Posts: 1,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Kressley

What year is your Durango and which engine do you have? My 04 Hemi had the same issue. When cold, the oil light would stay on for the first start of the day and then off from the 2nd start on.

Got the new oil sender from Autozone and it was a quick and easy install. Gotta say though that I had not had the D very long, and the first time it stayed on my heart skipped.

I knew everything was good to go though as I did not hear that sickening sound of valve train rattle.

Don

2004 SLT Hemi Durango AWD Flame Red
w/ 3.55 gears. New in the stable since 03/26/10.

05 Linen Gold Pearl Grand Caravan SXT
w/3.8L (hers) since 09/30/06

Last edited by Don Fox; 11-04-2010 at 07:23 PM.
Don Fox is offline  
#5 Old 11-06-2010, 06:35 PM
matted2thefloor
Registered User
 
matted2thefloor's Avatar
 
Join Date: Dec 2008
Location: SC
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Good point, Don...if your oil light EVER comes on but there is NO engine noise/clatter...chances are very good it is NOT an oil pressure issue.


04 D 5.7 SLT AWD (hers)(gone 3/12)
99 Cobra (mine) SOLD
00 Toyota Camry
06 Toyota Avalon Limited (hers)
matted2thefloor is offline  
#6 Old 11-12-2010, 10:27 AM
kressley
Registered User
 
Join Date: Jul 2005
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks everyone. Hadn't been back on since posting. It's a 2005 with the 5.7 Hemi.

Light will go off if I restart. Only happens when the weather gets cold.

I'll replace the sending unit this weekend...
kressley is offline  
#7 Old 11-12-2010, 10:34 AM
kressley
Registered User
 
Join Date: Jul 2005
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So I just need the oil pressure switch?
kressley is offline  
#8 Old 11-12-2010, 07:34 PM
matted2thefloor
Registered User
 
matted2thefloor's Avatar
 
Join Date: Dec 2008
Location: SC
Posts: 1,264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That would the first thing I scrutinized...


04 D 5.7 SLT AWD (hers)(gone 3/12)
99 Cobra (mine) SOLD
00 Toyota Camry
06 Toyota Avalon Limited (hers)
matted2thefloor is offline  
#9 Old 11-15-2010, 12:50 PM
kressley
Registered User
 
Join Date: Jul 2005
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Seems to be fixed.

Replaced the oil sending unit over the weekend. Monday morning and no oil light on first start.

Thanks to all...
kressley is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cold was it this morning for you? Flintstone 3G Dodge RAM - General Talk 5 01-07-2010 10:05 AM
I have the oil light coming on on cold start!! Help!! mburge357 2G Dodge Durango - Drivetrain Talk 3 05-14-2008 11:07 AM
Oil light coming on at cold start! Please Help!! mburge357 2G Dodge Durango General Talk 1 12-24-2007 09:43 AM
Truck wouldn't start this morning (right away). Dodge318 2G Dodge RAM - General Talk 21 03-29-2007 08:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome