EVIC is not working - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 4th Gen (09 – Up) Forums > 4G Dodge RAM - General Talk

Closed Thread
 
Thread Tools

flysniper
 
  Thumbs down EVIC is not working - Posted: 07-15-2010, 05:25 PM
Woo Pig Sooiee
Joined: May 2010
Posts: 12
State: AR
Status: Offline
Post #1

EVIC went blank today.
everything else appears to be functioning fine, just a blank EVIC.
The back light appears to be on, no info being displayed.
Can anybody provide any insight?

slightly depressed.....I've only made one payment and 4,500 miles.
WAY to early to have issues like this.

mike
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

0212353
 
 Posted: 07-15-2010, 05:29 PM
0212353's Avatar
Fükken Retro'd Moderator
Joined: Apr 2008
Posts: 31,097
City: Florissant
State: MO
Status: Offline
View This User's Gallery View This User's Garage
View Member's FaceBook Profile
Post #2

I think the only option here is to take it to the dealer. Or try to reset the PCM and see it that helps.........but I doubt it.
__________________

DodgeTalk Moderator / Official DodgeTalk Supporter

Retro Shop - HID Projector Retros, Headlight Painting, Tail light tinting / Need a quote? Email me please - jeremy@retroshop.us

Fukken Wax Specials: Specials here! / Join our Fükken Facebook page!




Official Dodgetalk Facebook Page:
http://www.facebook.com/DodgeTalk
Like us! Prize Giveaways, News, and More!!!



View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

soad
 
 Posted: 07-15-2010, 05:37 PM
soad's Avatar
Registered User
Joined: Dec 2005
Posts: 66
Status: Offline
Post #3

When I first got my truck bumped the 'back' button and the EVIC went out. Took me a whole day to figure out what I did wrong. In your case it sounds like a malfunction, not 'driver error'
__________________
2009 Ram CC Sport 4x4 Hemi Chick Magnet
2007 Durango 4x4 Hemi Grocery Getter
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

renos09
 
 Posted: 07-15-2010, 06:03 PM
Registered User
Joined: Jun 2009
Posts: 322
State: NJ
Status: Offline
Post #4

Yes, more than likely you hit a button that makes the evic go blank. It happened to me and I got lucky that I figured it out.
__________________
2009 Dodge Ram 1500 SLT Quad cab 4x4 Mineral Gray/Luxury group/protection group/remote start and security/popular equipment group/5.7 vvt/32 gallon fuel tank/u connect and Navigation w/ back up camera/power adjustable pedals/class iv receiver hitch/under rail box liner/ 20" powder coated flat black rims
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

TI 3VOM
 
 Posted: 07-15-2010, 06:20 PM
TI 3VOM's Avatar
Registered User
Joined: Mar 2010
Posts: 116
State: BC
Status: Offline
Post #5

There is an RRT that they did for my truck, something about the EVIC going blank. Mine did it once, then came back on. Then one day I had it in and they said they were going to quickly flash it for some EVIC issues. Mine has beed 100% since.

Take it in and have them check for updates, that should fix it!
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

blackhemi4x4
 
 Posted: 07-15-2010, 07:50 PM
blackhemi4x4's Avatar
Shut up and drive!
Joined: Sep 2007
Posts: 2,899
City: Loganville
State: GA
Status: Offline
Post #6

Have you done or made any changes to the truck? If the EVIC is missing any input from a monitored system, it may not work. Dealer fix for sure though!

this is from the chrysler manual.


ELECTRONIC VEHICLE INFORMATION CENTER
The Electronic Vehicle Information Center (EVIC) data is obtained from several components on the Controller Area Network (CAN) Data Bus circuit. The EVIC will not function properly if the bus messages from any of these components is not received. If no EVIC data is displayed, check the CAN Data Bus circuit communications, the Instrument Cluster functions and the Totally Integrated Power Module (TIPM).

The use of a scan tool and the proper diagnostic procedures information are recommended for further testing of the EVIC and the CAN Data Bus circuit. Refer to the appropriate wiring information for complete circuit schematic or connector pin-out information.
__________________

2010 Ram 1500 QuadCab 4x4 5.7 HEMI Big Horn



mods: debadged
future mods: Exhaust, tires, tow hooks, skid plates, a/t tires, red brake calipers, maybe a tuner, line-x, 12" ported sub under a seat, colormatched grille
-Will be keeping it mostly stock.

My G/F also has the same truck, only hers is 100% stock-2010 Ram 1500 QuadCab 4x4 5.7 HEMI Big Horn



Former owner of 2007 Ram QC 4x4 BigHorn 5.7
99 Neon ES auto
01 Neon ES 5 speed
a handful of dodge Shadows (4 of them, all running)
early 90's D50

Im no longer amotorkat :P

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Bubba_Hemi
 
 Posted: 07-15-2010, 07:57 PM
Bubba_Hemi's Avatar
5 Years... 6 Dodges
Joined: Dec 2002
Posts: 25,386
City: NAS Whidbey Island
State: WA
Status: Offline
View This User's Gallery View This User's Garage
View This User's Timeslip View This User's Dyno Entries
Post #7

I'd make sure you didn't just hit the arrow to make it go away... lol
__________________
WCOG

2009 Dodge Ram
1500 QC SB

TOTM- October '04: '04 Ram 2500 CTD 600 QC SB..........'05 Dodge Stratus SXT SE: October '05- COTM

Posting Foolishness 69.12% of the time

SUPPORT THOSE WHO SUPPORT DODGETALK

You have one hell of an interesting perspective on things... and by "interesting", I mean retarded

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
EVIC Install What did I do Darrensdodge 2G Dodge Intrepid - Interior/Exterior Talk 2 08-11-2010 05:32 PM
EVIC Setup rut13 4G Dodge RAM - Interior/Exterior Talk 3 11-10-2009 11:33 PM
EVIC is Too Bright On My '09 Jack772 4G Dodge RAM - General Talk 7 11-07-2009 07:23 PM
Evic MilanBloom 2G Dodge Avenger - General Talk 2 02-24-2009 10:45 PM
EVIC question RobbieG Dodge Caravan/Grand Caravan Talk 1 08-19-2007 09:32 AM



All times are GMT -5. The time now is 06:26 AM.





Privacy Statement