Surging @ 1200 - 1400 RPM - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Closed Thread
 
Thread Tools
#1 Old 05-30-2010, 01:07 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Surging @ 1200 - 1400 RPM

Hi folks,

So here's my situation...

2004 Ram 5.7L 4x4

In the last week or so I've noticed that the truck surges below 1500 RPM at low speeds. The RPM will fluctuate randomly, sometimes as much as 300RPM... even dropped below 1000 RPM a few times almost like it wanted to stall.

At first I had thought it was the Superchips so I removed the tune and put it back to stock (although the tune has been in for months without any problems). Same issue. I reset the PCM and immediately had the same issue again. So I've ruled out the Superchips.

I'm not having any loss of power when I go WOT and when the RPM's are above 2000, the truck runs normal.

I've been searching the forums and I keep reading about changing the EGR and PCV... possibly the TPS too. Does it sound like an EGR issue? Wouldn't a TPS issue cause it to be wonky a various speeds and not just around 1200 RPM at low speeds?

... what about cleaning the EGR and throttle body?

*** Edited to add that I've ran 3 tanks of gas from reputable stations through the truck and also dumped in a bottle of fuel system cleaner in 2 tanks ago... no dice. I also checked for codes with the Superchips, none before or after the PCM reset ***

What say you, DodgeTalk?

Thanks!

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
Sponsored Links
Advertisement
 
#2 Old 05-30-2010, 01:14 PM
RMBLEBee2392
Registered User
 
RMBLEBee2392's Avatar
 
Join Date: Jun 2008
Location: Mid western Ont
Posts: 168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mine was doing what yours is two weeks ago. I replaced my EGR and it went away. Do you have any codes coming up?

RMBLEBee2392 is offline  
#3 Old 05-30-2010, 01:19 PM
Pipeliner_86
Registered User
 
Join Date: Mar 2009
Location: Petersburg, MI
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have had the same problems too. Mine spits and sputters when I am crusing at 70mph or so, about 10 minutes into driving, or at least after it has warmed up. It tries to stall, I punch it and it clears its throat. I get an engine light too.
I have cleaned my TB, has new plugs/wires and newer coil packs. Have run a few tanks of fuel with dry gas and fuel system cleaner. I just replaced my cam sensor, which was one of the codes I got. No EGR system on my engine, so I might as well go and replace my crank sensor which another code I got.

Good luck, I don't have any suggestions for you. Sorry.
If I figure it out, I'll let you know.

Jeremy

Hemi no more.
Replaced by a Ford Excursion 4x4

My truck:
1991 GMC Suburban 2500 4x4
6.2 diesel, SM465 stick shift and NP205 case.
4:10 gears, stump puller....not a hot rod.
Petersburg, MI
Pipeliner_86 is offline  
#4 Old 05-30-2010, 01:21 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by RMBLEBee2392 View Post
Mine was doing what yours is two weeks ago. I replaced my EGR and it went away. Do you have any codes coming up?
Nope, no codes at all. Were you getting these issues at the same RPM as me? Did you notice it starting to get worse too?

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#5 Old 05-30-2010, 01:22 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Pipeliner_86 View Post
I have had the same problems too. Mine spits and sputters when I am crusing at 70mph or so, about 10 minutes into driving, or at least after it has warmed up. It tries to stall, I punch it and it clears its throat. I get an engine light too.
I have cleaned my TB, has new plugs/wires and newer coil packs. Have run a few tanks of fuel with dry gas and fuel system cleaner. I just replaced my cam sensor, which was one of the codes I got. No EGR system on my engine, so I might as well go and replace my crank sensor which another code I got.

Good luck, I don't have any suggestions for you. Sorry.
If I figure it out, I'll let you know.
Mine seems okay at highway speeds. At least if it is doing it, I can't notice because of the speed so the surging might be happening too fast for the human ear/eye.

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#6 Old 05-30-2010, 01:32 PM
RMBLEBee2392
Registered User
 
RMBLEBee2392's Avatar
 
Join Date: Jun 2008
Location: Mid western Ont
Posts: 168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I was getting p0406, think it was sensor circuit to high. I was getting a surging around 1000-1700 rpm. Slow speeds through town was really noiticable. I kept on clearing the code but it would just come back on when I started the truck again. So broke down and got the EGR. Been good ever since.

RMBLEBee2392 is offline  
#7 Old 05-30-2010, 01:36 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by RMBLEBee2392 View Post
I was getting p0406, think it was sensor circuit to high. I was getting a surging around 1000-1700 rpm. Slow speeds through town was really noiticable. I kept on clearing the code but it would just come back on when I started the truck again. So broke down and got the EGR. Been good ever since.
Hmmm... I'm not getting any codes, yet. That does sound very similar to what I'm experiencing though. Around town is VERY noticable. What did you pay for a new EGR?

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#8 Old 05-30-2010, 03:25 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I wish I could get the truck to throw a code... then I'd know for sure.

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#9 Old 05-30-2010, 04:28 PM
ceri
'11 5.7L R/T Classic
 
ceri's Avatar
 
Join Date: Apr 2006
Location: North Richland Hills
Posts: 4,068
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Have you had your tranny serviced in the last 3 months or so? I'd start with the TB cleaning and pcv valve. Then move on to the EGR is it's still there. If the transmission's been serviced recently, there's a gasket that can cause some idle stalling issues.

2002 Dodge Ram 1500 QC SB 4.7L V8 2WD SOLD!
2004 Dodge Ram 1500 QC SB 5.7L V8 2WD SOLD!

2011 Dodge Challenger R/T Classic 5.7L V8 RWD
Waiting on tuning before the mods start!

ceri is offline  
#10 Old 05-30-2010, 05:02 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by ceri View Post
Have you had your tranny serviced in the last 3 months or so? I'd start with the TB cleaning and pcv valve. Then move on to the EGR is it's still there. If the transmission's been serviced recently, there's a gasket that can cause some idle stalling issues.
No tranny work at all recently and it actually idles well. There's been no stalling issues at stop lights or anything of that nature. It's just the surging between 1000 - 1500 RPM at low speeds. Everything else is like normal. I'm hyper sensitive to any change in the truck at all so maybe it'll get worse and throw a code or something. I'm going to clean the throttle body in the next day or so and see if that makes any difference and price the PCV and EGR. All the threads seem to be pointing me to that... just odd that I'm not getting a code.

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#11 Old 05-30-2010, 07:49 PM
Hemi_2500
Bigg Rigg
 
Hemi_2500's Avatar
 
Join Date: Jun 2006
Location: Carterville
Posts: 2,044
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
try unplugging the EGR and see if the symptons go away.

Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2013 Dodge Dart Limited Turbo
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
Hemi_2500 is offline  
#12 Old 05-30-2010, 08:39 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Hemi_1500 View Post
try unplugging the EGR and see if the symptons go away.
Excellent, Ill try that. Do I simply need to just unplug the clip? Should I expect it to throw a code while doing this test? Thanks for the idea!

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#13 Old 05-31-2010, 09:45 AM
Hemi_2500
Bigg Rigg
 
Hemi_2500's Avatar
 
Join Date: Jun 2006
Location: Carterville
Posts: 2,044
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I dont rember exactly. When I had my 05 and I had the same problem you are having some one on this site told me to unplug the EGR and if my symptons went away that my EGR was bad. I unpluged the connector from the EGR and my symptons went away so i drove around with it unplugged til the dealer got an EGR in. I want to say an EGR is around 60 bucks for one. Im pretty sure I had a CEL light come on. Hope this helps you out.

Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2013 Dodge Dart Limited Turbo
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
Hemi_2500 is offline  
#14 Old 05-31-2010, 12:48 PM
TheFinFanMan
Kenneth Robert
 
TheFinFanMan's Avatar
 
Join Date: Jun 2007
Location: Cincinnati
Posts: 573
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would clean your throttle body. Start with that and see what happens. It's cheap and might fix your issue. Worse case it doesn't and then you can look into the EGR.

2002 1500 QC 4x4 Sport in Mineral Grey
2001 Mustang GT Premium in Silver
TheFinFanMan is offline  
#15 Old 05-31-2010, 03:06 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So it was getting worse today and I decided to unplug the EGR... the problem went away. I guess it's the EGR after all, despite not throwing any codes. I'm going to remove the throttle body, PCV and EGR tomorrow if it's not raining and clean them all thoroughly... hopefully that takes care of the issue.

In other news, I almost traded the truck in today on a 2010 Inferno Red Sport model...

Anyone know what makes the R/T model any different other than the hood?

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#16 Old 05-31-2010, 08:19 PM
RMBLEBee2392
Registered User
 
RMBLEBee2392's Avatar
 
Join Date: Jun 2008
Location: Mid western Ont
Posts: 168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think the R/T has 410 gears and a higher stall converter.

RMBLEBee2392 is offline  
#17 Old 06-01-2010, 07:52 AM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by RMBLEBee2392 View Post
I think the R/T has 410 gears and a higher stall converter.
Can you get a R/T in 4 wheel drive, crew cab configuration or just 4x2, single cab? I saw what looked like a R/T hood on a 4x4, crew cab but didn't notice any R/T emblems.

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#18 Old 06-01-2010, 09:50 AM
Hemi_2500
Bigg Rigg
 
Hemi_2500's Avatar
 
Join Date: Jun 2006
Location: Carterville
Posts: 2,044
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
No,

You can only get them in SC 4x2 versions that is the main reason I have not jumped on one.

Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2013 Dodge Dart Limited Turbo
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
Hemi_2500 is offline  
#19 Old 06-01-2010, 01:46 PM
Selcher
Registered User
 
Selcher's Avatar
 
Join Date: Apr 2006
Location: Halifax
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Hemi_1500 View Post
No,

You can only get them in SC 4x2 versions that is the main reason I have not jumped on one.
Well, a black Hemi Ram Sport rolled off the assembly line today and I believe it will have my name on it. Time to trade up to a 2010 model me thinks.

2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
Selcher is offline  
#20 Old 06-01-2010, 02:15 PM
Hemi_2500
Bigg Rigg
 
Hemi_2500's Avatar
 
Join Date: Jun 2006
Location: Carterville
Posts: 2,044
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nice congrats make sure to take pics.

Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2013 Dodge Dart Limited Turbo
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
Hemi_2500 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck idling rpm surging up & down jayz-23 3G Dodge Ram Performance Talk 2 02-12-2010 03:44 PM
What would cause my engine to rev to 1200-1800 RPM by itself???? Vader Ram 3G Dodge RAM - General Talk 6 09-26-2008 11:11 AM
Trans /RPM Surging Dragonbain 2G Dodge RAM - Drivetrain Talk 13 12-22-2007 06:56 AM
What Could I get for $1400? MonsoonMike 3G Dodge RAM - 4X4 Talk 9 02-23-2006 09:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome