Surging @ 1200 - 1400 RPM - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP DODGETALK MERCHANDISE ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 3rd Gen (02 08) Forums > 3G Dodge RAM - General Talk

Closed Thread
 
Thread Tools

Selcher
 
  Surging @ 1200 - 1400 RPM - Posted: 05-30-2010, 01:07 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #1

Hi folks,

So here's my situation...

2004 Ram 5.7L 4x4

In the last week or so I've noticed that the truck surges below 1500 RPM at low speeds. The RPM will fluctuate randomly, sometimes as much as 300RPM... even dropped below 1000 RPM a few times almost like it wanted to stall.

At first I had thought it was the Superchips so I removed the tune and put it back to stock (although the tune has been in for months without any problems). Same issue. I reset the PCM and immediately had the same issue again. So I've ruled out the Superchips.

I'm not having any loss of power when I go WOT and when the RPM's are above 2000, the truck runs normal.

I've been searching the forums and I keep reading about changing the EGR and PCV... possibly the TPS too. Does it sound like an EGR issue? Wouldn't a TPS issue cause it to be wonky a various speeds and not just around 1200 RPM at low speeds?

... what about cleaning the EGR and throttle body?

*** Edited to add that I've ran 3 tanks of gas from reputable stations through the truck and also dumped in a bottle of fuel system cleaner in 2 tanks ago... no dice. I also checked for codes with the Superchips, none before or after the PCM reset ***

What say you, DodgeTalk?

Thanks!
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

RMBLEBee2392
 
 Posted: 05-30-2010, 01:14 PM
RMBLEBee2392's Avatar
Registered User
Joined: Jun 2008
Posts: 168
City: Mid western Ont
State: ON
Status: Offline
View This User's Gallery
Post #2

Mine was doing what yours is two weeks ago. I replaced my EGR and it went away. Do you have any codes coming up?
__________________
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Pipeliner_86
 
 Posted: 05-30-2010, 01:19 PM
Registered User
Joined: Mar 2009
Posts: 57
City: Petersburg, MI
State: MI
Status: Offline
Post #3

I have had the same problems too. Mine spits and sputters when I am crusing at 70mph or so, about 10 minutes into driving, or at least after it has warmed up. It tries to stall, I punch it and it clears its throat. I get an engine light too.
I have cleaned my TB, has new plugs/wires and newer coil packs. Have run a few tanks of fuel with dry gas and fuel system cleaner. I just replaced my cam sensor, which was one of the codes I got. No EGR system on my engine, so I might as well go and replace my crank sensor which another code I got.

Good luck, I don't have any suggestions for you. Sorry.
If I figure it out, I'll let you know.
__________________
Jeremy

Hemi no more.
Replaced by a Ford Excursion 4x4

My truck:
1991 GMC Suburban 2500 4x4
6.2 diesel, SM465 stick shift and NP205 case.
4:10 gears, stump puller....not a hot rod.
Petersburg, MI
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-30-2010, 01:21 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #4

Quote:
Originally Posted by RMBLEBee2392 View Post
Mine was doing what yours is two weeks ago. I replaced my EGR and it went away. Do you have any codes coming up?
Nope, no codes at all. Were you getting these issues at the same RPM as me? Did you notice it starting to get worse too?
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-30-2010, 01:22 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #5

Quote:
Originally Posted by Pipeliner_86 View Post
I have had the same problems too. Mine spits and sputters when I am crusing at 70mph or so, about 10 minutes into driving, or at least after it has warmed up. It tries to stall, I punch it and it clears its throat. I get an engine light too.
I have cleaned my TB, has new plugs/wires and newer coil packs. Have run a few tanks of fuel with dry gas and fuel system cleaner. I just replaced my cam sensor, which was one of the codes I got. No EGR system on my engine, so I might as well go and replace my crank sensor which another code I got.

Good luck, I don't have any suggestions for you. Sorry.
If I figure it out, I'll let you know.
Mine seems okay at highway speeds. At least if it is doing it, I can't notice because of the speed so the surging might be happening too fast for the human ear/eye.
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

RMBLEBee2392
 
 Posted: 05-30-2010, 01:32 PM
RMBLEBee2392's Avatar
Registered User
Joined: Jun 2008
Posts: 168
City: Mid western Ont
State: ON
Status: Offline
View This User's Gallery
Post #6

I was getting p0406, think it was sensor circuit to high. I was getting a surging around 1000-1700 rpm. Slow speeds through town was really noiticable. I kept on clearing the code but it would just come back on when I started the truck again. So broke down and got the EGR. Been good ever since.
__________________
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-30-2010, 01:36 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #7

Quote:
Originally Posted by RMBLEBee2392 View Post
I was getting p0406, think it was sensor circuit to high. I was getting a surging around 1000-1700 rpm. Slow speeds through town was really noiticable. I kept on clearing the code but it would just come back on when I started the truck again. So broke down and got the EGR. Been good ever since.
Hmmm... I'm not getting any codes, yet. That does sound very similar to what I'm experiencing though. Around town is VERY noticable. What did you pay for a new EGR?
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-30-2010, 03:25 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #8

I wish I could get the truck to throw a code... then I'd know for sure.
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

ceri
 
 Posted: 05-30-2010, 04:28 PM
ceri's Avatar
'11 5.7L R/T Classic
Joined: Apr 2006
Posts: 4,068
City: North Richland Hills
State: TX
Status: Offline
View This User's Gallery
Post #9

Have you had your tranny serviced in the last 3 months or so? I'd start with the TB cleaning and pcv valve. Then move on to the EGR is it's still there. If the transmission's been serviced recently, there's a gasket that can cause some idle stalling issues.
__________________
2002 Dodge Ram 1500 QC SB 4.7L V8 2WD SOLD!
2004 Dodge Ram 1500 QC SB 5.7L V8 2WD SOLD!

2011 Dodge Challenger R/T Classic 5.7L V8 RWD
Waiting on tuning before the mods start!

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-30-2010, 05:02 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #10

Quote:
Originally Posted by ceri View Post
Have you had your tranny serviced in the last 3 months or so? I'd start with the TB cleaning and pcv valve. Then move on to the EGR is it's still there. If the transmission's been serviced recently, there's a gasket that can cause some idle stalling issues.
No tranny work at all recently and it actually idles well. There's been no stalling issues at stop lights or anything of that nature. It's just the surging between 1000 - 1500 RPM at low speeds. Everything else is like normal. I'm hyper sensitive to any change in the truck at all so maybe it'll get worse and throw a code or something. I'm going to clean the throttle body in the next day or so and see if that makes any difference and price the PCV and EGR. All the threads seem to be pointing me to that... just odd that I'm not getting a code.
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Hemi_2500
 
 Posted: 05-30-2010, 07:49 PM
Hemi_2500's Avatar
Bigg Rigg
Joined: Jun 2006
Posts: 2,039
City: Carterville
State: IL
Status: Offline
View This User's Gallery View This User's Garage
Post #11

try unplugging the EGR and see if the symptons go away.
__________________
Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
2005 Dodge Magnum R/T Hemi GONE
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-30-2010, 08:39 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #12

Quote:
Originally Posted by Hemi_1500 View Post
try unplugging the EGR and see if the symptons go away.
Excellent, Ill try that. Do I simply need to just unplug the clip? Should I expect it to throw a code while doing this test? Thanks for the idea!
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Hemi_2500
 
 Posted: 05-31-2010, 09:45 AM
Hemi_2500's Avatar
Bigg Rigg
Joined: Jun 2006
Posts: 2,039
City: Carterville
State: IL
Status: Offline
View This User's Gallery View This User's Garage
Post #13

I dont rember exactly. When I had my 05 and I had the same problem you are having some one on this site told me to unplug the EGR and if my symptons went away that my EGR was bad. I unpluged the connector from the EGR and my symptons went away so i drove around with it unplugged til the dealer got an EGR in. I want to say an EGR is around 60 bucks for one. Im pretty sure I had a CEL light come on. Hope this helps you out.
__________________
Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
2005 Dodge Magnum R/T Hemi GONE
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

TheFinFanMan
 
 Posted: 05-31-2010, 12:48 PM
TheFinFanMan's Avatar
Kenneth Robert
Joined: Jun 2007
Posts: 573
City: Cincinnati
Status: Offline
Post #14

I would clean your throttle body. Start with that and see what happens. It's cheap and might fix your issue. Worse case it doesn't and then you can look into the EGR.
__________________
2002 1500 QC 4x4 Sport in Mineral Grey
2001 Mustang GT Premium in Silver
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 05-31-2010, 03:06 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #15

So it was getting worse today and I decided to unplug the EGR... the problem went away. I guess it's the EGR after all, despite not throwing any codes. I'm going to remove the throttle body, PCV and EGR tomorrow if it's not raining and clean them all thoroughly... hopefully that takes care of the issue.

In other news, I almost traded the truck in today on a 2010 Inferno Red Sport model...

Anyone know what makes the R/T model any different other than the hood?
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

RMBLEBee2392
 
 Posted: 05-31-2010, 08:19 PM
RMBLEBee2392's Avatar
Registered User
Joined: Jun 2008
Posts: 168
City: Mid western Ont
State: ON
Status: Offline
View This User's Gallery
Post #16

I think the R/T has 410 gears and a higher stall converter.
__________________
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 06-01-2010, 07:52 AM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #17

Quote:
Originally Posted by RMBLEBee2392 View Post
I think the R/T has 410 gears and a higher stall converter.
Can you get a R/T in 4 wheel drive, crew cab configuration or just 4x2, single cab? I saw what looked like a R/T hood on a 4x4, crew cab but didn't notice any R/T emblems.
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Hemi_2500
 
 Posted: 06-01-2010, 09:50 AM
Hemi_2500's Avatar
Bigg Rigg
Joined: Jun 2006
Posts: 2,039
City: Carterville
State: IL
Status: Offline
View This User's Gallery View This User's Garage
Post #18

No,

You can only get them in SC 4x2 versions that is the main reason I have not jumped on one.
__________________
Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
2005 Dodge Magnum R/T Hemi GONE
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Selcher
 
 Posted: 06-01-2010, 01:46 PM
Selcher's Avatar
Registered User
Joined: Apr 2006
Posts: 183
City: Halifax
State: NS
Status: Offline
Post #19

Quote:
Originally Posted by Hemi_1500 View Post
No,

You can only get them in SC 4x2 versions that is the main reason I have not jumped on one.
Well, a black Hemi Ram Sport rolled off the assembly line today and I believe it will have my name on it. Time to trade up to a 2010 model me thinks.
__________________
2010 Dodge Ram Hemi Sport Crew Cab 4x4 - Brilliant Black Crystal Pearl

MBRP Pro Series Dual Split Rear Exhaust
Superchips Flashpaq 3865
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Hemi_2500
 
 Posted: 06-01-2010, 02:15 PM
Hemi_2500's Avatar
Bigg Rigg
Joined: Jun 2006
Posts: 2,039
City: Carterville
State: IL
Status: Offline
View This User's Gallery View This User's Garage
Post #20

Nice congrats make sure to take pics.
__________________
Proud Member of the White Truck Club #77
Proud Member of the Military Truck Club #10
2003 Dodge Ram 2500 Hemi
2013 Dodge Journey Blacktop Edition
2005 Dodge Magnum R/T Hemi GONE
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck idling rpm surging up & down jayz-23 3G Dodge Ram Performance Talk 2 02-12-2010 03:44 PM
What would cause my engine to rev to 1200-1800 RPM by itself???? Vader Ram 3G Dodge RAM - General Talk 6 09-26-2008 11:11 AM
Trans /RPM Surging Dragonbain 2G Dodge RAM - Drivetrain Talk 13 12-22-2007 06:56 AM
What Could I get for $1400? MonsoonMike 3G Dodge RAM - 4X4 Talk 9 02-23-2006 09:09 PM
A/T - Engine Bucking/Surging at 5,300 Rpm Izzy 2.5L, 3.9L, 5.2L, 5.9L, V10 Tech 2 08-31-2004 04:51 PM



All times are GMT -5. The time now is 11:00 PM.





Privacy Statement