Intermittent Turn signals '99 Caravan - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 05-06-2010, 04:18 PM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Intermittent Turn signals '99 Caravan

This is a 1999 Caravan that has had intermittent turn signal operation. I have checked fuses (OK), reversed flasher relays (with 4-ways which work ok) and replaced the turn signal module on the column.

It continues to be intermittent. Turn on the ignition to the run position and it'll work one cycle then not function. Turn off key and remove it, replace turn to run position and it again works for 1 (or more) times.

Anyone have any ideas? I have searched these forums (and others) for an answer..... no help. I don't want to spend any more $ on parts until I can be sure of a fix!
CAPofMD is offline  
Sponsored Links
Advertisement
 
#2 Old 05-06-2010, 04:28 PM
ringnalda506
Registered User
 
ringnalda506's Avatar
 
Join Date: Jun 2009
Posts: 197
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
To me it sounds like a stickking deck in the blinker relay.
Or something wrong with the holding circuit inside the relay.
Did you try changing it for another one?
ringnalda506 is offline  
#3 Old 05-06-2010, 04:41 PM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
As I noted, I swapped it with the working relay with the Emergency flasher relay...they had the same P/N on them. Both were in the fuse panel.
CAPofMD is offline  
#4 Old 05-06-2010, 04:49 PM
ringnalda506
Registered User
 
ringnalda506's Avatar
 
Join Date: Jun 2009
Posts: 197
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
so that means it must have something to do with what they have in common.
The connection in the fuse box.
Did you measure for any resistance .
And maybe you can also check the contacts in the actual turn signal handle to see if they are ok or maybe worn(afterall it,s an old car your talking about
ringnalda506 is offline  
#5 Old 05-06-2010, 05:13 PM
donald7150
Registered User
 
donald7150's Avatar
 
Join Date: May 2005
Posts: 1,054
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your turn signal stalk took a crap, i'm 100% sure

If you go for another one make sure its from a '99 or 2000 model
the 96-98's had different resistance values for the wiper switch

2005 Chrysler 300 (DD): 6000K 50W HIDs, Niteshades, LED Interior light Conversion...
'99 Caravan: Work van. 6000K HID headlights and fogs
'92 Chrysler Daytona IROC R/T (2.2L DOHC Turbo-III)
donald7150 is offline  
#6 Old 05-06-2010, 05:19 PM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
What is a "turn signal stalk"? I said I replaced the multi-function switch (flasher/turn signal module) with a new one. Yes I ordered one for a '99...it cost more......

She just got back with the car...she said it was still intermittent, but add a problem. The turn signal cancel didn't not work.

Just looked at the battery....much corrosion on the positive terminal....gonna check voltage and clean the terminals....
CAPofMD is offline  
#7 Old 05-06-2010, 05:57 PM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
UPDATE: Turn signals work normally.... voltages good. Problem is the part I received from vender (multi-function switch) is probably bad.... the cancel turn signal isn't working. Re-installed old switch, no turn signals, but cancel feature works.....
CAPofMD is offline  
#8 Old 05-09-2010, 11:07 AM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
NEW UPDATE - And a call for help!!!

One day of driving and the signal lights are right back doing what they were before....sometimes they work, sometimes they don't. When they don't, they don't! Usually happens after they HAVE been working and the ignition is turned off.....This is really weird....ANYONE?????

To review, I replaced the multi-function switch with a new one. Battery is good and strong.... I switched the flasher with the emergency flasher in the fuse panel. No diff......
CAPofMD is offline  
#9 Old 05-12-2010, 07:33 PM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I can't believe that no one has run into this problem......... ANYONE?
CAPofMD is offline  
#10 Old 05-27-2010, 03:51 PM
CAPofMD
Registered User
 
Join Date: May 2010
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Just bumping this up for review.
CAPofMD is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 Grand Caravan - Radio and Turn Signals Intermittently Not Working jerseycat10 Dodge Caravan General Talk 3 01-09-2009 09:29 AM
1998 Caravan Turn Signals work intermitently johmar Dodge Caravan General Talk 1 12-29-2008 07:42 PM
HELP! 2002 G Caravan Turn Signals Staying on cdnjan Dodge Caravan General Talk 1 06-10-2008 02:57 PM
2002 Caravan Turn Signals Won't Cancel dazed&confused Dodge Caravan General Talk 4 07-17-2006 10:58 PM
Intermittent turn signals galaxie66 Dodge Caravan General Talk 1 05-18-2004 10:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome