Transmission fluid smell...In 4x4 mode - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 4th Gen (09 Up) Forums > 4G Dodge RAM - Drivetrain Talk

Closed Thread
 
Thread Tools

darkwind72
 
  Transmission fluid smell...In 4x4 mode - Posted: 12-05-2009, 02:01 PM
darkwind72's Avatar
Registered User
Joined: Apr 2009
Posts: 264
City: Drayton Valley, AB
State: AB
Status: Offline
View This User's Gallery
Post #1

Has anyone else noticed this:

We've gotten quite a bit of snow in Alberta, and I've had to lock my truck up in 4x4, and when I'm driving around, it's fine, but when I have to punch it, I can smell transmission fluid. It's not a strong smell, and it goes away after a minute or so, but I didn't notice the smell in my old truck (a ford). Anyone else notice this? Is it normal?
__________________
Dave

: 2013 Dodge Ram CrewCab 4X4 Sport Package. All white exterior, black interior. Eight-speed Auto with the HEMI, nearly loaded
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

buckmann686
 
 Posted: 12-09-2009, 02:08 PM
Registered User
Joined: Jun 2005
Posts: 268
Status: Offline
Post #2

I have ran my truck in 4x4 quiet a bit but only in mud we don't get snow here in Alabama. I have never noticed the smell you are talking about on this truck or my last 05 dodge.
__________________
'09 Dodge Ram 1500 4x4 Hemi Crew Cab Laramie- Stone White
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

darkwind72
 
 Posted: 12-09-2009, 02:57 PM
darkwind72's Avatar
Registered User
Joined: Apr 2009
Posts: 264
City: Drayton Valley, AB
State: AB
Status: Offline
View This User's Gallery
Post #3

Thanks. I've checked the fluid in the transfer case, and the transmission, and there's no fluid loss. As I said, I have never noticed the smell in my Ford before. Weird!
__________________
Dave

: 2013 Dodge Ram CrewCab 4X4 Sport Package. All white exterior, black interior. Eight-speed Auto with the HEMI, nearly loaded
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Limp mode Techy Dodge Avenger 1st Gen (95 - 2000) 0 05-05-2008 10:44 PM
Transmission is stuck in limp mode ????? SixT8Chevl 3G Dodge RAM Diesel Talk 12 05-18-2007 06:20 AM
Transmission fluid level does not go up when adding fluid Hemixav 3G Dodge RAM - Drivetrain Talk 17 02-23-2007 07:03 AM
Tow mode on, transmission still goes into 5th 68Malibu 3G Dodge RAM - General Talk 11 11-01-2005 06:11 AM
99 stratus limp mode Transmission intrigueing Dodge Stratus 1st Gen (95 - 00) 0 06-06-2005 08:20 AM



All times are GMT -5. The time now is 01:35 PM.





Privacy Statement