Transmission fluid smell...In 4x4 mode - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Notices

Closed Thread
 
Thread Tools
post #1 of 3 Old 12-05-2009, 03:01 PM Thread Starter
darkwind72
Registered User
 
darkwind72's Avatar
 
Join Date: Apr 2009
Location: Kenora, ON
Posts: 274
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
(Thread Starter)
Transmission fluid smell...In 4x4 mode

Has anyone else noticed this:

We've gotten quite a bit of snow in Alberta, and I've had to lock my truck up in 4x4, and when I'm driving around, it's fine, but when I have to punch it, I can smell transmission fluid. It's not a strong smell, and it goes away after a minute or so, but I didn't notice the smell in my old truck (a ford). Anyone else notice this? Is it normal?

Dave S

2013 Ram CrewCab 4X4 Sport.

White exterior/black interior. Eight-speed auto c/w HEMI.
darkwind72 is offline  
Quick Reply
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-09-2009, 03:08 PM
buckmann686
Registered User
 
Join Date: Jun 2005
Posts: 268
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have ran my truck in 4x4 quiet a bit but only in mud we don't get snow here in Alabama. I have never noticed the smell you are talking about on this truck or my last 05 dodge.

'09 Dodge Ram 1500 4x4 Hemi Crew Cab Laramie- Stone White
buckmann686 is offline  
post #3 of 3 Old 12-09-2009, 03:57 PM Thread Starter
darkwind72
Registered User
 
darkwind72's Avatar
 
Join Date: Apr 2009
Location: Kenora, ON
Posts: 274
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
(Thread Starter)
Thanks. I've checked the fluid in the transfer case, and the transmission, and there's no fluid loss. As I said, I have never noticed the smell in my Ford before. Weird!

Dave S

2013 Ram CrewCab 4X4 Sport.

White exterior/black interior. Eight-speed auto c/w HEMI.
darkwind72 is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page


    Forum Jump

    Similar Threads
    Thread Thread Starter Forum Replies Last Post
    Transmission Limp mode Techy Dodge Avenger 1st Gen (95 - 2000) 0 05-05-2008 11:44 PM
    Transmission is stuck in limp mode ????? SixT8Chevl 3G Dodge RAM Diesel Talk 12 05-18-2007 07:20 AM
    Transmission fluid level does not go up when adding fluid Hemixav 3G Dodge RAM - Drivetrain Talk 17 02-23-2007 08:03 AM
    Tow mode on, transmission still goes into 5th 68Malibu 3G Dodge RAM - General Talk 11 11-01-2005 07:11 AM
    99 stratus limp mode Transmission intrigueing Dodge Stratus 1st Gen (95 - 00) 0 06-06-2005 09:20 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

     
    For the best viewing experience please update your browser to Google Chrome