accelerator pedal position (app) sensor - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 3rd Gen (02 08) Forums > 3G Dodge RAM - General Talk

Closed Thread
 
Thread Tools

Peppy
 
  accelerator pedal position (app) sensor - Posted: 11-05-2009, 05:14 PM
Peppy's Avatar
Registered User
Joined: Jan 2009
Posts: 10
City: Hamilton
State: OH
Status: Offline
Post #1

Has anyone had to replace this sensor? I noticed my truck bogging down sometimes when I take off as well as it not shifting right (at least that's what it felt like). Hooked up a scanner and it this is what was flagged.
I was just curious if anyone has replaced this and what was the price. Also how difficult it was to replace. I'm pretty sure I know where it is, doesn't seem like a big deal. Do you think this would cause what I explained. also, i have adj pedals if that matters.
__________________
2004 QC Hemi SLT Sport 4X4
Altlantic Blue
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

RubberFrog
 
 Posted: 11-05-2009, 05:17 PM
RubberFrog's Avatar
I RECOMMEND FUKKEN WAX
Joined: Mar 2006
Posts: 13,992
City: Vienna
State: VA
Status: Offline
View This User's Gallery View This User's Garage
Post #2

Try recalibrating the throttle first.
__________________
'07 QCSB, Flame Red 5.7 4x4 SLT
Performance:
Internal: Custom Cam, 180 T-Stat - Intake: Ported Throttle Body, K&N Filter - Exhaust: Edelbrock Shorties, Magnaflow Y Pipe, Raceland Cutout, Dumped Gibson Catback
Tuning & Monitoring: SuperChimps, Aeroforce Interceptor w/ afr
Suspension & Tires:
Lift: 6" Suspension, 3" Body Lift - Wheels: Custom Painted BMF S.O.T.A.s, 37" Trail Grapplers, Mopar Wheel Well Liners
Appearance:
Bed: Leer 100XQ Shell, Line-x XTRA, Defender Roof Rack - Other: SRT Hood, Bushwacker Pocket Flares,Tow Mirrors, Nerf Bars, 2500 Tow Hooks, Shorty Antenna, Tactical Grill
AV:
Tunes: Kenwood DDX512, Infinity Reference Speakers, Kicker 10" Sub, Kicker 400.1 Amp, FoxBox - Video: 10.4" TFT-LCD Flip-down Overhead Monitor, R Cam, Chuck Norris Kicked My Ass
Lighting:
Led Tails, Smoked Cab Lights, 4x VisionX 180w, Hella 500's

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Thor93
 
 Posted: 11-05-2009, 08:29 PM
Thor93's Avatar
Registered User
Joined: Feb 2009
Posts: 22
State: NJ
Status: Offline
Post #3

I just had my teuck at the dealership today for the same issues. I have to replace the app sensor as well. I was told i need to replace the pedal assembly because the sensor is built into it. I also have adjustable pedals and the dealership quoted me at about $350. Im gonna be doing it myself. My uncle replaced one before and said it was easy.
__________________
2003 Dodge Ram 1500
5.7L V8 HEMI
Laramie Quad cab
Pro Comp leveling kit
17" Mamba wheels BF Goodrich All-Terrain t/a 315/70/17
Gibson Dual Extreme exhaust
CAI, Superchip Programer
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

JeffB2002
 
 Posted: 11-05-2009, 08:36 PM
JeffB2002's Avatar
Member
Joined: Sep 2005
Posts: 15,912
State: OTHER
Status: Offline
View This User's Gallery View This User's Garage
Post #4

What Frog said....try recalibrating the pedal first before you do anything else.....the procedure should be in your owners manual.
__________________
Jeff
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

crasher76
 
 Posted: 11-05-2009, 10:53 PM
crasher76's Avatar
Im wired!!!
Joined: May 2009
Posts: 2,325
City: K-TOWN
State: WI
Status: Offline
Post #5

good luck
__________________
Black 2003 QC SB SLT 4x4 Offroad 5.7L HEMI, Original Owner 3.92 LSD, 260 cam, 6.1 Rods/Springs, Home Ported/Polished Heads, Psc1, 04 Map sensor and Fuel pump assembly, Oil pressure guage, Amsoil, Champs, MSD 8.5MM Full length Wires, Transgo HD w/out resistor, Superchip, 180 T-Stat, K/N 77 Series, Ceramic Flowtech headers with Y-Pipe, Stage 8 locks, Ditched the cat, O2 sensor mod, Jack Rabbit bed cover, Sprayed bed liner, Big Mouth Grill-Black, Blackend Headlights/Tails, Silverstar ultras, Ditched all chrome, Custom 10's sub enclosure, Upgraded 160 amp alt, Window tint, Relocated purge valve, Energy suspension bushings, Rear spring clamps, Rebuilt front suspension, Ditched Sway Bar, Passport 8500 Radar Detector, Ditched the baby seat- kid wasnt mine, Cigarette burn in the seat mod, Debadged, Custom Rewired/Properly Grounded.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Peppy
 
 Posted: 11-06-2009, 06:24 AM
Peppy's Avatar
Registered User
Joined: Jan 2009
Posts: 10
City: Hamilton
State: OH
Status: Offline
Post #6

I was just searching through the manual and it said the sensor is located under the battery tray. Exactly where we thought it was. I'm not sure why you would have to replace the entire pedal assy.
I'm going to try and recalibrate it first. Once I figure out how. If that doesn't work, I'll be replacing just the sensor, not the entire assy. Thoughts.
__________________
2004 QC Hemi SLT Sport 4X4
Altlantic Blue
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Thor93
 
 Posted: 11-06-2009, 08:41 AM
Thor93's Avatar
Registered User
Joined: Feb 2009
Posts: 22
State: NJ
Status: Offline
Post #7

Well the dealership told me you had to replace the entire petal assembly, and they wouldnt lie to me...lol. I did some reading as well and i didnt see anything that said replace the pedal assembly. Ill be heading to the auto store now and working on this tomorrow.
__________________
2003 Dodge Ram 1500
5.7L V8 HEMI
Laramie Quad cab
Pro Comp leveling kit
17" Mamba wheels BF Goodrich All-Terrain t/a 315/70/17
Gibson Dual Extreme exhaust
CAI, Superchip Programer
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Peppy
 
 Posted: 11-06-2009, 08:43 AM
Peppy's Avatar
Registered User
Joined: Jan 2009
Posts: 10
City: Hamilton
State: OH
Status: Offline
Post #8

Thor,
Let me know what you find out. Any idea of how to recalibrate the pedal?
__________________
2004 QC Hemi SLT Sport 4X4
Altlantic Blue
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Thor93
 
 Posted: 11-06-2009, 08:44 AM
Thor93's Avatar
Registered User
Joined: Feb 2009
Posts: 22
State: NJ
Status: Offline
Post #9

FYI...recalibration did not work for me
__________________
2003 Dodge Ram 1500
5.7L V8 HEMI
Laramie Quad cab
Pro Comp leveling kit
17" Mamba wheels BF Goodrich All-Terrain t/a 315/70/17
Gibson Dual Extreme exhaust
CAI, Superchip Programer
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

JeffB2002
 
 Posted: 11-06-2009, 08:44 AM
JeffB2002's Avatar
Member
Joined: Sep 2005
Posts: 15,912
State: OTHER
Status: Offline
View This User's Gallery View This User's Garage
Post #10

The process for recalibrating the pedal should be in your owners manual.
__________________
Jeff
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Peppy
 
 Posted: 11-06-2009, 08:47 AM
Peppy's Avatar
Registered User
Joined: Jan 2009
Posts: 10
City: Hamilton
State: OH
Status: Offline
Post #11

Jeff,
I looked through the manual and didn't see anything. Not saying it's not in there, just didn't see it. Any idea what section it's in?
__________________
2004 QC Hemi SLT Sport 4X4
Altlantic Blue
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

JeffB2002
 
 Posted: 11-06-2009, 08:56 AM
JeffB2002's Avatar
Member
Joined: Sep 2005
Posts: 15,912
State: OTHER
Status: Offline
View This User's Gallery View This User's Garage
Post #12

I do not have the fly by wire throttle....so I do not know where it is in the manual. If you still have trouble finding it, let me know and I will check the service manual.
__________________
Jeff
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Thor93
 
 Posted: 11-06-2009, 10:53 AM
Thor93's Avatar
Registered User
Joined: Feb 2009
Posts: 22
State: NJ
Status: Offline
Post #13

I found this while searching the froum. Its what i tried.

"The code said you need to change the sensor? Try this.

Disconnect batterys for 20 min. Reconnect. Turn the key on but do not start, slowly mash down on the accelerator till it hits the floor then slowly let up, turn key off. Crank and drive and see if there is a difference. This will reset the APPS."

I just got back from autozone and they told me that the APPS is only available through the dealer. I called them and it runs $265
__________________
2003 Dodge Ram 1500
5.7L V8 HEMI
Laramie Quad cab
Pro Comp leveling kit
17" Mamba wheels BF Goodrich All-Terrain t/a 315/70/17
Gibson Dual Extreme exhaust
CAI, Superchip Programer
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Peppy
 
 Posted: 11-06-2009, 11:13 AM
Peppy's Avatar
Registered User
Joined: Jan 2009
Posts: 10
City: Hamilton
State: OH
Status: Offline
Post #14

Yeah I've tried that before. Everything but the battery disc. I'll try that when I get home. Cheaper than $200+
__________________
2004 QC Hemi SLT Sport 4X4
Altlantic Blue
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Peppy
 
 Posted: 11-06-2009, 11:18 AM
Peppy's Avatar
Registered User
Joined: Jan 2009
Posts: 10
City: Hamilton
State: OH
Status: Offline
Post #15

Thor,
Just wondering what your truck was doing, symptoms wise?
__________________
2004 QC Hemi SLT Sport 4X4
Altlantic Blue
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Thor93
 
 Posted: 11-06-2009, 11:27 AM
Thor93's Avatar
Registered User
Joined: Feb 2009
Posts: 22
State: NJ
Status: Offline
Post #16

I have been experiencing some acceleration issues. Sometimes when I go to get on the gas to pass someone or take off I get no response. It would take a awhile for it to respond. Mainly it happens when i am already moving and try to accelerate.
__________________
2003 Dodge Ram 1500
5.7L V8 HEMI
Laramie Quad cab
Pro Comp leveling kit
17" Mamba wheels BF Goodrich All-Terrain t/a 315/70/17
Gibson Dual Extreme exhaust
CAI, Superchip Programer
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
accel pedal position sensor? TAZ4X4 2G Dodge Ram Diesel Talk 25 05-07-2009 07:45 PM
accelerator pedal position sensor (apps) (or throttle position sensor - TPS) FatBull 2G Dodge Ram Diesel Talk 2 03-24-2008 10:41 PM
Accelerator pedal travel Budd 2G Dodge RAM - General Talk 1 09-21-2007 02:10 AM
pedal position sensor? (murrays and autozone were no help) MLL5000 2G Dodge RAM - General Talk 3 01-03-2004 11:22 PM
Play in accelerator pedal JRosenberg 3G Dodge RAM - General Talk 3 09-18-2003 07:10 AM



All times are GMT -5. The time now is 10:31 AM.





Privacy Statement