2003 Dodge Caravan - No Heat at Idle - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 10-28-2009, 01:29 PM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2003 Dodge Caravan - No Heat at Idle

I have a 2003 Dodge Grand Caravan 3.3. I do not get heat when I am warming up the car. It appears that I only get heat when the temperature gage is half way between C and H. When I drive its heats fine, but as soon as I park or idle it blows cold again.

A clue might be the air circulation button on the dash is suppose to light up when pressed in, mine blinks for a couple of seconds and turns off, it never goes on.

I have been told its 10 different things, as a divorced mom can someone help me narrow it down.

Thanks so much.
kklblue is offline  
Sponsored Links
Advertisement
 
#2 Old 10-28-2009, 02:43 PM
Wrenchgear
Registered User
 
Join Date: Jun 2009
Location: Heidelberg Ont.
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This is a guess / maybe something to look at...

The blend door in the heater box (behind the glove box) is vacuum operated.
- a vacuum line maybe partially off the vacuum motor not being able to operate it properly
- a vacuum line may have a hole in it (same as above)
- diaphram in vacuum motor is torn
- slide control that you adjust for warm/cold temp. leaking vacuum
- problem at vacuum line at engine area

Vacuum changes with engine speed. There maybe a vacuum canister on that van somwhere (I'm not sure where) and it may have a hole in it as well. You would lose the built up supply of vacuum (in the canister) when you're at a stop (idle) and the blend door moves letting more cold air in. When you take off from the stop, vacuum is built up again and the blend door moves and cuts off the cold air coming into the heater box resulting in more heat being blown through the vents.

Wrench

2001 GC Sport
1996 Intrepid

Last edited by Wrenchgear; 10-28-2009 at 02:50 PM.
Wrenchgear is offline  
#3 Old 10-28-2009, 02:46 PM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I imagine that is something I can try and take a peek at myself?
kklblue is offline  
#4 Old 10-28-2009, 03:36 PM
hotrod_06010
Registered User
 
Join Date: Aug 2004
Location: Bristol, Connecticut
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Does the temp guage drop when you stop?
hotrod_06010 is offline  
#5 Old 10-28-2009, 03:51 PM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
You know I have never noticed. But I didn't notice anything out of the ordinary.
kklblue is offline  
#6 Old 10-29-2009, 08:09 AM
hotrod_06010
Registered User
 
Join Date: Aug 2004
Location: Bristol, Connecticut
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
if the temp guage drops when you stop, could be a sign that the thermostat is stuck open. This won't let the water sit in the motor to warm up. Gives you same problems you have, no heat at idle but heat as you drive.
hotrod_06010 is offline  
#7 Old 10-29-2009, 08:58 AM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the responses, I have it at the dealership as we speak, will find out soon.
kklblue is offline  
#8 Old 10-29-2009, 04:51 PM
Chiv
Registered User
 
Join Date: Oct 2009
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Wink

you came to the right place to ask for help. While I am so new here I can not even post pictures yet, I can a sure you someone will look at this, and maybe then you will get a response. At least this is brought back to everbodies attention now.

-Chiv
Chiv is offline  
#9 Old 11-03-2009, 06:03 PM
grey day
Registered User
 
Join Date: Oct 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kklblue, please report dealer findings. I have 2005 with exact same issue!
grey day is offline  
#10 Old 11-03-2009, 08:38 PM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I just got my car back from the dealership and I am not sure I believe what they are saying, but it appears to be fixed.

Apparently my radiator has been leaking. I didn't notice because it ran down some shroud. That diagnosis doesn't make sense to me. They replaced the radiator and did some pressure testing and I do have heat now. But wouldn't I notice water or antifreeze on the ground.

Other finds was - replace power steering pump-rack n pinion. Not sure how to spell that.

Replace valve cover gaskets as they were leaking.

My check engine light was on because I had a small crack in a 4 inch pollution control hose. They replaced that.

They also realigned the car because of the rack n pinion (sp).

I did notice that my air circulation button on my dash still blinks and doesn't stay on . I am going to call them back on that.

I hope this helps. The tech said that knowing I only have 400 miles on my extended warranty they tried to get everything they could covered under this service call so I do believe they did.

Thanks

Kris
kklblue is offline  
#11 Old 11-03-2009, 08:59 PM
grey day
Registered User
 
Join Date: Oct 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would never have thought my rad was leaking but maybe I'll have a closer look, guess it will be low on coolant if thats the case. As for the blinking light mine is also the same, think it only remains on when AC is running.
grey day is offline  
#12 Old 11-03-2009, 09:23 PM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I haven't tried pressing that button when the AC is on. I will try that.
kklblue is offline  
#13 Old 11-03-2009, 10:11 PM
kklblue
Registered User
 
Join Date: Mar 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I just was playing with the air circulation button and figured out that if you have the right knob where the heat is directed turned all the way to the left so it comes out the vents in the dash then the air circulation light stays on.

If you turn that knob all the way back over to the right to the defrost position the light blinks and goes off.

So mine is working fine.
kklblue is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 G Caravan Heat problem cheapascanbe Dodge Caravan General Talk 0 11-24-2008 03:18 PM
2003 Dodge Ram 1500 4.7L Idle problems acroyer 3G Dodge RAM - General Talk 3 10-07-2007 12:58 PM
Engine Racing / Idle High 2003 Caravan SE sredworb Dodge Caravan General Talk 2 08-31-2007 04:22 PM
1994 Dodge Caravan- No Heat from Heater Kimmie Dodge Caravan General Talk 6 03-14-2005 10:49 PM
99 Dodge Caravan fan (for air, ac, and heat) grahamski Dodge Caravan General Talk 1 09-25-2004 10:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome