2004 Ram 1500 4.7V8 engine/oil prob - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 10-20-2009, 12:08 PM
PhoenixMopar
Registered User
 
Join Date: Oct 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy 2004 Ram 1500 4.7V8 engine/oil prob

[F][/FONT]2004 Ram 1500 4.7V8 stick shift

A few days ago I was driving along and the oil pressure gauge started dropping to nothing and coming back up. Sometimes it would be for just a second, sometimes for several minutes, sometimes longer, etc. Every time the gauge dropped the "check gauges" light would come on. Checked the oil and it's still full. I know I'm due for an oil change. Engine never over-heated, and I heard no other sounds suggesting engine problems so I figured it was a bad connection on the gauge itself.

This weekend on a 2-hour trip the engine began to sound like it was either dry or not getting oil. Sound got progressively worse over the last 5 miles, and louder at higher rpms.

Has anyone encountered this problem before or know what it might be?


Could it be the oil pump going out or the screen clogged up?

I already had to shell out $100 for a diagnostic at the Dodge house where the problems culminated but they couldn't figure it out and now they want $500 more to "tear it down to find the problem."

Any help is greatly appreciated...
PhoenixMopar is offline  
Sponsored Links
Advertisement
 
#2 Old 10-20-2009, 12:43 PM
stricnine
RANGO
 
stricnine's Avatar
 
Join Date: Apr 2007
Posts: 1,648
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If you have an 04 you should still be under powertrain warranty shouldn't you? Why would they charge you $500.00 to figure out what a problem is. Something doesn't sound right.....
stricnine is offline  
#3 Old 10-20-2009, 12:43 PM
mopar_57
Registered User
 
Join Date: Apr 2009
Posts: 298
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check the oil, make sure its full? I had this happen to mine, all I did was change the oil and everything work again.
mopar_57 is offline  
#4 Old 10-20-2009, 08:59 PM
07quad
Registered User
 
07quad's Avatar
 
Join Date: Oct 2007
Location: Cornwall, Ontario
Posts: 363
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Could be just a oil pressure switch problem, they are not made of quality.

2007 Ram 1500 QC 4X4
Patriot Blue
325/60R20 BFG all terrains on mopar wheels
levelled with Bilsteins
3" PA body lift
Magnaflow exhaust
Hella's behind the grille

Blue Truck Club member #136


1998 ram 1500 4x4
318 auto
hole in lf fender
38's jammed in stock tearing fenders apart as I turn
waiting to be lifted,dovetailed,shortened and beaten


" having an import that can run 11's...is kinda like coming out of the closet....your going to suprise a lot of people....but in the end your still gay"
07quad is offline  
#5 Old 10-20-2009, 10:42 PM
crasher76
Im wired!!!
 
crasher76's Avatar
 
Join Date: May 2009
Location: K-TOWN
Posts: 2,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
oil

Who does your oil changes and what weight you running, what brand filter?

Black 2003 QC SB SLT 4x4 Offroad 5.7L HEMI, Original Owner 3.92 LSD, 260 cam, 6.1 Rods/Springs, Home Ported/Polished Heads, Psc1, 04 Map sensor and Fuel pump assembly, Oil pressure guage, Amsoil, Champs, MSD 8.5MM Full length Wires, Transgo HD w/out resistor, Superchip, 180 T-Stat, K/N 77 Series, Ceramic Flowtech headers with Y-Pipe, Stage 8 locks, Ditched the cat, O2 sensor mod, Jack Rabbit bed cover, Sprayed bed liner, Big Mouth Grill-Black, Blackend Headlights/Tails, Silverstar ultras, Ditched all chrome, Custom 10's sub enclosure, Upgraded 160 amp alt, Window tint, Relocated purge valve, Energy suspension bushings, Rear spring clamps, Rebuilt front suspension, Ditched Sway Bar, Passport 8500 Radar Detector, Ditched the baby seat- kid wasnt mine, Cigarette burn in the seat mod, Debadged, Custom Rewired/Properly Grounded.
crasher76 is offline  
#6 Old 10-23-2009, 10:07 AM
PhoenixMopar
Registered User
 
Join Date: Oct 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I'm using 5w-30 and fram filters. I've always done my own oil changes with the exception of this last time. Just never can fully trust a shop. I always use synthetic but I don't know what they used. It was a Goodyear shop if they have a company-wide policy. When this started and I checked the oil I tried to open the oil cap just in case and neither I nor my father could get it to budge... Does Goodyear use torque specs to put it back on?

I bought it used so the warranty has been up for just short of a year.

I've got the truck back and I'm going to change the oil and filter, run it for a bit, then change it again. Hopefully it's just sludge and the first oil change will help clean the gunk off all the walls... (had to take off the air filter housing and use a pair of vice grips to get the oil cap off)
PhoenixMopar is offline  
#7 Old 10-23-2009, 10:37 AM
BigHemiTex
Tex
 
BigHemiTex's Avatar
 
Join Date: Oct 2007
Location: Dallas/Ft. Worth
Posts: 3,717
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
could be your oil pump starting to fail

2003 Hemi + Mods
BigHemiTex is offline  
#8 Old 10-23-2009, 11:09 AM
greenshovel
So Mote It Be !!!
 
greenshovel's Avatar
 
Join Date: Jan 2007
Location: Harker Heights
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oil pump, I had this on my second gen ram. Took it to the dealership, they replace the sending unit, sent me on my way. Still did it, they then replaced the switch, still did it....Then the engine started to make the noise your describing, crank bearings shot due to bad oil pump.

The dodge stealership actually replaced the whole motor for free, after corporate got involved....Long story

Good luck with this.....

Steve ستيف

Member #64 "Mineral Gray Metallic Clear Coat"
Retired Combat Engineer-Regular Army
2008 Lone Star RAM 4X4 - T/G Level kit - 3" PA Body Lift - Line-X XTR in bed - OEM Nerf bars - OEM Wheel Well Liners - Micky Thompson Classics II - 17x9 - LT315/70R17 BF Goodrich - K&N Air Filter - Superchips Flashpaq Tuner 3865 - Flowmaster 50 Series Cat Back - Warn Fender Flares W/Line-X Xtra - 4.56 gears - Detroit TrueTrac -

Sig pic provided by - BMRbrnSNRbrd - Thanks Dave

"Life is not a journey to the grave with the intention of arriving safely in a pretty and well-preserved body, but rather to skid in broadside, thoroughly used up, and loudly proclaiming, 'Wow, what a ride....................So Mote It Be!!....o~`o..!'"

greenshovel is offline  
#9 Old 10-23-2009, 02:54 PM
crasher76
Im wired!!!
 
crasher76's Avatar
 
Join Date: May 2009
Location: K-TOWN
Posts: 2,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like a new motor is in your trucks near future.

Black 2003 QC SB SLT 4x4 Offroad 5.7L HEMI, Original Owner 3.92 LSD, 260 cam, 6.1 Rods/Springs, Home Ported/Polished Heads, Psc1, 04 Map sensor and Fuel pump assembly, Oil pressure guage, Amsoil, Champs, MSD 8.5MM Full length Wires, Transgo HD w/out resistor, Superchip, 180 T-Stat, K/N 77 Series, Ceramic Flowtech headers with Y-Pipe, Stage 8 locks, Ditched the cat, O2 sensor mod, Jack Rabbit bed cover, Sprayed bed liner, Big Mouth Grill-Black, Blackend Headlights/Tails, Silverstar ultras, Ditched all chrome, Custom 10's sub enclosure, Upgraded 160 amp alt, Window tint, Relocated purge valve, Energy suspension bushings, Rear spring clamps, Rebuilt front suspension, Ditched Sway Bar, Passport 8500 Radar Detector, Ditched the baby seat- kid wasnt mine, Cigarette burn in the seat mod, Debadged, Custom Rewired/Properly Grounded.
crasher76 is offline  
#10 Old 10-23-2009, 06:58 PM
PhoenixMopar
Registered User
 
Join Date: Oct 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Well I changed the oil a couple of times and ran some engine flush through it both times... no real change.

Tommorow gonna drop the oil pan and check the screen, filter and pump itself.

In the back of my mind I've been thinking it may be the pump, but if it was going bad would it not just die instead of going out then coming back on like it has been?
PhoenixMopar is offline  
#11 Old 10-23-2009, 07:06 PM
greenshovel
So Mote It Be !!!
 
greenshovel's Avatar
 
Join Date: Jan 2007
Location: Harker Heights
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by PhoenixMopar View Post
Well I changed the oil a couple of times and ran some engine flush through it both times... no real change.

Tommorow gonna drop the oil pan and check the screen, filter and pump itself.

In the back of my mind I've been thinking it may be the pump, but if it was going bad would it not just die instead of going out then coming back on like it has been?
Nope, mine did exactly like yours is doing. Good to go drop to nothing bounce a bit back to normal....Could stay normal for an hour then drop to zero whenever, no method to it's madness.

Steve ستيف

Member #64 "Mineral Gray Metallic Clear Coat"
Retired Combat Engineer-Regular Army
2008 Lone Star RAM 4X4 - T/G Level kit - 3" PA Body Lift - Line-X XTR in bed - OEM Nerf bars - OEM Wheel Well Liners - Micky Thompson Classics II - 17x9 - LT315/70R17 BF Goodrich - K&N Air Filter - Superchips Flashpaq Tuner 3865 - Flowmaster 50 Series Cat Back - Warn Fender Flares W/Line-X Xtra - 4.56 gears - Detroit TrueTrac -

Sig pic provided by - BMRbrnSNRbrd - Thanks Dave

"Life is not a journey to the grave with the intention of arriving safely in a pretty and well-preserved body, but rather to skid in broadside, thoroughly used up, and loudly proclaiming, 'Wow, what a ride....................So Mote It Be!!....o~`o..!'"

greenshovel is offline  
#12 Old 10-23-2009, 08:24 PM
chambers
Registered User
 
Join Date: Dec 2008
Posts: 801
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sub'd, good luck it sounds like the oil pump considering Steve's experience in which he had the same symptoms.

3.7L Powertech Club Member #12

Mods:
SCT tuned by hemifever
True Flow intake w/ AEM dryflow filter
ASP underdrive pulley
Taurus e-fan
Magnaflow muffler dual-in single-out (factory y gone)
Jet stream scoop
jba titanium ceramic headers
Fastman ported TB
Line-x bedliner, rocker panels, and tailgate
Hellwig anti-sway bar
chambers is offline  
#13 Old 10-24-2009, 06:17 AM
crasher76
Im wired!!!
 
crasher76's Avatar
 
Join Date: May 2009
Location: K-TOWN
Posts: 2,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Good luck!

Black 2003 QC SB SLT 4x4 Offroad 5.7L HEMI, Original Owner 3.92 LSD, 260 cam, 6.1 Rods/Springs, Home Ported/Polished Heads, Psc1, 04 Map sensor and Fuel pump assembly, Oil pressure guage, Amsoil, Champs, MSD 8.5MM Full length Wires, Transgo HD w/out resistor, Superchip, 180 T-Stat, K/N 77 Series, Ceramic Flowtech headers with Y-Pipe, Stage 8 locks, Ditched the cat, O2 sensor mod, Jack Rabbit bed cover, Sprayed bed liner, Big Mouth Grill-Black, Blackend Headlights/Tails, Silverstar ultras, Ditched all chrome, Custom 10's sub enclosure, Upgraded 160 amp alt, Window tint, Relocated purge valve, Energy suspension bushings, Rear spring clamps, Rebuilt front suspension, Ditched Sway Bar, Passport 8500 Radar Detector, Ditched the baby seat- kid wasnt mine, Cigarette burn in the seat mod, Debadged, Custom Rewired/Properly Grounded.
crasher76 is offline  
#14 Old 12-11-2009, 11:54 PM
mailiboy
Registered User
 
Join Date: Dec 2007
Location: Waianae
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
had same problem on my 04 ram, drop oil pan. full of slug, also removed pick up tube and cleaned. did't have a problem after. switched to sinthetic oil. about 1 1/2 year later started again. droped pan and found pick up tube cloged, but no slug this time. it was all the crap that was left by slug problem. was easy fix. been about 6 months now and no problems.
mailiboy is offline  
#15 Old 12-12-2009, 01:34 AM
speedy81304
Registered User
 
Join Date: Jan 2009
Location: Effort
Posts: 358
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
if you lost oil pressure for more then a couple secs. the damage is already done. and you say you would drive it for mins even longer. and it making a noise now. I say your pump is going or gone. and your going to need a new engine or a rebuild. dont forget theres no cam bearings in the heads the cams ride on the head. and if oil pressure dropped and no oil got to the cam area. your cams and heads are done for.
speedy81304 is offline  
#16 Old 12-12-2009, 04:44 AM
Turboram4.7
ASE master certified
 
Turboram4.7's Avatar
 
Join Date: Dec 2009
Posts: 83
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
come'on guys an oil psi switch wont make the knocking he's describing...

what normally happens in the 4.7 is 2 things

1. the sludge/carbon chunks in the engine clog up the filter screen and block oil flow to the bearings causing you to chew up conncting rod bearings in short order (5 mins)

2. the timing chain guide is plastic after alot of heat cycles the thing snaps and winds up floating in you oil pan , eventually it clogs up the oil pump pickup tube and bam cuts oil pressure and you chew up bearings , how long it takes to destroy the engine depends on how clogged the tube screen is ...

you have noise so one of your connecting rod bearings is shot guarenteed , mine almost suffered the same fate but I caught it in time ...

pull the oil pan and clean out the tube screen , check for any kinda crap in there , the plastic will be orangy colored ...

there is no way to just change the oil and fix it , you have to pull the pan , there will also be about 1/4" of sludge in the bottom of the pan


the dealer wants you to think its a pump , more money involved there then replacing the pickup tube and cleaning the pan or changing the switch , 9 times out of 10 its the pickup tube , usually my customers let me catch it in time before they need a new engine , but 2 hours ? your engines done bro, sorry

2003 dodge ram 1500 4.7 auto,twin garrett T-03 turbos,pcv/valve cover mod, srt-10 seats,srt dash bezel,srt brakes,billet gas door ,future mods include 08 front end conversion, some kinda drop kit 4/6

Last edited by Turboram4.7; 12-12-2009 at 04:51 AM.
Turboram4.7 is offline  
#17 Old 12-12-2009, 08:44 AM
greenshovel
So Mote It Be !!!
 
greenshovel's Avatar
 
Join Date: Jan 2007
Location: Harker Heights
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Turboram4.7 View Post
come'on guys an oil psi switch wont make the knocking he's describing...

what normally happens in the 4.7 is 2 things

1. the sludge/carbon chunks in the engine clog up the filter screen and block oil flow to the bearings causing you to chew up conncting rod bearings in short order (5 mins)

2. the timing chain guide is plastic after alot of heat cycles the thing snaps and winds up floating in you oil pan , eventually it clogs up the oil pump pickup tube and bam cuts oil pressure and you chew up bearings , how long it takes to destroy the engine depends on how clogged the tube screen is ...

you have noise so one of your connecting rod bearings is shot guarenteed , mine almost suffered the same fate but I caught it in time ...

pull the oil pan and clean out the tube screen , check for any kinda crap in there , the plastic will be orangy colored ...

there is no way to just change the oil and fix it , you have to pull the pan , there will also be about 1/4" of sludge in the bottom of the pan


the dealer wants you to think its a pump , more money involved there then replacing the pickup tube and cleaning the pan or changing the switch , 9 times out of 10 its the pickup tube , usually my customers let me catch it in time before they need a new engine , but 2 hours ? your engines done bro, sorry
Not always true, mine had no sludge as that was the deciding factor if they were going to pay or me. They paid as the pan had no sludge....I was also there to see myself to ensure they (the stealership) wouldn't BS me ....

Quote:
Originally Posted by greenshovel View Post
Oil pump, I had this on my second gen ram. Took it to the dealership, they replace the sending unit, sent me on my way. Still did it, they then replaced the switch, still did it....Then the engine started to make the noise your describing, crank bearings shot due to bad oil pump.

The dodge stealership actually replaced the whole motor for free, after corporate got involved....Long story

Good luck with this.....
Turbo, if you read my post you will see that the knocking didn't take place until after they swapped the switch, not during the knocking.

To the OP what was the final results to the situation?

Steve ستيف

Member #64 "Mineral Gray Metallic Clear Coat"
Retired Combat Engineer-Regular Army
2008 Lone Star RAM 4X4 - T/G Level kit - 3" PA Body Lift - Line-X XTR in bed - OEM Nerf bars - OEM Wheel Well Liners - Micky Thompson Classics II - 17x9 - LT315/70R17 BF Goodrich - K&N Air Filter - Superchips Flashpaq Tuner 3865 - Flowmaster 50 Series Cat Back - Warn Fender Flares W/Line-X Xtra - 4.56 gears - Detroit TrueTrac -

Sig pic provided by - BMRbrnSNRbrd - Thanks Dave

"Life is not a journey to the grave with the intention of arriving safely in a pretty and well-preserved body, but rather to skid in broadside, thoroughly used up, and loudly proclaiming, 'Wow, what a ride....................So Mote It Be!!....o~`o..!'"


Last edited by greenshovel; 12-12-2009 at 11:40 AM. Reason: Added content...
greenshovel is offline  
#18 Old 12-12-2009, 10:05 AM
peeblesm
ol faithful
 
peeblesm's Avatar
 
Join Date: Jan 2009
Location: Fort Leonard Wood
Posts: 826
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
interesting info here guys. i'm so tempted to drop my oil pan and see how my bottom end looks like.

2004 dodge ram 1500 4.7L engine. quadcab; shortbed 2wd military guy
nv3500 5-speed tranny
s&b cold air intake
4.56 motive gears and detroit tru trac in the rear end
centerforce II clutch
gibson headers, dual exhaust
flowmaster mufflers 40 series
NGK Spark Plugs (G-power) ZFR6FGP 7100
jet performance 180* t-stat
hurst competition plus shifter #3910155 (94-00 dakota v8) fits nv3500 tranny
line-x spray in bedliner over the rails
camper shell (A.R.E. brand with no windows on the side. too many blind spots now)
kool vue tow mirrors
debadged ram 1500 letters on both sides
PML diff. cover(I like it)
265/70/17 tires on stock rims painted metallic black ( holding up good so far. lol )
peeblesm is offline  
#19 Old 12-12-2009, 11:20 AM
Turboram4.7
ASE master certified
 
Turboram4.7's Avatar
 
Join Date: Dec 2009
Posts: 83
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
if you have 2wd its so damn easy to drop the oilpan , not sure who said you need to lift the motor , but you dont have 2

2003 dodge ram 1500 4.7 auto,twin garrett T-03 turbos,pcv/valve cover mod, srt-10 seats,srt dash bezel,srt brakes,billet gas door ,future mods include 08 front end conversion, some kinda drop kit 4/6
Turboram4.7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 D100 A/C wiring prob / Engine prob kkcummins98 1972-1987 Dodge Ram Trucks (D, W-series) 4 06-06-2009 05:44 AM
2004 Ram 1500 4x4 Check Engine Light fmaglin 3G Dodge RAM - General Talk 1 03-02-2008 10:30 AM
2004 Ram 1500 Hemi Dual Exhaust Installed and Check Engine Light problem jjames15ca 3G Dodge Ram Performance Talk 13 01-09-2008 07:02 PM
2005 ram 1500 electrical loss prob Embalmer 3G Dodge RAM - 4X4 Talk 1 04-06-2007 06:45 PM
2004 Durango rims on 2004 1500 ram? mfc 3G Dodge RAM - General Talk 2 11-09-2004 05:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome