Engine code PO 456 ? - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 04-27-2009, 10:54 AM
Cain
Registered User
 
Cain's Avatar
 
Join Date: Jul 2006
Location: Kingston
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Engine code PO 456 ?

Hey All,
A while back the engine light came on in my wifes 03 Ram, she took it to advanced auto, they hooked up their little diagnostic computer and it gave this code PO 456. They told her it was a gas cap issue, it might not be on all the way, sooo, she tightened the cap up and the light went out....woo hoo
HOWEVER, now its back on !! So this time I took it over to Advanced Auto and it spit back the same code. So I took off my gas cap from my 03 Ram and switched it out with hers, my thinking for this was, since im not haveing issues with my gas cap and were the same make, modle, and year no harm no foul. Well, the pretty little check engine light IS STILL ON
So, heres my question. Has anyone else had this issue? If so, what was your remedy to fix?
Also, was I mis-informed at Advanced Auto? Is the PO 456 code something other than a gas cap issue?
Any and ALL help is appreciated.
Cain is offline  
Sponsored Links
Advertisement
 
#2 Old 04-27-2009, 11:02 AM
SchroederMP
living life
 
SchroederMP's Avatar
 
Join Date: Apr 2009
Location: Columbus
Posts: 6,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My threw the same code. I'm not a mechanic by all mean but it had to do something with a purge sylidoid for emissions and a couple other things. They should have printed you out a ticket with all of the things the code could have ment. Then take that ticket to the dealer and they will run a better diagnostic on it.

2005 CTD 4x4-5" Turbo back exhaust, Icebox CAI, Smarty, AirDog, built tranny, leveled, Linex Rockers


1993 Dodge Stealth 3.0L 5sp-Project/Gas Saver


SchroederMP is offline  
#3 Old 04-27-2009, 11:04 AM
Palmentech766
^GM Goodwrench Certified^
 
Palmentech766's Avatar
 
Join Date: Oct 2008
Location: Racine
Posts: 2,918
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
p0456 is a small evap leak, most commonly caused by a faulty gas cap. Other things can cause it are most likely a crack in an evap system rubber hose.

2013 Ram 1500 Outdoorsman Mineral Gray
1978 AMC Matador Wagon Morocco Buff
1967 AMC Ambassador Convertible Matador Red
Palmentech766 is offline  
#4 Old 04-27-2009, 11:26 AM
SchroederMP
living life
 
SchroederMP's Avatar
 
Join Date: Apr 2009
Location: Columbus
Posts: 6,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
What he said

2005 CTD 4x4-5" Turbo back exhaust, Icebox CAI, Smarty, AirDog, built tranny, leveled, Linex Rockers


1993 Dodge Stealth 3.0L 5sp-Project/Gas Saver


SchroederMP is offline  
#5 Old 04-27-2009, 12:21 PM
Cain
Registered User
 
Cain's Avatar
 
Join Date: Jul 2006
Location: Kingston
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
If it is the rubber hose, is it an easy fix? And if so, where abouts is it located?
Cain is offline  
#6 Old 04-27-2009, 12:35 PM
mississaugaram
Are we going down?
 
mississaugaram's Avatar
 
Join Date: Oct 2005
Posts: 787
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same code last week, P0456. I crawled under the truck and checked my evap. hoses and found one had a small crack. You can find them on the drivers side just under the doors, there is a black box with a couple of hose's there. The hose I needed was part # 5210279aa. It cost me 10 bucks to fix. I will try to post a diagram I got off this site. Bye the way the code has not reappeared. Hope this helps.
Attached Files
File Type: pdf p0456_p0442.pdf (339.2 KB, 113 views)

2003 Dodge Ram Quadcab Sport 4X4
Silver
Hemi
3.92 gears,running boards,SRT-10 hood, rollup tonneau cover,cup holder light, carpeted fold flat floor,ebay CAI


Silver Truck Club Member # 134



Last edited by mississaugaram; 04-27-2009 at 12:42 PM.
mississaugaram is offline  
#7 Old 04-27-2009, 12:44 PM
Cain
Registered User
 
Cain's Avatar
 
Join Date: Jul 2006
Location: Kingston
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Great Diagram, very helpful. I will look at that this weekend to see if I can detect any cracks.
Thank you
Cain is offline  
#8 Old 05-16-2009, 05:08 PM
Rev jd
Registered User
 
Join Date: Nov 2004
Location: Tehachapi
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have this same code and the same 2 hoses show little cracks right at the fittings. Do I have to use the factory replacement hoses, or can I get hose from my parts house and bend them (maybe a little wider bend) to fit? Is there anything that would cause the hoses to collapse, etc., or otherwise foul things up if I did this?

2003 Ram QC 2WD
-Mighty 4.7 V8
-Volant Intake
-Fastman TB
-Flowmaster Exhaust
-Superchip
-4.56 Yukons (installed soon!)
-20' ECO rims
Rev jd is offline  
#9 Old 05-16-2009, 05:31 PM
rye
Moderator
 
rye's Avatar
 
Join Date: Apr 2009
Location: Ontario, Canada
Posts: 11,180
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If you can't find a leak, you can take it to a garage for a smoke test. Shouldn't be more than $40 for that. Just get them to tell you where the leak is and fix it yourself.





DODGETALK.COM MODERATOR
─────────────────────────────────────────────
5.9 2003 1500 4x4
─────────────────────────────────────────────

Official Dodgetalk Facebook Page:
http://www.facebook.com/DodgeTalk
Like us! Prize Giveaways, News, and More!!!

rye is offline  
#10 Old 05-16-2009, 05:40 PM
Rev jd
Registered User
 
Join Date: Nov 2004
Location: Tehachapi
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oh, I can see the cracks in the hoses, so I'm sure that's where the leak is. I went ahead and called my trusty dealership to buy the hoses. They have one in stock and ordered the other for me. I was just trying to be a cheap-o, as usual!

2003 Ram QC 2WD
-Mighty 4.7 V8
-Volant Intake
-Fastman TB
-Flowmaster Exhaust
-Superchip
-4.56 Yukons (installed soon!)
-20' ECO rims
Rev jd is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
456 install luvcycles2 3G Dodge RAM - General Talk 1 02-01-2009 04:03 PM
diagnostic code 456 donnie_roe 1G Dodge Durango General Talk 1 07-02-2007 10:22 PM
Check Engine code 2002 3.3 engine login Dodge Caravan General Talk 5 04-19-2006 11:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome