Turn signal flasher unit- - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 05-28-2004, 08:36 PM
jeepfreek
Registered User
 
jeepfreek's Avatar
 
Join Date: May 2004
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Turn signal flasher unit-

I picked up what they gave me at the parts store and its a typical 552 flasher unit. However- where the Haynes manual says it should be- its not. What gives? The reason I want to change it is because intermittently the turn signals will stop flashing for a bit. All bulbs are OK. Its a 99 Durango by the way.
jeepfreek is offline  
Sponsored Links
Advertisement
 
#2 Old 05-30-2004, 10:15 PM
caseyt
The Wild One
 
caseyt's Avatar
 
Join Date: Nov 2003
Location: Roseville, CA
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Talking

On the 99, the flasher is in a "hidden" fuse block behind the inside fuse panel, under the dash. You have to reach under the dash to get to it.

-Casey

Buy My Passenger Side Headlight!

White 1999 Dodge Durango SLT 4X4 5.9L
135k and counting...
Mods:
32x11.5x15 BFG Mud Terrains ~ Warn Trans4mer Grille Guard (soon to be replaced w/ Wincher Bumper)~ Rancho 9000x Shocks ~ Autolite 3923's ~ 12" SoundStream Subwoofer w/540 watt amp. ~ 4 Channel 300 Watt Alpine amp. ~ Pioneer Head Unit ~ Overhead DVD entertainmet system ~ Cobra 75WSXT CB with 4' Firestik Antenna ~ Shackle/Torsion lift ~ Hayden Tranny cooler ~ Aux electric cooling fan. ~ Black Halo CCFL Headlights ~ 5" 55w Procomp Off Road lights (comming in new bumper) ~ On Board Air System w/2 compressors and 5.5 gallons of air ~ 160db Air Horns ~ Kinetik HC2000 Battery ~ AlterStart 205AMP Alternator

caseyt is offline  
#3 Old 05-31-2004, 05:25 AM
jeepfreek
Registered User
 
jeepfreek's Avatar
 
Join Date: May 2004
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yep I found that- but I can't determine whats actually the flasher unit. The part I thought it was I pulled it and the turn signals still worked. So figured that wasn't it. Brilliant work I know...... Anyways- is it located quite high up on that hidden panel? Hard to get my damn hands up there.
jeepfreek is offline  
#4 Old 06-02-2004, 12:52 PM
lvd2340
Registered User
 
Join Date: Jan 2003
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This is right out of a Dodge service manual:

The combination flasher is located in the relay and fuse block which is located on the back of the junction block near the dash panel under the left end of the instrument panel.

Part # is 56021915AA and retails from Dodge for $33.60
lvd2340 is offline  
#5 Old 04-09-2005, 09:32 PM
3dron
Registered User
 
Join Date: Apr 2005
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Turn signal problem: I have same problem on a 2000 Durango

Is the "combination flasher" in the same place in a 2000, as it is in a 1999? Yesterday at Dodge service they told me it was the actual turn switch that was the problem (after I said I think a relay is bad.) So now it is $75 latter for the factory switch and an hour of my time, and I find that it made no difference.

Or is this now part of the whole turn signal switch assembly on the steering column that Dodge service told me was the problem?

Ron R.
3dron is offline  
#6 Old 04-10-2005, 08:50 AM
rockadaous
Keystoner
 
rockadaous's Avatar
 
Join Date: May 2003
Location: N.C.
Posts: 5,534
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
http://www.dodgetalk.com/forums/show...hlight=flasher
here's the thread I started. Hope it helps


rock
99 SLT+ 4X4 (5.2/318 & 44RE trans)
Patriot Blue (3.55 axle ratio)
Interior mods
APC rev glow gauges*Lotek Gauge Pod w/APC gauges*Nu-Image A/C & light panel*Redline shifter*Pilot titanium mesh pedals*Nu-Image gauge bezel*dodge logo door sills*blue jel light covers*Phoenix imaging interior
Exterior mods
Keystone kit*Cervinis SS Hood*Keystone Spoiler*Billet gas door*Altezza tail lights*Diamond cut euro headlights & parks*SS speed grille*3A Racing fog lights*APC M3 mirrors* MB Motoring Smoothies 20X10*Goodyear Eagle GT II 275/45/20*Pilot billet antenna*chrome differential cover*shaved roof rack*vent visors*APC bulbs*smiley grill*reflex shocks*drilled & slotted rotors*hawk HPS pads*TFP handle covers*2" drop"debadged
Engine mods
Intense performance stage II CAI w/9" big mouth filter*mopar valve covers*TD billet engine caps*180 T-stat*IAT Sensor Mod*GSport radiator hose*Goodyear gatorback S-belt*Flowmaster 40 series muffler*Dual exhaust*synthetic fluids*yellow loomz*brass cap & rotor* BP billet fuse cover*AL 3923 plugs*

http://members.cardomain.com/durang0

rockadaous is offline  
#7 Old 06-22-2005, 08:02 AM
bblank
Registered User
 
Join Date: Jun 2005
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 Dodge Durango

I looked for the flasher unit in the two places you guys posted here and cannot find it. Would it be somewhere different on a 2003? I was trying to get my trailer lights working and somehow managed to kill my flashers and hazard lights, changed all the fuses and so it looks like the flasher unit is toast.
bblank is offline  
#8 Old 01-09-2006, 01:05 PM
bradhrbj
Registered User
 
Join Date: Jan 2006
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey,

I have the exact same issue here with my 03 Durango. Working on the trailer lights, something gets fried, now I have no turn signals or hazard lights and all fuses in the main fuse panel are ok. I cannot locate any other turn signal/flasher fuse or relay, any ideas?

Please let me know at brad (at) neverthehero (dot) com

Thanks!
bradhrbj is offline  
#9 Old 01-16-2006, 11:45 AM
chieferman
Registered User
 
Join Date: Feb 2005
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
flasher module or actual signal in column?

My turn signals started to act up last week. They will stay on for a few seconds , sometimes more, sometimes less. I don't know if its the unit under that dash or the unit in the steering column. Like I said they work for just a bit then shut off. Any suggestions?
chieferman is offline  
#10 Old 01-17-2006, 08:20 AM
jeepfreek
Registered User
 
jeepfreek's Avatar
 
Join Date: May 2004
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Sounds like the regular turn signal flasher under the dash. Acting just like mine did.

99 SLT 5.2 Mobil 1 in the crankcase
Synthetics in Xfer case and diffs so far
Shackle/Torsion bar lift
32X11.5 BFG Mud Terrains
DYNOMAX muffler
K+N Filter
Pro-Line Roof Rack
Wilson 5000 CB Antenna
2 6" KC Highlighters on top
Sensatracs
3923 Sparkers
jeepfreek is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome