Battery going dead overnight, help! - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 12-20-2008, 01:23 PM
jram03
Registered User
 
jram03's Avatar
 
Join Date: Nov 2007
Location: New Port Richey
Posts: 612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Battery going dead overnight, help!

Finally got my long tube headers on a few weeks ago.

Now, my battery goes dead when truck sits one or two days without being driven.

I took the truck to get charging system checked and they said battery was bad, so I bought a new Optima Red top. Same thing, goes dead if I don't drive it everyday.

When I installed headers, I pulled the wires out of one of the o2 sensor plugs. I do not get any codes, could wiring the o2 sensor wrong cause this?

Any suggestions?


2003 Quad Cab 1500 Thunder Road pkg. 5.7 HEMI
Superchips, Gibson Supertruck Exhaust, Hotchkis Performance Suspension 2/4 Drop, Load leveler bags, TCM mod. Oasis 22's with Falken STZ04. Street Scene speed grill(s). 20% Tinted windows. Painted Red to match: mirrors, handles, ground effects, EFX roll pan, calipers, rotors, fuse box cover and interior trim. Red Powder coated valve covers. Super Bee embroidery on front seats. Super Bee hood and bed strips. Sig pic by "Rye"
Stereo: Pioneer DEH-77P Head unit w/ CD player, Infinity upgraded door and dash speakers amped by Kenwood KAC-8402 720W, 2-12" JBL subs driven by MTX 1501 1500W under back seat.

Future Mods:Letting things mellow for a while.............

Member #302 "The Red Truck Club"
Member #10 "Ohio Truck Club"
jram03 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-20-2008, 01:26 PM
Tom
Registered User
 
Tom's Avatar
 
Join Date: Aug 2002
Location: Austin
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would not think so, but you either have an energy drain somewhere or the red top is also bad. Check the battery first before exploring any more.
Tom is offline  
#3 Old 12-20-2008, 01:33 PM
jordan21210
Senior Member
 
jordan21210's Avatar
 
Join Date: Jul 2007
Location: Baton Rouge/Houma, LA
Posts: 3,353
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
could be a bad alternator

2011 Ram 1500 CC Sport
jordan21210 is offline  
#4 Old 12-20-2008, 01:34 PM
BobtheBuilder
Registered User
 
BobtheBuilder's Avatar
 
Join Date: Dec 2008
Location: Humble
Posts: 1,748
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
definitely not o2 sensor
check for anything staying on stereo amp or maybe your on board compressor maybe electric fan?

Bob
2005 QC Black w/scratches and a few more dents now
1500 4x4
4.7
3.92's
265/70-17 destination a/t
70k
But I keep it clean
BobtheBuilder is offline  
#5 Old 12-20-2008, 01:51 PM
hawks4x4ram
Registered User
 
Join Date: Dec 2007
Location: Central IL
Posts: 380
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would be looking for any pinched wires that might have happened during installation of the headers. Good luck!!!

'04 Dodge Ram QC 1500 4x4
285/70/17 BFG All Terrains
Everything else pretty much stock (As far as Dodge is concerned )


"That's what I love about these high school girls, man. I get older, they stay the same age." Wooderson, Dazed and Confused
hawks4x4ram is offline  
#6 Old 12-20-2008, 02:18 PM
jram03
Registered User
 
jram03's Avatar
 
Join Date: Nov 2007
Location: New Port Richey
Posts: 612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I had it on the lift at the local muffler shop last Tuesday, I couldn't find anything obviously pinched. Everything electrical seems to be working correctly, charging system, lights, etc.

There are so many things that are powered when the trucks not on you can't really just do a positive to ground check.

Someone told me there are things in the computer that could cause a power drain?

Could a bad voltage regulator in the alternator do this?

I'm going to start unplugging any aftermarket items like the air compressor and the stereo amps to try to track it down.

I was hoping someone had seen this before and maybe it was a "dodge quirk" of some sort that pops up. It really stinks because this makes me very nervous driving anywhere worrying about getting stranded in the cold, more so for my wife's sake.

Oh well, going out in the cold to pull some fuses. Thanks for the ideas so far.


2003 Quad Cab 1500 Thunder Road pkg. 5.7 HEMI
Superchips, Gibson Supertruck Exhaust, Hotchkis Performance Suspension 2/4 Drop, Load leveler bags, TCM mod. Oasis 22's with Falken STZ04. Street Scene speed grill(s). 20% Tinted windows. Painted Red to match: mirrors, handles, ground effects, EFX roll pan, calipers, rotors, fuse box cover and interior trim. Red Powder coated valve covers. Super Bee embroidery on front seats. Super Bee hood and bed strips. Sig pic by "Rye"
Stereo: Pioneer DEH-77P Head unit w/ CD player, Infinity upgraded door and dash speakers amped by Kenwood KAC-8402 720W, 2-12" JBL subs driven by MTX 1501 1500W under back seat.

Future Mods:Letting things mellow for a while.............

Member #302 "The Red Truck Club"
Member #10 "Ohio Truck Club"
jram03 is offline  
#7 Old 12-20-2008, 03:58 PM
AER_DAVID
Registered User
 
AER_DAVID's Avatar
 
Join Date: Apr 2008
Location: Palm City
Posts: 1,256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just don't do the old trick of disconnecting the battery while running on that truck , but do check the batt with a volt meter while not running should see around 12.50-13 v, then start it up and check it again you should see a signifigant increse in voltage depending on your low status . If no increase get you an alternator.

MoesPerformance.com
red truck club #282
TMS CLUB MEMBER #1
CENTRAL FLORIDA CHAPTER MEMBER #8
<05> BIG RED BRICK QCSB4X4R.I.P.
03 QCLB 2500 4X4 LARAMIE CTD
AER_DAVID is offline  
#8 Old 12-20-2008, 04:13 PM
jram03
Registered User
 
jram03's Avatar
 
Join Date: Nov 2007
Location: New Port Richey
Posts: 612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, just came in, may a$$ is frozen! It's only 25 here, arrrg!
The battery reads a solid 12.5v with truck off and goes to 14+ with it running. (but this is after I took it off the battery charger, so ?)
If I can't figure it out by Monday, guess I'll take it somewhere $$$$$......

I did disconnect (pulled the fuses) to the air compressor, under glow led lights and unplugged the under hood light to see what happens.

Checked the amplifiers, they show no voltage when radio is off, just like they should.

The only other thing I did shortly after putting on the headers is change my superchips from performance/tow to 91 performance. I can't see that changing anything. May change it back tommorrow if I go out and it's dead again.


2003 Quad Cab 1500 Thunder Road pkg. 5.7 HEMI
Superchips, Gibson Supertruck Exhaust, Hotchkis Performance Suspension 2/4 Drop, Load leveler bags, TCM mod. Oasis 22's with Falken STZ04. Street Scene speed grill(s). 20% Tinted windows. Painted Red to match: mirrors, handles, ground effects, EFX roll pan, calipers, rotors, fuse box cover and interior trim. Red Powder coated valve covers. Super Bee embroidery on front seats. Super Bee hood and bed strips. Sig pic by "Rye"
Stereo: Pioneer DEH-77P Head unit w/ CD player, Infinity upgraded door and dash speakers amped by Kenwood KAC-8402 720W, 2-12" JBL subs driven by MTX 1501 1500W under back seat.

Future Mods:Letting things mellow for a while.............

Member #302 "The Red Truck Club"
Member #10 "Ohio Truck Club"
jram03 is offline  
#9 Old 12-20-2008, 04:18 PM
DODGENUTT
Silver Member
 
Join Date: Nov 2008
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Did You Loosen The Ground Wire To Install Headers?

You Need A Good Ground
DODGENUTT is offline  
#10 Old 12-20-2008, 05:02 PM
AER_DAVID
Registered User
 
AER_DAVID's Avatar
 
Join Date: Apr 2008
Location: Palm City
Posts: 1,256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

MoesPerformance.com
red truck club #282
TMS CLUB MEMBER #1
CENTRAL FLORIDA CHAPTER MEMBER #8
<05> BIG RED BRICK QCSB4X4R.I.P.
03 QCLB 2500 4X4 LARAMIE CTD
AER_DAVID is offline  
#11 Old 12-20-2008, 06:41 PM
kenihemi
Senior Member
 
kenihemi's Avatar
 
Join Date: Mar 2004
Location: The Soprano State
Posts: 2,608
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like your new battery is toast.

But, to be sure you have to isolate the drain if that is actually the problem. Make sure the connections are clean.

You can't just use a voltmeter to check the battery condition. You need to have it load tested.

You say that it was 12 when off and 14 when it was running means that the charging system is probably working fine.

I personally don't like Optima batteries. IMHO they suck in a street driven truck.

'04 Hemi Ram 1500 QC, 4X4, 4.56 gears, STS turbo = 450+RWHP, SCT Tuner, B&M MegaShifter.

Last edited by kenihemi; 12-20-2008 at 06:47 PM.
kenihemi is offline  
#12 Old 12-20-2008, 09:09 PM
piper18
Great View
 
piper18's Avatar
 
Join Date: Oct 2007
Location: Fond du Lac
Posts: 1,048
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
How you find a drain on the battery. With the engine off, disconnect the one lead of the battery and hook a ampmeter between the lead and the battery. Make sure there everything is off, dome light or hood light. There should be only a couple of milliamps of drain normally. If you have more then start pulling fuses one at a time and see if it goes away. You might find the circuit that is draining the battery.

2008 Dodge Ram 1500 4x4 SLT, 5.7 Hemi MDS, Regular Cab, Long Box, 3.55 LS rear end ,17" cast wheels, Flame Red

Member of the Red Truck Club #231


Switch installed in chime circuit to turn off chime Click to learn How To add a switch to the chime circuit
Installed MDS indicator light on dash ---Click to learn How To install a MDS light
Tools Box w/ lights inside tided to cargo light
Custom made deer guard 2" pipe
Sportsmaster Tonneau cover w/top gun fabric
Mopar rear wheel liners
Iron Cross stainless 3" step bars
Tailgate open indicator light
9005 fog light bulbs
piper18 is offline  
#13 Old 12-20-2008, 09:39 PM
desync0
Gear Jammer
 
desync0's Avatar
 
Join Date: Jan 2008
Location: Windsor,On,Canada
Posts: 251
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
piper18 has it right. anything that's drawing enough power to stop the truck from starting in only a few days should have a noticeable drop on an ammeter when you pull the fuse powering what ever is causing the drain.

2002 Flame Red QC 4x2 Sport With a 360! Sold
Red truck club member #251
2011 Wrangler Trading ASAP I miss my truck!
desync0 is offline  
#14 Old 12-20-2008, 11:25 PM
BobtheBuilder
Registered User
 
BobtheBuilder's Avatar
 
Join Date: Dec 2008
Location: Humble
Posts: 1,748
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yep what he said

Bob
2005 QC Black w/scratches and a few more dents now
1500 4x4
4.7
3.92's
265/70-17 destination a/t
70k
But I keep it clean
BobtheBuilder is offline  
#15 Old 12-21-2008, 08:44 AM
jram03
Registered User
 
jram03's Avatar
 
Join Date: Nov 2007
Location: New Port Richey
Posts: 612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks piper18, I knew there would be a way to logically figure this out, I just couldn't think of it. That's the answer I think I was looking for!

Getting ready to go see if my unplugged items where the problem, if not I'll re-charge it and start testing with the amp meter.

Kenihemi, why not the Optima? It cost almost twice as much as the top of the line regular battery any way, so if it's not dependable, I'll take the darn thing back.

I'll let everyone know this afternoon what's happening.

Thanks so much for every ones ideas.

I did take negative cable off when I installed headers, but ground wire on engine is on the block, so I didn't have to mess with it.


2003 Quad Cab 1500 Thunder Road pkg. 5.7 HEMI
Superchips, Gibson Supertruck Exhaust, Hotchkis Performance Suspension 2/4 Drop, Load leveler bags, TCM mod. Oasis 22's with Falken STZ04. Street Scene speed grill(s). 20% Tinted windows. Painted Red to match: mirrors, handles, ground effects, EFX roll pan, calipers, rotors, fuse box cover and interior trim. Red Powder coated valve covers. Super Bee embroidery on front seats. Super Bee hood and bed strips. Sig pic by "Rye"
Stereo: Pioneer DEH-77P Head unit w/ CD player, Infinity upgraded door and dash speakers amped by Kenwood KAC-8402 720W, 2-12" JBL subs driven by MTX 1501 1500W under back seat.

Future Mods:Letting things mellow for a while.............

Member #302 "The Red Truck Club"
Member #10 "Ohio Truck Club"

Last edited by jram03; 12-21-2008 at 08:50 AM.
jram03 is offline  
#16 Old 12-21-2008, 07:00 PM
kenihemi
Senior Member
 
kenihemi's Avatar
 
Join Date: Mar 2004
Location: The Soprano State
Posts: 2,608
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I don't care for the optimas because some friends that have had them watched them fail prematurely.

For the money, they are no way worth it IMHO. Just because they cost more doesn't mean they are better. Have it load tested and if its bad, take it back if its still withing its warranty.

I have an Energizer regular battery in my truck. Works great.

'04 Hemi Ram 1500 QC, 4X4, 4.56 gears, STS turbo = 450+RWHP, SCT Tuner, B&M MegaShifter.
kenihemi is offline  
#17 Old 12-22-2008, 03:26 PM
jram03
Registered User
 
jram03's Avatar
 
Join Date: Nov 2007
Location: New Port Richey
Posts: 612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Couldn't find anything obvious with the tester looking for voltage changes unplugging things. I had already unplugged the under hood light and truck has started fine the last two days. Maybe?

I'm going to let it sit until wed. and try it again. If it's Ok, then the light must be the problem.

If I have any more problems, I'm taking it to a local shop that specializes in Batteries, starters, alternators etc. Friday.

Place I bought the Optima from said they would not take battery back unless something was wrong with it, then they would only replace it with another of the same. So looks like I'll be doing a (hopefully) long term test on it.


2003 Quad Cab 1500 Thunder Road pkg. 5.7 HEMI
Superchips, Gibson Supertruck Exhaust, Hotchkis Performance Suspension 2/4 Drop, Load leveler bags, TCM mod. Oasis 22's with Falken STZ04. Street Scene speed grill(s). 20% Tinted windows. Painted Red to match: mirrors, handles, ground effects, EFX roll pan, calipers, rotors, fuse box cover and interior trim. Red Powder coated valve covers. Super Bee embroidery on front seats. Super Bee hood and bed strips. Sig pic by "Rye"
Stereo: Pioneer DEH-77P Head unit w/ CD player, Infinity upgraded door and dash speakers amped by Kenwood KAC-8402 720W, 2-12" JBL subs driven by MTX 1501 1500W under back seat.

Future Mods:Letting things mellow for a while.............

Member #302 "The Red Truck Club"
Member #10 "Ohio Truck Club"
jram03 is offline  
#18 Old 12-22-2008, 03:29 PM
piper18
Great View
 
piper18's Avatar
 
Join Date: Oct 2007
Location: Fond du Lac
Posts: 1,048
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your have to measure amperage not Voltage

2008 Dodge Ram 1500 4x4 SLT, 5.7 Hemi MDS, Regular Cab, Long Box, 3.55 LS rear end ,17" cast wheels, Flame Red

Member of the Red Truck Club #231


Switch installed in chime circuit to turn off chime Click to learn How To add a switch to the chime circuit
Installed MDS indicator light on dash ---Click to learn How To install a MDS light
Tools Box w/ lights inside tided to cargo light
Custom made deer guard 2" pipe
Sportsmaster Tonneau cover w/top gun fabric
Mopar rear wheel liners
Iron Cross stainless 3" step bars
Tailgate open indicator light
9005 fog light bulbs
piper18 is offline  
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Generic Chrysler Diagnostic Trouble Code List tactransman 3G Dodge Dakota General Talk 0 10-18-2007 01:27 PM
Dead Battery Now Transmission Problem bdrolet Dodge Caravan General Talk 2 09-17-2007 02:50 PM
Dead Battery and now Stratus has mind of it's own! angelau 2G Dodge Stratus - Performance Talk 1 07-25-2007 06:00 AM
Magnum dead battery still443 Dodge Magnum - General Talk 7 07-19-2005 08:37 AM
Dead battery, cranking twice floods it Thristy D New_D 1G Dodge Durango Performance Talk 3 02-28-2003 09:26 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome