Transmission Shifts Late at High RPM - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 05-10-2008, 12:02 AM
MagnumVP
Registered User
 
Join Date: Nov 2004
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Transmission Shifts Late at High RPM

1999 Dodge Ram Quad
5.9L V8
Automatic Transmission

When I start from a complete stop the transmission doesn't shift into 2nd until about 3000 RPM's. At that point the trucks shifts and the "Check Engine" light turns on. It still shifts smooth (well at least for this truck). I dropped the pan, replaced the filter and 5 Qts of ATF+4 fluid. Removed the Negative from the battery (resetting the computer) and try it again. Same thing (bummer, I was hoping for a $45 fix) and even drove it around 10 miles to let the fluid heat up but same thing. I also notice that it shifts from 3rd to 4th rather high as well.

What could be the issue? I am going to take it down to get the diagnostic code read to see what could possible be the issue, but wanted to go into the mechanic with an idea of what it could be.

Thanks

Magnum
MagnumVP is offline  
Sponsored Links
Advertisement
 
#2 Old 05-10-2008, 09:30 PM
itate
No Agenda Producer
 
itate's Avatar
 
Join Date: Aug 2007
Location: Dayton
Posts: 71
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's the output sensor, its on the side of the transmission tailshaft. They run about $17 at Advance Auto. I went through this a couple months ago and it was a bear to figure out.

98 Dodge Ram SS/T Black-Silver Stripes - 5.9L, Hughes Plenum Pan & Gasket, Open element air cleaner,
Harland Sharp 1.7 rockers, shorty headers, 3.91 gears, poor man's throttle body mod, and Hellas behind the grill.
98 Dodge Neon Sport DOHC (252,000 miles)
97 BMW Z3 2.8
68 Plymouth Barracuda - May 2009 VOTM
62 Chrysler Newport
"Hella's Behind the Grille" Club Member #36
100,000 Mile+ Club Member #27
Black Truck Club Member #181
SS/T Club Member #3
Manual Club#3
itate is offline  
#3 Old 05-11-2008, 12:14 AM
greenriverboy
Green river boy is here!
 
greenriverboy's Avatar
 
Join Date: Aug 2007
Location: Canmer,Ky
Posts: 118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MIne is doing this but it is the govener sensor or something like that and its a $150 peice.
greenriverboy is offline  
#4 Old 05-11-2008, 01:01 PM
MagnumVP
Registered User
 
Join Date: Nov 2004
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Just some more information about it. Perhaps this will help diagnose what the issue is.

From the truck being turned off. I start the truck and take off. The first time that the transmission attempts to shifts it goes to 3000 RPM's and the shifts. From then on, it shifts normally. Every once in a while it acts up but never as bad as the first time. It never shifts hard, it has no problem down shifting...at least yet and it sometimes takes a while to shift from 3rd to 4th, but never at really high RPM's.

If I disconnect the neg from the battery and reset the computer, the "Check Engine" light turns on when the truck shifts from 1st to 2nd during the initial startup and high RPM's.
MagnumVP is offline  
#5 Old 05-12-2008, 04:34 PM
chizzle1
REDNECK SPACESTATION
 
chizzle1's Avatar
 
Join Date: May 2006
Posts: 5,224
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
just a dumb question, but have you adjusted the TV cable at all?
If the line pressure is set too high (TV cable too tight) then you will get the late shifting & gear hunting you are referring to.


01 Ram 5.9 Sport QC 4x4 - 165k, current build project - SCT Stage1 custom tune via Hemifever, Harland Sharp 1.7:1 roller rockers, Modded Kegger, Edelbrock ProFlow,52mm TB,180* t-stat,e-fans, pacesetter long tube headers, true dual with spun cats and thrush shorties, 34x11 Falken ATs on 3rd gen Dodge 20"s, 3"TC lift, PML Deep Pan,SunPro Tranny Temp gauge,Rebuilt 231D,TSC Diamond Box, Sony head unit, AVS 3 piece bug deflector
10 Dodge Challenger R/T in Brilliant black - MyGig 730N w/ navi,dvd,HD,u-connect & rear cam, 6 spd, Track Pak, SRT8 shorties & mids, DS Predator, Jet 180*, Airaid CAI, BBK 85mm tb, SLP line locks, de-badged, resonators removed, DRL enabled, skip shift eliminator, mopar hood struts, functional hood vents, 392 chin spoiler
09 Suzuki 1255S Bandit Metallic Blue on black, 1255cc I-4, 6 spd, Yoshi can, K&N, Bags Connection tank bag, TPX fuzz buster, Techmount GPS holder, Suzuki center stand, World Performance Seat
2013 Dart Limited Pitch black, fully loaded, hers
SOLD 06 Hemi Durango 4x4 Limited in Atlantic Blue Pearl
SOLD 97 Ram 1500 SLT Laramie in DuPont Frost White Pearl
chizzle1 is offline  
#6 Old 05-12-2008, 10:33 PM
MagnumVP
Registered User
 
Join Date: Nov 2004
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
It was putting out a P0720 code (courtesy of a Free error check from AutoZone. Replaced the Output Speed Sensor and it fixed it. Thanks for everything.

Here is that part that it needed.

http://www.partsamerica.com/productd...e=1179&PTSet=A
MagnumVP is offline  
#7 Old 05-13-2008, 08:34 AM
chizzle1
REDNECK SPACESTATION
 
chizzle1's Avatar
 
Join Date: May 2006
Posts: 5,224
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
glad you got her running right for cheap


01 Ram 5.9 Sport QC 4x4 - 165k, current build project - SCT Stage1 custom tune via Hemifever, Harland Sharp 1.7:1 roller rockers, Modded Kegger, Edelbrock ProFlow,52mm TB,180* t-stat,e-fans, pacesetter long tube headers, true dual with spun cats and thrush shorties, 34x11 Falken ATs on 3rd gen Dodge 20"s, 3"TC lift, PML Deep Pan,SunPro Tranny Temp gauge,Rebuilt 231D,TSC Diamond Box, Sony head unit, AVS 3 piece bug deflector
10 Dodge Challenger R/T in Brilliant black - MyGig 730N w/ navi,dvd,HD,u-connect & rear cam, 6 spd, Track Pak, SRT8 shorties & mids, DS Predator, Jet 180*, Airaid CAI, BBK 85mm tb, SLP line locks, de-badged, resonators removed, DRL enabled, skip shift eliminator, mopar hood struts, functional hood vents, 392 chin spoiler
09 Suzuki 1255S Bandit Metallic Blue on black, 1255cc I-4, 6 spd, Yoshi can, K&N, Bags Connection tank bag, TPX fuzz buster, Techmount GPS holder, Suzuki center stand, World Performance Seat
2013 Dart Limited Pitch black, fully loaded, hers
SOLD 06 Hemi Durango 4x4 Limited in Atlantic Blue Pearl
SOLD 97 Ram 1500 SLT Laramie in DuPont Frost White Pearl
chizzle1 is offline  
#8 Old 09-25-2008, 05:39 PM
Rico6161
Registered User
 
Join Date: Sep 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey guys, I got a 95 with the same problem..

My 95 has the same issues with shifting.. Tranys was rebuilt about two yrs ago, but only put 2000 miles on her sense.. I looked for this speed sensor and mine doesn't look like this at all.. Mine has a 3 wire sensor that looks like it's part of the old cable speedo.. Has 1 bolt that holds it in.. Would my sensor do the samething / Shifting late? Whats the TV cable I read on here? Someone said it might need adjusted?

Thanks for any help..
Rico6161 is offline  
#9 Old 09-25-2008, 10:09 PM
chizzle1
REDNECK SPACESTATION
 
chizzle1's Avatar
 
Join Date: May 2006
Posts: 5,224
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by Rico6161 View Post
My 95 has the same issues with shifting.. Tranys was rebuilt about two yrs ago, but only put 2000 miles on her sense.. I looked for this speed sensor and mine doesn't look like this at all.. Mine has a 3 wire sensor that looks like it's part of the old cable speedo.. Has 1 bolt that holds it in.. Would my sensor do the samething / Shifting late? Whats the TV cable I read on here? Someone said it might need adjusted?

Thanks for any help..
the TV (throttle valve I think) basically controls line pressure. More throttle = more line pressure for firmer shifts. It has a certain amount of control over kick down points as well.
It connects to your throttle cable assy at the throttle body, and can be adjusted near the firewall via a bracket assembly.
You should only adjust this a SMALL amount and I would advise you to mark the TV cable in such a way as to be able to set it back to were it was if you fook it up.
I adjusted mine shorter a while back (about 5 years) to increase line pressure in an endeavor to extend the service life of the tranny. It shifts a little too firm but I don't mind as I haven't needed a rebuild yet.
IMO the #1 way to make sure your 46RE tranny lasts is to keep it cool (180*) - deep pan, tranny cooler w/ dedicated fan, and temp gage.

edit: also check that the return spring for the TV cable is present at the tranny end of the cable.


01 Ram 5.9 Sport QC 4x4 - 165k, current build project - SCT Stage1 custom tune via Hemifever, Harland Sharp 1.7:1 roller rockers, Modded Kegger, Edelbrock ProFlow,52mm TB,180* t-stat,e-fans, pacesetter long tube headers, true dual with spun cats and thrush shorties, 34x11 Falken ATs on 3rd gen Dodge 20"s, 3"TC lift, PML Deep Pan,SunPro Tranny Temp gauge,Rebuilt 231D,TSC Diamond Box, Sony head unit, AVS 3 piece bug deflector
10 Dodge Challenger R/T in Brilliant black - MyGig 730N w/ navi,dvd,HD,u-connect & rear cam, 6 spd, Track Pak, SRT8 shorties & mids, DS Predator, Jet 180*, Airaid CAI, BBK 85mm tb, SLP line locks, de-badged, resonators removed, DRL enabled, skip shift eliminator, mopar hood struts, functional hood vents, 392 chin spoiler
09 Suzuki 1255S Bandit Metallic Blue on black, 1255cc I-4, 6 spd, Yoshi can, K&N, Bags Connection tank bag, TPX fuzz buster, Techmount GPS holder, Suzuki center stand, World Performance Seat
2013 Dart Limited Pitch black, fully loaded, hers
SOLD 06 Hemi Durango 4x4 Limited in Atlantic Blue Pearl
SOLD 97 Ram 1500 SLT Laramie in DuPont Frost White Pearl
chizzle1 is offline  
#10 Old 09-26-2008, 11:08 AM
89smurf
Urban Wheeler
 
89smurf's Avatar
 
Join Date: Jan 2006
Posts: 415
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by chizzle1 View Post
the #1 way to make sure your 46RE tranny lasts is to keep it cool (180*)
Troof!

Chrome don't get ya home, but it'll sure get ya laid.

98 Ram 1500 QC SB, 318, SCT Tuner, CAI, high flow cat, headers, Electric fan, 8.5mm wires, 220L Aux. fuel transfer tank, 1500W Circulating block heater, DIY dual batteries with self boost ability.
89smurf is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plenum gasket procedure gunmetalgolfer 2G Dodge RAM - Drivetrain Talk 37 01-25-2008 03:25 AM
Generic Chrysler Diagnostic Trouble Code List tactransman 1G Dodge Durango General Talk 0 10-18-2007 02:27 PM
Generic Chrysler Diagnostic Trouble Code List tactransman 2G Dodge Durango General Talk 0 10-18-2007 02:27 PM
Trans shifts at 3,900 RPM @ WOT. 98QuadCabV10 2G Dodge RAM - Drivetrain Talk 7 08-04-2005 09:11 PM
Key Sequence for Codes on 04s scapegoat047 3G Dodge RAM - General Talk 10 03-05-2005 09:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome