Random Rough Idle - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 3rd Gen (02 08) Forums > 3G Dodge RAM - Drivetrain Talk

Closed Thread
 
Thread Tools

Laetus_Lupus
 
  Random Rough Idle - Posted: 11-17-2007, 09:05 PM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #1

2004 ram 3.7 5sp 75k miles

I've read a lot of similar threads but nothing really hit my problem dead on

I've had the truck for about 6 months, about 2 months ago I came to a stop and the engine idle dropped to around 400 and was shaking hard, (normal cold idle is 1000 warm is approx 700) then it cleared up in a few seconds with out me doing anything before taking off, then a few weeks after that it did it again, if I gave it gas it would rev up fine but drop to 400 again with rough idle and then cleared up on takeoff. the last 2 times it did this, again weeks apart, it seemed worse, I thought it might die but never did, as I took off it run rough and barely accel. and the engine light was blinking but as soon as i got over 2500rpm it cleared up and took off like a bat out of hell.

The hesatation reminds me of a 86 ranger i had that got moisture in the fuel a lot but it had problems all the time, not intermittently. I have a short drive to work so it never acts up cold, only after it warms up.

This may not be connected, but when I got the truck, I noticed it started knocking a bit under 2000 rpms with moderate to heavy accel. engine code said misfire cyl 1, so I changed the plugs, probably the first tune up it had,fixed that problem. I'm the second owner, amazing the truck didn't act up until after I bought it.
I wonder why all the problems clear up at high rpms? I would think it would stutter all the way through the rpms if it had a real problem.

The truck has always had a slight rough Idle just enough to let you know its running, most vehicles do, the idle I'm talking about feels like its going to shake itself apart or something. The only thing I could compare it to is that ranger. One cold morning I started it, it didn't want to run, gave it gas to keep running but i swear it felt like it was running on 2 cylenders. or compare the shaking to an earthquake

back to the dodge
just did the key trick, no codes.

What could be causing this problem?
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

Laetus_Lupus
 
 Posted: 11-25-2007, 01:41 AM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #2

I may have solved this. I filled up and add two bottles of stp fuel treatment due to the 30+ gallon tank I got. I guess it worked. that stuff cleans injectors, removes moisture etc. well, until next time.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Laetus_Lupus
 
 Posted: 12-11-2007, 06:53 PM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #3

Nope, did it again today, worse as ever. In about a 10 minute time span, I'm driving along and then it starts to bog down and run rough, engine light flashing. when I came to a stoplight it idles real low shaking truck but didn't die. then I take off and it runs real rough and then straightens up a few seconds and starts running rough again. about 2 minutes from my house it straightens up again all the way home it's fine like nothing ever happened. did the key trick, no codes. Confusing as hell. Could it be moisture in the fuel? I'd change the fuel filter if it wasn't in the tank. If I had a bad sensor somewhere wouldn't I get a code? Any one have this problem?
__________________
2004 Dodge Ram 1500 Quadcab
3.7L V6 5 speed manual,
2wd, 3.92 gears, 17 in. wheels
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

BlackSmoke1989
 
 Posted: 12-11-2007, 07:01 PM
BlackSmoke1989's Avatar
The Silver Bullet
Joined: Nov 2007
Posts: 591
City: Louise
State: TX
Status: Offline
View This User's Gallery
Post #4

go to oriellys and find out what is causing the code to pop up
__________________

Member "The Red Truck Club" #245



2012 Dodge Ram 1500 Hemi 4X4
K&N Air Filter.
More mods to come soon!
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

piper18
 
 Posted: 12-11-2007, 10:09 PM
piper18's Avatar
Great View
Joined: Oct 2007
Posts: 1,048
City: Fond du Lac
State: WI
Status: Offline
Post #5

Sound like the throttle body needs to be cleaned or EGR valve.
__________________
2008 Dodge Ram 1500 4x4 SLT, 5.7 Hemi MDS, Regular Cab, Long Box, 3.55 LS rear end ,17" cast wheels, Flame Red

Member of the Red Truck Club #231


Switch installed in chime circuit to turn off chime Click to learn How To add a switch to the chime circuit
Installed MDS indicator light on dash ---Click to learn How To install a MDS light
Tools Box w/ lights inside tided to cargo light
Custom made deer guard 2" pipe
Sportsmaster Tonneau cover w/top gun fabric
Mopar rear wheel liners
Iron Cross stainless 3" step bars
Tailgate open indicator light
9005 fog light bulbs
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

MikeHTally
 
 Posted: 12-12-2007, 06:07 AM
MikeHTally's Avatar
Got 2 Hemis
Joined: Aug 2007
Posts: 4,702
City: Tallahassee, FL
Status: Online
View This User's Gallery
Post #6

Quote:
Originally Posted by piper18
Sound like the throttle body needs to be cleaned or EGR valve.
TB was my first guess. Maybe it wants plugs? Is the air filter clean?
__________________

'03 1500 QCSB Hemi
Vent shades/15% tint
A.R.E. Tonneau/Bed Rug
Nerf step bars
Rear LED light bar/LED frt. turn signals
LED tails & 3d brake light/White Night backup lamps & LED interior lights
Halos/projector headlights KC HiLites Titanium Driving lights
Tailgate Easy Lift & EZ Down
E&G Classics mesh grill
WeatherTech Floor Liners
Overhead console with HomeLink
JVC KD-AR780 Receiver & CH-X1500 Changer
Jensen 6x9 3-way up frt., 5 1/4" 2-way rear
GenTex auto-dimming mirror & Towing mirrors
Fender liners & Ram splash guards
Silver Truck Club Member #140
S.N.A.T.C.H. Club Member 666-666
2 1/2" level kit
Jetstream Scoop/Power Wire
MagnaFlow Stainless Cat-back SI/DO
TrueFlow intake kit
Hellwig 7651 sway bar
Flex-a-lite Black Magic Extr. 180 Elect. Fan
Dick Cepek Chrome DC-1s/Bridgestone Revo2 285/70

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Laetus_Lupus
 
 Posted: 12-12-2007, 06:57 PM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #7

OK, this morning, I started it up and the engine light stayed on. the whole trip to work was pretty good it only had slight hesitation a few times but barely noticable. When I got to work I did the key thing, it said P 0300, I looked up my haynes manual. It said misfire multiple cylinders.I put a bottle of gas line anti-freeze/water remover in to eliminate that variable(I hadn't added any this tank). I drove it a couple miles to get lunch. it seemed fine for the most part, just a little hesitation around 1400 rpm's. I stopped at the store on my way home afterwork. It drove fine except the engine light was on(I'm not extremely concerned because i know why) first and second gear are fine, third at about 1400 rpm's it hesitates and then fine in fourth cruising at 1500. I noticed if I baby it in third it won't hesitate but if I give it about half throttle it does. I wonder why?

I can't believe its the sparkplugs, they only have 2k miles on them. Its cold this time of year so I'm afraid it will have to wait til spring to clean a throttle body or egr valve unless I can do it in 15 minutes. How much would a shop charge?
__________________
2004 Dodge Ram 1500 Quadcab
3.7L V6 5 speed manual,
2wd, 3.92 gears, 17 in. wheels

Last edited by Laetus_Lupus : 12-12-2007 at 07:05 PM.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

BlackSmoke1989
 
 Posted: 12-12-2007, 10:46 PM
BlackSmoke1989's Avatar
The Silver Bullet
Joined: Nov 2007
Posts: 591
City: Louise
State: TX
Status: Offline
View This User's Gallery
Post #8

It's not really hard to clean those things, considering a shop around here charges 50 dollars an hour, i would rather do it myself for 10
__________________

Member "The Red Truck Club" #245



2012 Dodge Ram 1500 Hemi 4X4
K&N Air Filter.
More mods to come soon!
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Laetus_Lupus
 
 Posted: 12-13-2007, 06:39 PM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #9

Today I left early this morning. It was dark, rainning and cold. If a vehicle is going to act up, this is usually it. But it didn't. Drove all the way to walmart with the engine light on but it drove perfectly fine. when I left walmart the engine light when off. seem fine now. I guess the ISO-HEAT water remover/antifreeze worked. which leaves the question:

Why do I have moisture in my fuel?

if that is the correct conclusion.
__________________
2004 Dodge Ram 1500 Quadcab
3.7L V6 5 speed manual,
2wd, 3.92 gears, 17 in. wheels
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Laetus_Lupus
 
 Posted: 12-13-2007, 06:48 PM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #10

I'm planning on continuing this thread here:

http://www.dodgetalk.com/forums/showthread.php?t=184616
__________________
2004 Dodge Ram 1500 Quadcab
3.7L V6 5 speed manual,
2wd, 3.92 gears, 17 in. wheels
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

siiturbo
 
 Posted: 12-15-2007, 01:10 AM
Registered User
Joined: Jul 2007
Posts: 542
City: Grapevine/Dallas
State: TX
Status: Offline
View This User's Gallery View This User's Garage
Post #11

So did you say you did a tune-up on it with new spark plugs and everything?
__________________
Dodge Ram 1500 QC 4.7L SWB AT
20x10" MB Gunner 5 wheels
305/55-R20 (33.21") Nitto Terra Grappler AT tires
Focal Component Speakers (Front)
Infinity Kappa (Rear)
Rockford Fosgate HX2 10" Sub (FOX Box)
Boss GT1500D Amp
Side-Steps (need modified)
OEM Fog lights
NGK 6987 Sparkplugs
Performance Accessories 3" Body Lift
Flowmaster 50 Series Exhaust 3"in, Dual 2.25"out
20% Tint so you can't see up in my window lol
Motive 4.56gears
Auburn LSD
Superchips

Future aspirations:
Rebuild motor nice and beefy
Add Supercharger or Turbo
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Laetus_Lupus
 
 Posted: 12-15-2007, 03:49 PM
Laetus_Lupus's Avatar
Registered User
Joined: Oct 2007
Posts: 83
Status: Offline
Post #12

I changed the sparkplugs, air filter, and pcv valve. What else is there to a tune up on these modern trucks?
__________________
2004 Dodge Ram 1500 Quadcab
3.7L V6 5 speed manual,
2wd, 3.92 gears, 17 in. wheels
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

piper18
 
 Posted: 12-16-2007, 12:18 AM
piper18's Avatar
Great View
Joined: Oct 2007
Posts: 1,048
City: Fond du Lac
State: WI
Status: Offline
Post #13

check oil levels in the rear end and tranny.
__________________
2008 Dodge Ram 1500 4x4 SLT, 5.7 Hemi MDS, Regular Cab, Long Box, 3.55 LS rear end ,17" cast wheels, Flame Red

Member of the Red Truck Club #231


Switch installed in chime circuit to turn off chime Click to learn How To add a switch to the chime circuit
Installed MDS indicator light on dash ---Click to learn How To install a MDS light
Tools Box w/ lights inside tided to cargo light
Custom made deer guard 2" pipe
Sportsmaster Tonneau cover w/top gun fabric
Mopar rear wheel liners
Iron Cross stainless 3" step bars
Tailgate open indicator light
9005 fog light bulbs
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle Help Please mwcop1 2G Dodge RAM - General Talk 5 04-18-2007 07:32 AM
'89 Ram Rough Idle Question Ram_Angel Dodge Ram Truck 1st Gen (88 - 93) Forum 4 02-05-2007 08:23 AM
Help Needed: Durango Hesitation rough idle and loud air sucking sound random spudsdude 1G Dodge Durango General Talk 1 03-23-2006 08:45 PM
02 rough idle Help obbie02 2G Dodge Dakota General Talk 1 10-06-2005 03:02 PM
rough idle, random acceleration, stalling majorprofit 1G Dodge Durango General Talk 10 02-20-2005 10:44 PM



All times are GMT -5. The time now is 01:32 PM.





Privacy Statement