Red Flashing Security Light On, Help Me Please - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP DODGETALK MERCHANDISE ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 3rd Gen (02 – 08) Forums > 3G Dodge RAM - General Talk

Closed Thread
 
Thread Tools

Taz8172
 
  Red Flashing Security Light On, Help Me Please - Posted: 04-02-2007, 06:53 PM
Taz8172's Avatar
Registered User
Joined: Nov 2006
Posts: 134
State: KS
Status: Offline
Post #1

I went out to pull my truck in the garage about an hour ago and now it will not start. It started to but then it died immediately. Now I have the red flashing security light going and it will not do anything. I can not even use my keyless to lock or unlock the doors. The button to lock or unlock the doors will not even work on the door panel. The radio will not work in accessory, I mean nothing will work.

I do not have the chipped key. I have never had it do this in the 6 months that I have owed it. I used my keyless to open the door as I was getting into it. My wife tried her key and nothing. I went back out and tried my key again and the odometer would flash also opposite of the red light.

I have pulled the battery cable hoping it will reset it but I have a feeling it won't.

Any ideas what to do?

Thanks
__________________
2003 1500 4x4 Hemi
SLT Quad Cab
Exterior Color: Graphite Metallic Clear Coat
Interior Color: Dark Slate Gray Cloth
5 Speed Auto 45RFE Transmission
Electronic Shift On The Fly Transfer Case
Axle Ratio: 3.55
Wheels: 17x8.0 Painted Cast Alum
LT285/70/17 Michelin LTX M/S2
Black Diamond Plate Toolbox
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

sherdep
 
 Posted: 04-02-2007, 07:47 PM
sherdep's Avatar
voo doo 1 I am buggin out
Joined: Nov 2004
Posts: 6,354
City: Saint Cloud Florida
State: FL
Status: Offline
View This User's Gallery View This User's Garage
View This User's Timeslip
Post #2

from what you are explaining it sounds like the security feature has been enabled,
Maybe check your fuses would be where I would start. If you do not have a manual go downlod it off of hemitruckclub.com for your 03.
If you want me to pm you my number to help I will be more then willing to try and help you over the phone as well
__________________
04 Dodge Ram 1500 4x4
6" Fabtech Lift
305/70/18 Dick Cepek FC-II Tires on DC-1 Rims
Fram Boost CAI
Hellwig Rear sway Bar
Train Horns with a Viar420C and a 5 Gallon Air Tank
Dynatech Long Tube Headers - Great fit but Dynatech's support is lacking
DynoMax Part # 19413 Single Cat Back Exhaust
If you need to contact me - please send me an email due to not being on here as much as I used to.

Some get it and some will never get it

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

ramtastic
 
 Posted: 04-03-2007, 03:30 AM
ramtastic's Avatar
Registered User
Joined: Aug 2006
Posts: 19
State: AR
Status: Offline
View This User's Gallery
Post #3

sounds like a dead battery. I had the same symptoms when my battery went out on me.
__________________
2003 QC 4x4
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Taz8172
 
 Posted: 04-03-2007, 12:09 PM
Taz8172's Avatar
Registered User
Joined: Nov 2006
Posts: 134
State: KS
Status: Offline
Post #4

Well, I have replaced the battery and the other battery was bad. And now I have the red brake light and the yellow anti lock light are on. I have not driven it yet. I called the local Dodge dealership and they are stumped as to why. They told me to check some fuses and I unhooked the new battery again to see if it resets.

They also said try and drive it and see how if works. They wonder if it will reset itself but they do not think so. If none of that works they said to call if I want them to read the code on it.

Thanks for all the help and suggestions.
__________________
2003 1500 4x4 Hemi
SLT Quad Cab
Exterior Color: Graphite Metallic Clear Coat
Interior Color: Dark Slate Gray Cloth
5 Speed Auto 45RFE Transmission
Electronic Shift On The Fly Transfer Case
Axle Ratio: 3.55
Wheels: 17x8.0 Painted Cast Alum
LT285/70/17 Michelin LTX M/S2
Black Diamond Plate Toolbox
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

mrmagoo_83
 
 Posted: 04-03-2007, 12:16 PM
Registered User
Joined: Feb 2002
Posts: 404
State: TX
Status: Offline
Post #5

Do me a favor, drive it for a short bit, to the end of the block works, and see if your Speedo works.

If not it could be another Speed Sensor go bad, on top of your other issue. Someone else on here is having a Speed Sensor issue as well.
__________________
Just gotta make it faster and louder!!

Member #3 - "Hemi Sport Edition"
Member #144 - "The Red Truck Club"

2006 Quad Cab Sport Hemi --{ FLAME RED **--

Mods...
Mopar Side Steps (dealer installed)
Mopar Bedliner (Swapping out for spray in)
Rear Wheel Well Liners (82207367)
Front (82210680) & Rear (82210681) Splash Guards
Ash Tray Lamp (4608669-AA)
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

sherdep
 
 Posted: 04-03-2007, 04:10 PM
sherdep's Avatar
voo doo 1 I am buggin out
Joined: Nov 2004
Posts: 6,354
City: Saint Cloud Florida
State: FL
Status: Offline
View This User's Gallery View This User's Garage
View This User's Timeslip
Post #6

Quote:
Originally Posted by ramtastic
sounds like a dead battery. I had the same symptoms when my battery went out on me.
Was thinking the same thing after I posted my first set of comments and then my internet connection went down so could repost what you said ...... ZAZ had this same issue last week and told him to check the battery and it was battery.
__________________
04 Dodge Ram 1500 4x4
6" Fabtech Lift
305/70/18 Dick Cepek FC-II Tires on DC-1 Rims
Fram Boost CAI
Hellwig Rear sway Bar
Train Horns with a Viar420C and a 5 Gallon Air Tank
Dynatech Long Tube Headers - Great fit but Dynatech's support is lacking
DynoMax Part # 19413 Single Cat Back Exhaust
If you need to contact me - please send me an email due to not being on here as much as I used to.

Some get it and some will never get it

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

kenihemi
 
 Posted: 04-03-2007, 06:52 PM
kenihemi's Avatar
Senior Member
Joined: Mar 2004
Posts: 2,608
City: The Soprano State
State: NJ
Status: Offline
Post #7

Disconnecting the battery WILL NOT fully reset the PCM.

You have to do it the right way.

I wish all these guys that post that disconnecting the battery will do it, IT WON'T.

Leave the batt connected.
Remove the PCM/SKIM fuse. Its different for different years.
Buckle driver seat belt. (to stop other chimes)
Put in key and turn it to START (it won't) and hold it until you hear 2 chimes.
Replace fuse.
Done.


The first time you start it you may experience a delay, that's normal.

And you may find that the idle goes up/down a little, that's normal.

The PCM will learn and all will be fine.

If you still have a problem that the PCM doesn't like, it'll set another code.

The only time I ever saw that light was when my battery was pooping the bed.
__________________
'04 Hemi Ram 1500 QC, 4X4, 4.56 gears, STS turbo = 450+RWHP, SCT Tuner, B&M MegaShifter.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

eatsleepdrivesc
 
 Posted: 04-03-2007, 08:07 PM
eatsleepdrivesc's Avatar
Coolest Ram Club in FL
Joined: May 2006
Posts: 4,294
State: FL
Status: Offline
View This User's Gallery View This User's Garage
View This User's Timeslip
Post #8

battery
__________________

Charles
---------
2002 Ram 1500 Quad Cab Long Bed
4.7L

Performance mods: Superchips 3815 Elec Cutout, K&N Drop in Filter, 545RFE TCM Swap, JBA Headers



Exterior/Interior mods: Debadged, Clarion DXZ785USB, Samsung Helix (XM Radio), Infinity Reference Series Front and Back Speakers, Fox-Ported Dual 10" Sub Box with 2-10" JL 10w3's, JL Slash V2 500/1 and JL Slash V2 300/4 amps, Factory Keyless Entry Added, HID Headlights and Fogs, Extang Trifecta Tonno Cover



DodgeTalk Central Florida Chapter Member #4


*287 Enthusiast Member #84*


*Silver Truck Club Memeber #68*


*Long Bed Club Member #1*


"Don't Fear The Drone" #2


Nekid Truck Club Member #4


LiL Ram Ridin Shotgun club Member #2



Best Time and speed: 17.035@81.05, Orlando Speed World 12/17/08

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Taz8172
 
 Posted: 04-03-2007, 09:37 PM
Taz8172's Avatar
Registered User
Joined: Nov 2006
Posts: 134
State: KS
Status: Offline
Post #9

Thanks everyone. It ended up being the battery. The brake lights went off after I took the truck for a drive. I got about a block away from the house and they went off. So far so good.

I did not know what happened when it dies like it did yesterday and the red light starting flashing. I have never had that happen before.

I think my wife jixned me yesterday. She asked me how the truck was doing and if I still liked it or missed my GMC I traded off for the Dodge. I'll keep the Dodge. I like it.

Again thanks for all the help.
__________________
2003 1500 4x4 Hemi
SLT Quad Cab
Exterior Color: Graphite Metallic Clear Coat
Interior Color: Dark Slate Gray Cloth
5 Speed Auto 45RFE Transmission
Electronic Shift On The Fly Transfer Case
Axle Ratio: 3.55
Wheels: 17x8.0 Painted Cast Alum
LT285/70/17 Michelin LTX M/S2
Black Diamond Plate Toolbox
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Omars121
 
 Posted: 06-03-2007, 10:32 PM
Registered User
Joined: Oct 2006
Posts: 2
Status: Offline
Post #10

by resetting the PCM ... what does that do exactly? i think im having the same problem
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

Taz8172
 
 Posted: 06-11-2007, 09:34 PM
Taz8172's Avatar
Registered User
Joined: Nov 2006
Posts: 134
State: KS
Status: Offline
Post #11

Omars121, sorry I have not got back to you sooner. I was gone for a week and trying to get caught up with work and all. Is it the brake light or the red flashing light that you are having the problem with? For me it ended up being the battery shorting out and going dead suddenly. After getting a new battery it stopped the red flashing light. Then driving the truck for about a block reset the brake light.

Good luck and if I can help with anything else let me know.
__________________
2003 1500 4x4 Hemi
SLT Quad Cab
Exterior Color: Graphite Metallic Clear Coat
Interior Color: Dark Slate Gray Cloth
5 Speed Auto 45RFE Transmission
Electronic Shift On The Fly Transfer Case
Axle Ratio: 3.55
Wheels: 17x8.0 Painted Cast Alum
LT285/70/17 Michelin LTX M/S2
Black Diamond Plate Toolbox
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP - Towing light pkg. check engine light grammar police 3G Dodge Dakota General Talk 1 11-09-2006 11:17 AM
94 Dodge Shadow. No radio or dome light... pyr02k1 Vintage Dodge Car Forum 11 02-12-2006 02:01 AM
Engine light flashing Drifter1 3G Dodge RAM - General Talk 3 02-11-2006 01:33 AM
ABS (amber) and red break light on Wallace Scheurm 2G Dodge RAM - General Talk 0 01-23-2005 06:10 PM
Hemi stalled at red light John73292003 3G Dodge RAM - General Talk 6 11-21-2003 10:25 AM



All times are GMT -5. The time now is 01:20 PM.





Privacy Statement