Error Code P1195 - mass air flow sensor? - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 
Thread Tools
#1 Old 05-22-2006, 11:46 AM
chrisk
Registered User
 
Join Date: May 2006
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Error Code P1195 - mass air flow sensor?

My check engine light recently came on and was giving the error code P1195, which I believe to be a problem with the mass air flow sensor. I've heard stories of these going bad on other cars and people fixing it themselves. This, and seeing pictures of the actual part lead me to believe it isn't that hard to replace. Has anyone ever replaced one and can provide any tips?
chrisk is offline  
Sponsored Links
Advertisement
 
#2 Old 05-22-2006, 02:10 PM
edglock21
The Green Machine
 
edglock21's Avatar
 
Join Date: Mar 2005
Location: Raleigh
Posts: 1,722
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Our trucks don't use Mass Air - they're Speed-Density. I'll see if I can find some more info on that code for you

ED
98 RAM 1500 SLT QuadCab 4x4 360/AT
86 Shelby GLHS

** How to: Changing Ball Joints on 2nd Gen Ram

Quote:
Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children's children what it was once like in the United States where men were free. - President Ronald Reagan
I'll rochambeau ya for it..." Eric Cartman
edglock21 is offline  
#3 Old 05-22-2006, 02:37 PM
Silver_DodgeRam
Mmmmmmmmm, beer.
 
Silver_DodgeRam's Avatar
 
Join Date: Dec 2004
Location: Colorado Springs
Posts: 2,463
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That code is an o2 sensor code:

P1195 - 1/1 O2S Slow During Catalyst Monitor

2009 Dodge Ram 1500 4x4, 5.7 Hemi, Crew - work in progress
2008 Chrysler Aspen 4x4, 5.7 Hemi, Loaded
Silver_DodgeRam is offline  
#4 Old 05-22-2006, 03:10 PM
edglock21
The Green Machine
 
edglock21's Avatar
 
Join Date: Mar 2005
Location: Raleigh
Posts: 1,722
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Silver beat me too it


- looks like you need an oxygen sensor

ED
98 RAM 1500 SLT QuadCab 4x4 360/AT
86 Shelby GLHS

** How to: Changing Ball Joints on 2nd Gen Ram

Quote:
Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children's children what it was once like in the United States where men were free. - President Ronald Reagan
I'll rochambeau ya for it..." Eric Cartman
edglock21 is offline  
#5 Old 05-22-2006, 08:11 PM
chrisk
Registered User
 
Join Date: May 2006
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool, thanks to you both. I'm looking on AutoZone's website and they have two sensor, one for before the cat and one for after. Any ideas which one it would be?

Edit: Well it looks like both links take me to the same part. I just need to see which one of them is bad...
chrisk is offline  
#6 Old 05-23-2006, 12:32 AM
knowplay
Team ASE
 
knowplay's Avatar
 
Join Date: Apr 2006
Posts: 302
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
1/1 means Bank 1 Sensor 1. This would be the one closest to the engine on the driver's side.

Here's some info:

SYMPTOM
P-1195 SLOW 1/1 O2S DURING CATALYST MONITOR

WHEN MONITORED
With the engine running, coolant > 170 degrees F , open throttle, steady to slightly increasing vehicle speed > 18MPH < 55MPH , with a light load on the engine for a period no less than five minutes .

SET CONDITION
The oxygen sensor signal voltage is switching form below 0.39 volt to above 0.6 volt and back fewer times than required.

POSSIBLE CAUSES

* 1/1 Oxygen sensor ground circuit open
* Engine fluid consumption
* 1/1 Oxygen sensor connector observable defect
* 1/1 Oxygen sensor defective
* Exhaust system leaking
* PCM connector observable defect

Might not be the O2 sensor, though with a "slow" code it usually is. Hope this helps.

'97 Extended Cab 5.2L 5spd Black Ram
Quite a few mods. Pretty fast and loud only when I want it to be. Needs painting.
knowplay is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 Caravan wont stay running JMDTOYS Dodge Caravan General Talk 3 05-05-2006 11:57 AM
mass air flow sensor? kalen427 2G Dodge Ram Performance Talk 22 12-10-2005 04:47 PM
mass air flow sensor in '02 T+C 3.8L? B1G BLEU Dodge Caravan General Talk 0 12-10-2005 02:08 PM
360Airintakez Opinions needed... fischputza 3G Dodge Ram Performance Talk 8 09-02-2005 09:35 PM
Engine Light on at 21,100 miles ColoradoQuadCab 2G Dodge Dakota Performance Talk 6 11-17-2003 03:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome