Vent Selector does not work - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Notices

Closed Thread
 
Thread Tools
post #1 of 9 Old 10-29-2009, 07:18 PM Thread Starter
qtipextra
^BIG D^
 
qtipextra's Avatar
 
Join Date: Oct 2005
Location: Idaho Falls
Posts: 2,283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Vent Selector does not work

My vent selector switch doesn't work. It blows to the defrost only. I can move the selector switch to any position and nothing happens. The fan switch works well, I just cant get it off the defrost top vents.

I am thinking it's the switch itself, but wanted to check to see if anyone else has any ideas before I dive in. I did check to make sure the wiring harness was tightly attached, but haven't had time for much more diagnosis on that yet. Any ideas or suggestions?

"Big D" - SOM Feb '10
Black 2003 Dodge Durango Sport 4.7L 4X4 4.56:1 Auburn LSD

Interior: Double DIN Pioneer HU - 141.7 dB Sound System - Dash Mat - Blue L.E.D Interior Lighting - Blue Gauge Backlighting - Audiovox 2-Way Remote Start - 6 Gauge Cluster Swap
Exterior: Black 1 Piece DEPO headlights - 55W DDM 5000K HID 9007 BiXenon - Hella Optilux 2500 Driving lights - 55W DDM 5000K HID H3 - 3rd Brake light decal "BIG D" - Dodge Hitch/Cover - Dodge Logo on Tinted Tails - Stainless Steel Bar Grill Inserts - Gibson 4" Exhaust Tip
Performance: Dynomax Bullet Muffler - Flowmonster High Flow Catalytic Converter - Chrome Intakes CAI - Superchips 3715 at 91 Octane - NGK V-Power Plugs
Tires/Wheels/Lift: 3" PA Body Lift - 2" T/S Lift - 33 X 11.5 X 16 Firestone Destination M/T Tires - MB Gunner 6 Gun metal gray 16X8 rims
Drivetrain: Rebuilt 545RFE Trans with Transgo Shift Kit - 4.56:1 R/P Motive gears - Auburn High Performance LSD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

qtipextra is offline  
Quick Reply
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-03-2009, 09:29 PM
Wetherdad
Wetherdad
 
Wetherdad's Avatar
 
Join Date: Jul 2009
Location: Templeton
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
the door is sticking, I have the same problem on my '02....under the dash on the drivers side is a part that almost looks like a cam.....when your door gets stuck the door defaults to the defrost setting......you can reach up under the dash....(to the right of the steering wheel and you can find the "cam" i am talking about and you can "help" it move the door to the other settings.....from what i can tell it would be a bear to change it out......i have gotten mine to work again with a substantial amount of lubrication....good luck!
Wetherdad is offline  
post #3 of 9 Old 11-03-2009, 10:36 PM
gramol
Registered User
 
Join Date: May 2004
Location: Thunder Bay, Ontario
Posts: 827
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ignore him...........full of crap tp be polite........its vacuum operated...default position is defrost when no vacuum is present
...look for a broken line either on the intake or just as it passes throught the firewall...........no information is better than none at all

2000 dodge durango,5.9 L,4wd,cold air intake,clear corners,mechanic from canada(spend my days diagnosing and finding broken wires/bad modules),onboard laptop loaded with mitchell, alldata,autoenginuity among others
gramol is offline  
 
post #4 of 9 Old 11-03-2009, 11:11 PM
MagnumD
Silver Member
 
Join Date: Jul 2006
Posts: 270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yes, it is vacuum operated and the line may have broken or came loose.
MagnumD is offline  
post #5 of 9 Old 11-04-2009, 03:14 PM
Wetherdad
Wetherdad
 
Wetherdad's Avatar
 
Join Date: Jul 2009
Location: Templeton
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Actually, It Is Driven By A Servo Motor....if You 2 Were Smart Enough To Look At His Signature, He Has A 2003.....which Is Not Operated By Vaccuum......i Have The Same Problem On My 2002.......ask Some Of The Members Here Who Really Know The 1st Gen Durangos......your Vent Door Is Operated By A Servo Motor That Turns A Can Which Operates The Vent Door. You Can Waste Your Time Looking For A Vacuum Line That Isnt There Or You Can Look Under The Dash On The Drivers Side Just The The Right Of Steering Wheel And See What I Am Trying To Describe!!!!!!

Last edited by Wetherdad; 11-04-2009 at 03:15 PM. Reason: spelling
Wetherdad is offline  
post #6 of 9 Old 11-04-2009, 03:24 PM
Wetherdad
Wetherdad
 
Wetherdad's Avatar
 
Join Date: Jul 2009
Location: Templeton
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
and here is proof that i am right......read all the postings from when i first was looking for help with this problem......the cam i am referring to is actually part of an actuator......from 2001 on......the Durangos use electric actuators and not vacuum

http://www.dodgetalk.com/forums/showthread.php?t=265080

Last edited by Wetherdad; 11-04-2009 at 03:24 PM. Reason: forgot link to previous thread
Wetherdad is offline  
post #7 of 9 Old 11-04-2009, 07:05 PM
MagnumD
Silver Member
 
Join Date: Jul 2006
Posts: 270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Wetherdad View Post
Actually, It Is Driven By A Servo Motor....if You 2 Were Smart Enough To Look At His Signature, He Has A 2003.....which Is Not Operated By Vaccuum......i Have The Same Problem On My 2002.......ask Some Of The Members Here Who Really Know The 1st Gen Durangos......your Vent Door Is Operated By A Servo Motor That Turns A Can Which Operates The Vent Door. You Can Waste Your Time Looking For A Vacuum Line That Isnt There Or You Can Look Under The Dash On The Drivers Side Just The The Right Of Steering Wheel And See What I Am Trying To Describe!!!!!!
Okay, you are right I didn't notice that he has a 2003, so I stand corrected. However, your comment "if You 2 Were Smart Enough" was very immature.
MagnumD is offline  
post #8 of 9 Old 11-04-2009, 08:17 PM Thread Starter
qtipextra
^BIG D^
 
qtipextra's Avatar
 
Join Date: Oct 2005
Location: Idaho Falls
Posts: 2,283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Thanks for the insight guys, I will look into it.

"Big D" - SOM Feb '10
Black 2003 Dodge Durango Sport 4.7L 4X4 4.56:1 Auburn LSD

Interior: Double DIN Pioneer HU - 141.7 dB Sound System - Dash Mat - Blue L.E.D Interior Lighting - Blue Gauge Backlighting - Audiovox 2-Way Remote Start - 6 Gauge Cluster Swap
Exterior: Black 1 Piece DEPO headlights - 55W DDM 5000K HID 9007 BiXenon - Hella Optilux 2500 Driving lights - 55W DDM 5000K HID H3 - 3rd Brake light decal "BIG D" - Dodge Hitch/Cover - Dodge Logo on Tinted Tails - Stainless Steel Bar Grill Inserts - Gibson 4" Exhaust Tip
Performance: Dynomax Bullet Muffler - Flowmonster High Flow Catalytic Converter - Chrome Intakes CAI - Superchips 3715 at 91 Octane - NGK V-Power Plugs
Tires/Wheels/Lift: 3" PA Body Lift - 2" T/S Lift - 33 X 11.5 X 16 Firestone Destination M/T Tires - MB Gunner 6 Gun metal gray 16X8 rims
Drivetrain: Rebuilt 545RFE Trans with Transgo Shift Kit - 4.56:1 R/P Motive gears - Auburn High Performance LSD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

qtipextra is offline  
post #9 of 9 Old 11-08-2009, 12:23 PM Thread Starter
qtipextra
^BIG D^
 
qtipextra's Avatar
 
Join Date: Oct 2005
Location: Idaho Falls
Posts: 2,283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Well I finally had some time to check under the dash. That "cam" thing is definitely the culprit, but I dont know how to fix it. It will try and rotate but, gets stuck and wont go any further, so goes back over to the default defrost spot. Even if I try and help it along, it gets a a certain point where I cant move it anymore.


Wetherdad, what did you use for lubrication, and where did you apply it? Did you disassemble the cover and spray it in there?

Thanks for all the help so far

"Big D" - SOM Feb '10
Black 2003 Dodge Durango Sport 4.7L 4X4 4.56:1 Auburn LSD

Interior: Double DIN Pioneer HU - 141.7 dB Sound System - Dash Mat - Blue L.E.D Interior Lighting - Blue Gauge Backlighting - Audiovox 2-Way Remote Start - 6 Gauge Cluster Swap
Exterior: Black 1 Piece DEPO headlights - 55W DDM 5000K HID 9007 BiXenon - Hella Optilux 2500 Driving lights - 55W DDM 5000K HID H3 - 3rd Brake light decal "BIG D" - Dodge Hitch/Cover - Dodge Logo on Tinted Tails - Stainless Steel Bar Grill Inserts - Gibson 4" Exhaust Tip
Performance: Dynomax Bullet Muffler - Flowmonster High Flow Catalytic Converter - Chrome Intakes CAI - Superchips 3715 at 91 Octane - NGK V-Power Plugs
Tires/Wheels/Lift: 3" PA Body Lift - 2" T/S Lift - 33 X 11.5 X 16 Firestone Destination M/T Tires - MB Gunner 6 Gun metal gray 16X8 rims
Drivetrain: Rebuilt 545RFE Trans with Transgo Shift Kit - 4.56:1 R/P Motive gears - Auburn High Performance LSD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

qtipextra is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page


    Forum Jump

    Similar Threads
    Thread Thread Starter Forum Replies Last Post
    Floor - Vent - Defrost selector Stick69 3G Dodge RAM - Interior/Exterior Talk 17 10-03-2007 10:25 PM
    AC Air Vent mode selector switch broke arp35 3G Dodge RAM - General Talk 13 02-12-2007 08:57 PM
    Hissing behind driver side of dash and vent selector problem chrisd0729 1G Dodge Durango General Talk 6 01-12-2007 06:18 AM
    1998 Stratus defogger vent suddenly changes to front vent Stratfan Dodge Stratus 1st Gen (95 - 00) 0 03-05-2006 11:01 AM
    Vent Selector Switch Stuck in Defrost! kickhams 2G Dodge Stratus - General Talk 0 05-28-2003 01:15 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

     
    For the best viewing experience please update your browser to Google Chrome