power loss.. is it a turbo issue??? - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Notices

Closed Thread
 
Thread Tools
post #1 of 1 Old 02-24-2016, 07:16 PM Thread Starter
adel19642004
Registered User
 
Join Date: Feb 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
power loss.. is it a turbo issue???

Hi All... I finally bought my first Sprinter, a 2006 with 193K on it... it used to be a DHL truck... I had my brother drive it down for me and here is the problem I am having.
When I turn the van on... it cranks right away and takes off great... shifting through the gears with plenty of power. When I stop at a stop light it is as if the turbo is not working... it shifted too quickly through the gears but no turbo boost. It will eventually get up to highway speeds as long as the road is relatively flat .EVERY time I turn it off an then on again it does the same thing. I, also have the ABS light on besides the engine light and every once in a while I feel a strong shudder... I can only assume that the brakes are some how grabbing. The rotors seem clean and smooth with no apparent ill effect from the shuddering.
I took the van to a shop for diag, they replaced the fuel filter and replaced the shifter (since apparently it had a hard code and the mechanic could not manually + or 1 the gears.) with shifting corrected they are charging me a small fortune to take things apart to check for leaks and cracks. Everything came back good and the last pressure test on one of the parts (I forget since he called me when I was driving) tested good with no cracks but it showed the presence of oil. The mechanic says that this points to the turbo as being bad. I read some posts about the EGR valve and the resonator but it kind of makes sense if the seals inside the turbo are leaking that it would have to rebuilt or replaced. BUT since I am a complete novice when it comes to diesel and especially turbo ones I decided to reach out to the group. Any ideas before I run out and express order a turbo tomorrow?
adel19642004 is offline  
Quick Reply
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to use most of our features, you must first register.
Please enter your desired User Name, your Email Address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
The registration process requires you to activate your membership by following a link in an E-Mail that will be sent to you immediately upon completing this form. You must enter a valid email address or you will not receive this activation code and you will NOT be registered. Your E-Mail address is NOT publicly available to anyone as policy.

AOL E-MAIL USERS: Please click HERE for important info pertaining to your e-mail address.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page


    Forum Jump

    Similar Threads
    Thread Thread Starter Forum Replies Last Post
    Issue with coolant loss JTREM 2G Dodge RAM - Drivetrain Talk 11 11-11-2014 03:27 PM
    2004 1500 3.7L oil loss issue Jnoland94 3G Dodge RAM - Drivetrain Talk 0 03-06-2014 09:01 PM
    slight power power loss with bog at take off Stickhemi 3G Dodge Ram Performance Talk 29 08-28-2010 06:51 PM
    Unexplained loss of power with 5.9 Turbo Diesel mgood777 3G Dodge RAM Diesel Talk 3 12-14-2008 10:26 AM
    power loss ramherder 2G Dodge RAM - General Talk 0 01-08-2008 12:20 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off

     
    For the best viewing experience please update your browser to Google Chrome