front end noise in my 2012 ram, 2000kms!!!! - Page 2 - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
Closed Thread
 
Thread Tools
#21 Old 10-12-2012, 12:25 PM
ORDODGE1500
Registered User
 
ORDODGE1500's Avatar
 
Join Date: Oct 2009
Location: Tangent
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Got the same noise the wife says it sounds like it is coming from the wheel well area by her feet and mine is mostly slow turns. The technician saw rub marks on wheel liner that looked like it was hitting the upper strut tower bolts. they put in a new liner and clips and havent really heard anything since. I started hearing it only a 1000 miles in and I have 2400 now. Still not 100% sure if they fixed it because it sounded like loose suspension to me as well.

2012 Ram 1500 Express in Deep Cherry/Hemi/Crew Cab/3.92 gears/LSD/Tow Package/Brake Controller/Sat Radio/Bed Liner/2" TC leveling kit/Toyo Open Country AT II's in 275/65-20/Century Cap/Icon Running Boards/35% tint(OR legal)
ORDODGE1500 is offline  
Sponsored Links
Advertisement
 
#22 Old 10-22-2012, 06:56 PM
revrx2
Registered User
 
Join Date: Oct 2012
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey Guys,

so this is what i would be looking at,

it is your tie rod ends, i know there was a recall but they are still shit!
i have a 2010 ram 1500 sport 4x4, the first set of tie rod ends had play at 20000 kms,but didnt get hem replaced till 34000, when i bought the truck from new i had a vibration in the gas pedal and could never find the cause, got the 2 outer tie rod ends changed under the recall and also 1 inner changed at the same time and the vibration was gone. prior to the recall comming out i noticed play in my tie rods so i had the truck looked at by a dealer due to a clunking noise in the front end and the play and then the recall came out. the recall was only for outer ends yet i had had a bad inner end also. so now i had a clunk in the front again and guess what another tie rod end, so i just got that tie rod end changed on the 27th of september and today guess what, i now have play in the other side again. so the front end of my truck is shit. my budy bought a truck same time as me (within a week) and he has had no issues with his front end, but i drove his truck when it was new and he did not have the same gas pedal vibration as i did.
also if you find play in the tie rod ends watch them because they get worse really fast!! also i would just like to note that this truck is only driven on smooth paved roads (wifes truck) and has never spent any time in the bush. i take my chevy in the bush! i just called dodge tonight and they said just keep getting the parts replaced as long as you can under warranty - THANKS ALOT, anyways i came on this forum to see if other people are getting thier tie rod ends replaced as much as me and i can see that there will be more. check your front ends and please post if you find anything. also there is no vibration or shaking noted in the steering wheel with the tie rod end play.
revrx2 is offline  
#23 Old 11-20-2012, 10:54 AM
2012Rooster
Registered User
 
Join Date: Oct 2012
Location: Fargo
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I took my truck into the Dodge Dealership for the front end noise, only 1400 miles on my pickup. They heard the clanking noise. Technician said everything looks solid underneath, couldnt figure out the problem.... He said another person brought a 2012 ram in for same issue and they replaced both his front shocks. This apparently did not fix the issue. Certified Dealership could not figure it out. I like the pickup look, but now am wondering if i should have kept my 2011 Silverado crew which was very solid in the suspension. Disappointed.
2012Rooster is offline  
#24 Old 11-20-2012, 08:26 PM
hemidogg
Dodge Tech
 
Join Date: Jul 2006
Location: Roxbury NJ
Posts: 1,609
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by 2012Rooster View Post
I took my truck into the Dodge Dealership for the front end noise, only 1400 miles on my pickup. They heard the clanking noise. Technician said everything looks solid underneath, couldnt figure out the problem.... He said another person brought a 2012 ram in for same issue and they replaced both his front shocks. This apparently did not fix the issue. Certified Dealership could not figure it out. I like the pickup look, but now am wondering if i should have kept my 2011 Silverado crew which was very solid in the suspension. Disappointed.
i have worked on a few of these in both cases i found the noise was comming from the lower radiator support on passanger side i just tighted up the body mount its mounted to and noise was gone,, if u open the hood and get a buddy to push up and down on the truck u can here the noise and watch the support move

2014 Dodge Challenger R/T Classic 6 Speed-Mine
2014 Dodge Challenger R/T Blacktop auto-Hers

2010 brillent black qc sport Sold
2013 Dodge Dart Rally 1.4 turbo Sold



Red Neck White Trash Blue Collar

hemidogg is offline  
#25 Old 11-20-2012, 09:09 PM
danimalhemi24
danimalhemi24
 
danimalhemi24's Avatar
 
Join Date: Nov 2004
Location: Pontiac
Posts: 822
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Back in July I would hear a faint grinding(metal on metal) sound only while cruising with the windows down. 2012 Ram sport with like 6k miles. Took it to the dealership and they said 2 techs drove it and couldn't hear any noises other than the sucking noise from my cai. I was like whatever, what I'm hearing is not my cai. So in an effort to do something, they said my brakes were dirty and they cleaned them up. I was certain that wouldn't take care it, but I agreed to drive it for a few days and see if the brake cleaning took care of it. Anyway, a few months passed and it was early September. Grinding sound getting worse and now a vibration in the brake pedal that was getting worse by the day. Took it back in and they replaced all 4 rotors. That took care of my problem, she runs smooth now. Drove me nuts for several months though!
danimalhemi24 is offline  
#26 Old 11-21-2012, 12:36 AM
moonboon
Registered User
 
Join Date: Nov 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by sighless View Post
i wont be taking my truck in until my first oil change.. and maybe then i'll find out whats causing the vibration through the gas pedal.
I would be interested in what they find out as well. My 4G was the only truck I test drove and right off the lot I noticed the gas pedal vibration. Figured it was normal but now reading these forums it's making me wonder.. Also a 2012 crew sport from Canada. Just turning over to 3000km now.
moonboon is offline  
#27 Old 12-29-2012, 12:36 PM
Bassfarmers
Registered User
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Have the same truck now have the noise in front of each week. Were you able to fix yours?
Bassfarmers is offline  
#28 Old 12-29-2012, 06:37 PM
Bassfarmers
Registered User
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Noisy front end 2012 dodge ram 4x4

Have had this truck 6 months new, one month ago started making noise same as yours around front passenger tire, now doing the same around the driver tire and is driving me nuts, dealership replaced front cv axle passenger side and gave it back to me. Noise still there and getting worse, now trucks seems to steer left and right on its own, any help on the noise in the front end?
Bassfarmers is offline  
#29 Old 12-29-2012, 06:47 PM
Bassfarmers
Registered User
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Have same problem with new truck, did you get yours fixed?
Bassfarmers is offline  
#30 Old 01-01-2013, 09:40 PM
ORDODGE1500
Registered User
 
ORDODGE1500's Avatar
 
Join Date: Oct 2009
Location: Tangent
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mine ended up being the the body mounts, the dealership loosened them up and torqued them down to proper specs and it hasn't made a sound since.

2012 Ram 1500 Express in Deep Cherry/Hemi/Crew Cab/3.92 gears/LSD/Tow Package/Brake Controller/Sat Radio/Bed Liner/2" TC leveling kit/Toyo Open Country AT II's in 275/65-20/Century Cap/Icon Running Boards/35% tint(OR legal)
ORDODGE1500 is offline  
#31 Old 03-11-2013, 12:58 PM
Safetyman16
Registered User
 
Join Date: Mar 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the exact same problem with my new truck. It took about 4the days for the service dept to figure out what it was. They ended up ordering and replacing the right front isolated, absorber and mount shock. It seemed to be the right fix, but the exact same noise came back exactly a month later. Here is the really strange part, yesterday I filled up with shell premium and I haven't heard the noise since. Im still skeptical, and I bet I will hear it again at the end of the week.

It has been very because it happened the day after I took the truck home.
Safetyman16 is offline  
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009-2012 Front Mount Receiver Hitch Curt 31374 ShawnQ For Sale - Truck Parts 0 06-04-2012 02:35 AM
2012 1500 chatter in front end razer 4G Dodge RAM - 4X4 Talk 14 05-25-2012 02:01 AM
Are the 2012 Ram 1500 front drivetrains differenet??? wyorat 4G Dodge RAM - 4X4 Talk 3 01-23-2012 11:57 PM
2012 RAM 1500 different front end??? wyorat 3G Dodge RAM - 4X4 Talk 1 01-14-2012 07:23 AM
2012 Dodge Journey, can the fold flat front passenger seat be ordered and installed? Treeman82 Dodge Journey Talk 2 12-02-2011 01:36 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome