idle issue, need help. - DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums
 HOME  FORUMS  GALLERY  GARAGE  TECH  CLASSIFIEDS  LINKS  MEMBER MAP  ARCHIVE  SPONSORS
INFO SITE HELP ARCADE TELL-A-FRIEND STAFF CONTACT US AUTO LOANS


DodgeTalk.com is the premier Dodge forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!
Go Back   DodgeTalk : Dodge Car Forums, Dodge Truck Forums and Ram Forums > Dodge Truck, SUV and Van Forums > Dodge Ram Truck 3rd Gen (02 08) Forums > 3G Dodge RAM - Drivetrain Talk

Closed Thread
 
Thread Tools

J.trevor123
 
  idle issue, need help. - Posted: 12-05-2012, 04:36 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #1

Okay I have a 2007 ram 5.7. About a month ago I changed my spark plugs, cleaned my throttle body , and had fluids changed. Anyways I noticed (dont believe it was right after these changes or have any corrilation with the changes) when i stop at a stop light for example my truck idling at its normal 600 rpm slowly drops to about 400 rpm then bumps back up to 600. Almost like my truck falls asleep and then realizes it needs to go back to 600 rpm. I notice at night it even effects my lights, for a split second when reving back up to 600rpm the lights dim.... Any clue what would cause this idling issue? by the way it does not do it everytime i am idling but often.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Sponsored Links
Advertisement
 

gtrwun
 
 Posted: 12-05-2012, 04:57 PM
gtrwun's Avatar
Registered User
Joined: Dec 2012
Posts: 19
City: Modesto
State: CA
Status: Offline
Post #2

What kind of plugs did you put in? Champion?
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-05-2012, 06:23 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #3

yes sir champion plugs. Gapped to correct dimension
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

orvtenn
 
 Posted: 12-05-2012, 08:05 PM
orvtenn's Avatar
+ Hemi Addict +
Joined: Apr 2010
Posts: 517
State: TN
Status: Offline
View This User's Gallery
Post #4

An EGR valve that's on its way out can do that
__________________
2004 1500 SLT RC/SB 4x4 Hemi 5.7
2006 Grand Caravan 3.3L
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-05-2012, 08:24 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #5

an egr valve huh. I put a brand new one in it a little over a year ago. I guess there is no way on knowing until it goes?
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

MoparAndy04
 
 Posted: 12-05-2012, 08:25 PM
MoparAndy04's Avatar
Registered User
Joined: Apr 2006
Posts: 1,032
City: Twin Cities
State: MN
Status: Offline
Post #6

Quote:
Originally Posted by orvtenn View Post
An EGR valve that's on its way out can do that
I can attest to that. It happened to me three or so times. Once while idling in stop and go traffic. And twice while coming to a stop at a stop sign. I just pulled the EGR, cleaned it out with some brake cleaner, and its been good ever since.
__________________


2014 Ram 1500 Express QC 4x4
5.7L Hemi, 8spd ZF Trans, 3.21 Posi, U-Connect 5.0
18" Magnaflow, BT Catch Can, K&N Drop In, Mopar Molded Splash Guards
Line-X Spray In Bedliner, Tonno Pro Lo-Roll Tonneau Cover

2004 Ram 1500 SLT QC SB 4x4 - Gone But Not Forgotten

View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-05-2012, 08:33 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #7

huh i guess i need to check it out. It does it almost everytime it idles
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

crasher76
 
 Posted: 12-05-2012, 10:27 PM
crasher76's Avatar
Im wired!!!
Joined: May 2009
Posts: 2,325
City: K-TOWN
State: WI
Status: Offline
Post #8

does your throttle blade have a little wiggle play in it??
__________________
Black 2003 QC SB SLT 4x4 Offroad 5.7L HEMI, Original Owner 3.92 LSD, 260 cam, 6.1 Rods/Springs, Home Ported/Polished Heads, Psc1, 04 Map sensor and Fuel pump assembly, Oil pressure guage, Amsoil, Champs, MSD 8.5MM Full length Wires, Transgo HD w/out resistor, Superchip, 180 T-Stat, K/N 77 Series, Ceramic Flowtech headers with Y-Pipe, Stage 8 locks, Ditched the cat, O2 sensor mod, Jack Rabbit bed cover, Sprayed bed liner, Big Mouth Grill-Black, Blackend Headlights/Tails, Silverstar ultras, Ditched all chrome, Custom 10's sub enclosure, Upgraded 160 amp alt, Window tint, Relocated purge valve, Energy suspension bushings, Rear spring clamps, Rebuilt front suspension, Ditched Sway Bar, Passport 8500 Radar Detector, Ditched the baby seat- kid wasnt mine, Cigarette burn in the seat mod, Debadged, Custom Rewired/Properly Grounded.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-06-2012, 06:01 AM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #9

on my throttle body? not that i know of. But i havent checked since i cleaned it. When i cleaned it, it did not.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

orvtenn
 
 Posted: 12-06-2012, 05:24 PM
orvtenn's Avatar
+ Hemi Addict +
Joined: Apr 2010
Posts: 517
State: TN
Status: Offline
View This User's Gallery
Post #10

Quote:
Originally Posted by J.trevor123 View Post
an egr valve huh. I put a brand new one in it a little over a year ago. I guess there is no way on knowing until it goes?
Correct. The plunger on the valve usually sticks but I have seen the hole on the block plugged full of carbon, if that's the case shoot some brake cleaner up in there, just wear eye protection - the splash back burns. On these trucks, they usually won't set a code right away. I ran mine for 3-4 months with it occasionally stalling or trying to stall at lights before it finally set a code for the EGR.
__________________
2004 1500 SLT RC/SB 4x4 Hemi 5.7
2006 Grand Caravan 3.3L
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-06-2012, 08:15 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #11

okay thanks alot, i took the egr out today and cleaned it. seemed to work. We will see with more driving.
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-07-2012, 06:30 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #12

okay i cleaned the egr valve and idle issue was not fixed. I replacved the egr valve and still not fixed. Dont know why it wont idle consistantly... Also i romoved my PCV Valve on my throttle body and it had a oil like substance on it... thats normal?
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-07-2012, 07:17 PM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #13

also notices it idles fine in park, but stopped in drive is not consistant
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

orvtenn
 
 Posted: 12-08-2012, 02:42 AM
orvtenn's Avatar
+ Hemi Addict +
Joined: Apr 2010
Posts: 517
State: TN
Status: Offline
View This User's Gallery
Post #14

I think they're some PCM software updates available for low idle speed if the EGR doesn't fix the problem.
__________________
2004 1500 SLT RC/SB 4x4 Hemi 5.7
2006 Grand Caravan 3.3L
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote

J.trevor123
 
 Posted: 12-08-2012, 11:42 AM
Registered User
Joined: Oct 2012
Posts: 9
State: TX
Status: Offline
Post #15

I guess I would need to take it to the dealership for updates?
View Public ProfileSend a private message to %1$sSend email to %1$sFind all posts by %1$sAdd %1$s to Your Buddy List Reply Reply With Quote
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help with idle issue hpauto 3G Dodge Ram Performance Talk 7 06-26-2012 06:31 PM
idle issue Challopy 3G Dodge RAM - Drivetrain Talk 0 04-09-2012 02:38 PM
Idle issue gt40girl Dodge Magnum - Performance Talk 0 04-16-2011 06:59 PM
Idle issue Machzzzz1 3G Dodge RAM - General Talk 32 03-16-2011 08:23 AM
idle issue syfir Dodge Neon - General Talk 5 10-04-2010 03:05 PM



All times are GMT -5. The time now is 07:50 AM.





Privacy Statement